No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MAC Authentication for Local Users

Example for Configuring MAC Authentication for Local Users

Service Requirements

Dumb terminals (such as printers) in the physical access control department cannot have an authentication client installed. To meet the enterprise's security requirements, configure MAC address authentication on the AC and use the local authentication mode to authenticate identities of dumb terminals.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: tunnel forwarding
  • Authentication mode: MAC authentication
  • Security policy:open
Figure 5-35 Networking for configuring MAC authentication for local users

Data Planning

Table 5-41 AC data planning
Item Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateway address of STAs is 10.23.101.2.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for STAs

10.23.101.3-10.23.101.254/24

AC's source interface

VLANIF 100:10.23.100.1/24

AP group

  • Name: ap-group1

  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: CN

SSID profile

  • Name: wlan-net

  • SSID name: wlan-net

Security profile

  • Name: wlan-net

  • Security policy: open

Local authentication parameters

  • Name of the local authentication scheme: wlan-net
  • User name and password of the local user: 0011-2233-4455 and guest@123, respectively, which must be consistent with those in the MAC access profile
  • Access type of the local user: MAC
MAC access profile
  • Name: wlan-net
  • User name and password for MAC address authentication: A MAC address is used as the user name and the password is guest@123, which must be consistent with those in the local authentication parameters

Authentication profile

  • Name: wlan-net

  • Referenced profiles: MAC access profile wlan-net and authentication scheme wlan-net

VAP profile

  • Name: wlan-net

  • Forwarding mode: tunnel forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net, security profile wlan-net and Authentication profile wlan-net

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure system parameters for the AC.
  3. Select Config Wizard to configure the AP to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC. When configuring a security policy, select MAC address authentication and local authentication. When adding a local user, ensure that the user name is the same as the MAC address of the user, and the password is the same as that configured in the MAC access profile. Configure the planned password in the MAC access profile.
  5. Complete service verification.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 and GE0/0/2 on SwitchB (aggregation switch) to VLAN 100, and GE0/0/2 and GE0/0/3 to VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure a DHCP server to assign IP addresses to STAs and specify the gateway for the STAs.

    # On SwitchB, configure VLANIF 101 to assign IP addresses to STAs and set the default gateway address of STAs to 10.23.101.2.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 101 (service VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configure network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24, DHCP status to ON, DHCP type to Interface address pool.
      NOTE:
      Configure the DNS server address as required.


      # Click OK. An address pool for VLANIF 100 is configured.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Configure the default route and set its next hop address to 10.23.101.2.



      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Open (applicable to personal networks).

    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  6. Configure MAC authentication for local users.
    1. Create the authentication profile wlan-net.

      # Choose Configuration > AP Config > AP Group. The AP Group page is displayed.

      # Click AP group ap-group1. The AP group configuration page is displayed.

      # Choose VAP Configuration > wlan-net > Authentication Profile. The Authentication Profile page is displayed.

      # Click Create. On the Create Authentication Profile page that is displayed, enter the profile name wlan-net and click OK. The authentication profile configuration page is displayed.

      # Set Access mode to MAC authentication and Authentication mode to Local authentication.

      # Click Apply. In the dialog box that is displayed, click OK.

    2. Configure the MAC access profile wlan-net.

      # Click in front of Authentication Profile. Under it, click MAC Authentication. The MAC Authentication Profile page is displayed.

      # Click Create. On the Create MAC Authentication Profile page that is displayed, enter the profile name wlan-net and click OK. On the MAC authentication profile configuration page that is displayed, configure the user name format for MAC address authentication.
      NOTE:
      The user name and password used for MAC address authentication must be the same as those configured for local authentication.


      # Click Apply. In the dialog box that is displayed, click OK.

    3. Configure the local authentication scheme wlan-net.

      # Click in front of Authentication Profile. Under it, click Local Authentication. The Local Authentication page is displayed.

      # Click Manage. The Create Local User page is displayed.

      # Click Create. In the dialog box that is displayed, enter the user name and password.
      NOTE:
      The local user name and password must be the same as those in the MAC authentication profile.


      # Click OK.Click Close.Click Apply.

  7. Verify the configuration.
    1. The STAs automatically access the WLAN with the SSID wlan-net.
    2. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90944

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next