No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Interface Management

CloudEngine 12800 and 12800E V200R003C00

This document describes the interface management configuration, including basic interface configuration, Ethernet interface configuration, and logical interface configuration.

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Ethernet Layer 3 Sub-interfaces to Implement Inter-VLAN Communication

Example for Configuring Ethernet Layer 3 Sub-interfaces to Implement Inter-VLAN Communication

Networking Requirements

As shown in Figure 3-2, PC1 and PC2 belong to VLAN 10 and VLAN 20 respectively and are on different network segments. They connect to a Layer 3 switch SwitchB through a Layer 2 switch SwitchA. It is required that physical interface resources be saved and PC1 and PC2 communicate through a Layer 3 physical interface GE1/0/4 on SwitchB.

Figure 3-2 Networking diagram for configuring Ethernet Layer 3 sub-interfaces to implement inter-VLAN communication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add interfaces on SwitchA to VLANs.

  2. Switch a Layer 2 Ethernet interface on SwitchB to Layer 3 mode. Before creating Layer 3 sub-interfaces on an Ethernet interface, switch the Ethernet interface to Layer 3 mode first.

  3. Create Layer 3 sub-interfaces on SwitchB as gateway interfaces for network segments to implement inter-VLAN communication.

Procedure

  1. On SwitchA, create VLAN 10 and VLAN 20, and add GE1/0/1 to VLAN 10, GE1/0/2 to VLAN 20, and GE1/0/3 to VLAN 10 and VLAN 20.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20
    [*SwitchA] commit
    [~SwitchA] interface ge 1/0/1
    [~SwitchA-GE1/0/1] port default vlan 10
    [*SwitchA-GE1/0/1] quit
    [*SwitchA] interface ge 1/0/2
    [*SwitchA-GE1/0/2] port default vlan 20
    [*SwitchA-GE1/0/2] quit
    [*SwitchA] interface ge 1/0/3
    [*SwitchA-GE1/0/3] port link-type trunk
    [*SwitchA-GE1/0/3] port trunk allow-pass vlan 10 20
    [*SwitchA-GE1/0/3] quit
    [*SwitchA] commit

  2. On SwitchB, switch GE1/0/4 to Layer 3 mode.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] interface ge 1/0/4
    [~SwitchB-GE1/0/4] undo portswitch
    [*SwitchB-GE1/0/4] quit
    [*SwitchB] commit
    

  3. On SwitchB, create Layer 3 sub-interfaces GE1/0/4.10 and GE1/0/4.20 and use them as the gateway interfaces for network segments 10.10.10.0/24 and 10.20.20.0/24 respectively. Assign IP addresses to the Layer 3 sub-interfaces and configure the Layer 3 sub-interfaces to terminate single-tagged packets.

    [~SwitchB] interface ge 1/0/4.10
    [*SwitchB-GE1/0/4.10] ip address 10.10.10.10 24
    [*SwitchB-GE1/0/4.10] dot1q termination vid 10
    [*SwitchB-GE1/0/4.10] quit
    [*SwitchB] interface ge 1/0/4.20
    [*SwitchB-GE1/0/4.20] ip address 10.20.20.20 24
    [*SwitchB-GE1/0/4.20] dot1q termination vid 20
    [*SwitchB-GE1/0/4.20] quit
    [*SwitchB-GE1/0/4] commit

  4. Verify the configuration.

    # After the configuration is complete, perform ping operations on PC1 and PC2. PC1 and PC2 can communicate with each other.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface GE1/0/1
     port default vlan 10
    #
    interface GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    interface GE1/0/4
     undo portswitch
    #
    interface GE1/0/4.10
     ip address 10.10.10.10 255.255.255.0
     dot1q termination vid 10
    #
    interface GE1/0/4.20
     ip address 10.20.20.20 255.255.255.0
     dot1q termination vid 20
    #
    return
Translation
Download
Updated: 2019-05-05

Document ID: EDOC1100004195

Views: 18654

Downloads: 37

Average rating:
This Document Applies to these Products

Related Version

Related Documents

Share
Previous Next