No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VXLAN

CloudEngine 12800 and 12800E V200R003C00

This document describes the configurations of VXLAN.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Multicast Replication Mode for Forwarding BUM Packets on a VXLAN Network

Example for Configuring the Multicast Replication Mode for Forwarding BUM Packets on a VXLAN Network

Networking Requirements

As shown in Figure 12-19, the enterprise has its own VMs in different data centers. All the servers where the VMs reside belong to VLAN 10. VXLAN tunnels are required for communication between the VMs. Device 1 and Device 3 serve as Layer 2 VXLAN gateways, Device 2 serves a Layer 3 VXLAN gateway, and Device 4 is a non-gateway device on the VXLAN network. Layer 2 gateway forwarding is required for communication between VMs. Layer 3 gateway forwarding is required when a VM needs to access the Internet.

To reduce traffic floods caused by the forwarding of BUM packets, you can configure the multicast replication mode. Device 4 can serve as a static RP.

Figure 12-19 Networking diagram for configuring the multicast replication mode for forwarding BUM packets on a VXLAN network

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure a routing protocol on each device to allow them to communicate at Layer 3.

  2. Configure service access points on Device 1 and Device 3 to distinguish service flows.

  3. Configure VXLAN tunnels on Device 1, Device 2, and Device 3.

  4. Configure a Layer 3 VXLAN gateway on Device 2 so that VMs can access the Internet.

  5. Configure PIM-SM on each device and configure Device 4 as a static RP.

  6. Configure multicast replication on Device 1, Device 2, and Device 3.

Data Planning

To complete the configuration, you need the following data:

  • VLAN ID of the VMs (10)

  • IP addresses of interfaces connecting devices

  • Internal Gateway Protocol (IGP) (OSPF)

  • BD ID (10)

  • VNI ID of the VXLAN ID (100)

  • EVPN instance RDs (11:1, 12:1, and 13:1) and RTs (1:1)

  • Multicast replication address of VNI 100 (225.0.0.1)

Precautions

For the CE12800, in addition to the configuration in the procedure, you may also need to run the following commands based on actual requirements:
  • Run the assign forward nvo3 service extend enable command in the system view to enable the NVO3 service extension function.

    NOTE:

    By default, the NVO3 service extension function is disabled on the device. After the NVO3 service is deployed on a device, there is a high probability that other ACL-consuming services such as MQC, simplified ACL, traffic policing, BD traffic statistics collection, and DHCP fail to be configured on the device. You can enable the NVO3 ACL extension function to lower the configuration failure probability of EC (except the CE-L48GT-EC and CE-L48GS-EC cards), ED, EF, and EG series cards.

  • Run the assign forward nvo3 f-linecard compatibility enable command in the system view to ensure that VXLAN traffic can be forwarded when the card interoperability mode is non-enhanced mode.

    NOTE:

    If VXLAN traffic is forwarded between cards when the card interoperability mode is non-enhanced mode, the VXLAN traffic may fail to be forwarded. To use the VXLAN function, you must configure the assign forward nvo3 f-linecard compatibility enable command when the card interoperability mode is non-enhanced mode.

VXLAN-related constraints are described in the procedure. To obtain more constraint information, see Licensing Requirements and Limitations for VXLANs.

Procedure

  1. Assign an IP address to each interface.

    Configure Interface IP addresses based on Figure 12-19.

  2. Establish VXLAN tunnels using BGP EVPN.

    For configuration methods, see Example for Configuring VXLAN with Centralized Gateways in BGP EVPN Mode; for configuration details, see Configuration Files.

  3. Configure PIM-SM on each device and configure Device 4 as a static RP.

    # Configure Device 1.
    [~Device1] multicast routing-enable
    [*Device1] pim
    [*Device1-pim] static-rp 4.4.4.4
    [*Device1-pim] quit
    [*Device1] interface 10ge 1/0/1
    [*Device1-10GE1/0/1] pim sm
    [*Device1-10GE1/0/1] quit
    [*Device1] commit
    
    # Configure Device 2.
    [~Device2] multicast routing-enable
    [*Device2] pim
    [*Device2-pim] static-rp 4.4.4.4
    [*Device2-pim] quit
    [*Device2] interface 10ge 1/0/1
    [*Device2-10GE1/0/1] pim sm
    [*Device2-10GE1/0/1] quit
    [*Device2] commit
    # Configure Device 3.
    [~Device3] multicast routing-enable
    [*Device3] pim
    [*Device3-pim] static-rp 4.4.4.4
    [*Device3-pim] quit
    [*Device3] interface 10ge 1/0/1
    [*Device3-10GE1/0/1] pim sm
    [*Device3-10GE1/0/1] quit
    [*Device3] commit
    
    # Configure Device 4.
    [~Device4] multicast routing-enable
    [*Device4] pim
    [*Device4-pim] static-rp 4.4.4.4
    [*Device4-pim] quit
    [*Device4] interface 10ge 1/0/1
    [*Device4-10GE1/0/1] pim sm
    [*Device4-10GE1/0/1] quit
    [*Device4] interface 10ge 1/0/2
    [*Device4-10GE1/0/2] pim sm
    [*Device4-10GE1/0/2] quit
    [*Device4] interface 10ge 1/0/3
    [*Device4-10GE1/0/3] pim sm
    [*Device4-10GE1/0/3] quit
    [*Device4] commit

  4. Configure multicast replication on Device 1, Device 2, and Device 3.

    # Configure Device 1.
    [~Device1] interface nve 1
    [*Device1-Nve1] vni 100 mcast-group 225.0.0.1
    [*Device1-Nve1] quit
    [*Device1] commit
    # Configure Device 2.
    [~Device2] interface nve 1
    [*Device2-Nve1] vni 100 mcast-group 225.0.0.1
    [*Device2-Nve1] quit
    [*Device2] commit
    # Configure Device 3.
    [~Device3] interface nve 1
    [*Device3-Nve1] vni 100 mcast-group 225.0.0.1
    [*Device3-Nve1] quit
    [*Device3] commit

  5. Verify the configuration.

    After completing the configurations, run the display vxlan tunnel command on Device 1, Device 2, and Device 3 respectively to view information on VXLAN tunnels, including the VXLAN tunnels whose destination address is a multicast replication address. You can find that all VXLAN tunnels are in the Up state. The following example uses the command output on Device 1.

    [~Device1] display vxlan tunnel
    Number of vxlan tunnel : 3
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531845  1.1.1.1               2.2.2.2               up     dynamic  00:10:17
    4026531846  1.1.1.1               3.3.3.3               up     dynamic  00:10:13
    4026531847  1.1.1.1               225.0.0.1             up     static   00:07:56

    After completing the configurations, run the display vxlan vni 100 verbose command on Device 1, Device 2, and Device 3 respectively to view detailed configurations of the VXLAN whose VNI is 100 and BUM forwarding mode is multicast replication. The following example uses the command output on Device 1.

    [~Device1] display vxlan vni 100 verbose
        BD ID                  : 10
        State                  : up
        NVE                    : 64
        Source Address         : 1.1.1.1
        Source IPv6 Address    : -
        UDP Port               : 4789
        BUM Mode               : multicast replication
        Group Address          : 225.0.0.1

Configuration Files

  • Device 1 configuration file

    #
    sysname Device1
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    bridge-domain 10
     vxlan vni 100
     evpn 
      route-distinguisher 11:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1 
     vni 100 head-end peer-list protocol bgp
     vni 100 mcast-group 225.0.0.1
    #               
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
    #
    ospf 1          
     area 0.0.0.0   
      network 1.1.1.1 0.0.0.0
      network 10.1.0.0 0.0.255.255
    #               
    pim             
     static-rp 4.4.4.4
    #
    return
  • Device 2 configuration file

    #
    sysname Device2
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    bridge-domain 10
     vxlan vni 100
     evpn 
      route-distinguisher 12:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface Vbdif10
     ip address 192.168.10.1 255.255.255.0
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2 
     vni 100 head-end peer-list protocol bgp
     vni 100 mcast-group 225.0.0.1
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
    #
    ospf 1          
     area 0.0.0.0   
      network 2.2.2.2 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #               
    pim             
     static-rp 4.4.4.4
    #
    return
  • Device 3 configuration file

    #
    sysname Device3
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    bridge-domain 10
     vxlan vni 100
     evpn 
      route-distinguisher 13:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3 
     vni 100 head-end peer-list protocol bgp
     vni 100 mcast-group 225.0.0.1
    #               
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
    # 
    ospf 1          
     area 0.0.0.0   
      network 3.3.3.3 0.0.0.0
      network 10.1.3.0 0.0.0.255
    #               
    pim             
     static-rp 4.4.4.4
    #
    return
  • Device 4 configuration file

    #
    sysname Device4
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1          
     area 0.0.0.0   
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #               
    pim             
     static-rp 4.4.4.4
    #
    return
Translation
Download
Updated: 2019-05-05

Document ID: EDOC1100004207

Views: 24805

Downloads: 65

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next