No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VXLAN

CloudEngine 12800 and 12800E V200R003C00

This document describes the configurations of VXLAN.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Differentiated Services Using VXLAN QoS

Example for Configuring Differentiated Services Using VXLAN QoS

Networking Requirements

In Figure 12-20, the server accesses the VXLAN network in dual-homed M-LAG mode. VM1 and VM2 on the server bear different services. Traffic is transmitted to the VXLAN network through different Layer 2 sub-interfaces. The 802.1p priorities of packets from VM1 and VM2 are 0. Users want to perform differentiated services on VM1 and VM2 to make the service level of VM1 higher than that of VM2 when packets from VM1 and VM2 are forwarded on the VXLAN network, ensuring low-latency requirements of VM1 services.

Figure 12-20 VXLAN QoS configuration networking diagram

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure a VXLAN network on Leaf1, Leaf2, and Spine1 to implement VXLAN network communication.
  2. Configure an M-LAG on Leaf1 and Leaf2 to implement dual-homed access of the server.
  3. Create DiffServ domains on Leaf1 and Leaf2, map the 802.1p priority of VM1 to service level AF4, map the 802.1p priority of VM2 to service level AF2, and apply the mappings to Layer 2 sub-interfaces to implement differentiated services.

Procedure

  1. Configure a VXLAN network on Leaf1, Leaf2, and Spine1.

    In this example, a VXLAN centralized gateway is deployed in static mode. For detailed configurations, see Configuration Files.

  2. Configure an M-LAG on Leaf1 and Leaf2.

    For details about how to configure an M-LAG in a centralized gateway scenario,see Configuration Files

  3. Create DiffServ domains on Leaf1 and Leaf2 and bind the DiffServ domains to Layer 2 sub-interfaces.

    # Create DiffServ domains ds1 and ds2 and map 802.1p priorities of packets from VM1 and VM2 to corresponding service levels. The following uses Leaf1 as an example. Configurations of Leaf2 are similar to those of Leaf1 and are not provided here.

    [~Leaf1] diffserv domain ds1
    [*Leaf1-dsdomain-ds1] 8021p-inbound 0 phb af4 green
    [*Leaf1-dsdomain-ds1] quit
    [*Leaf1] diffserv domain ds2
    [*Leaf1-dsdomain-ds2] 8021p-inbound 0 phb af2 green
    [*Leaf1-dsdomain-ds2] quit
    [*Leaf1] commit
    

    # Bind DiffServ domains ds1 and ds2 to Layer 2 sub-interfaces respectively. (Layer 2 sub-interfaces corresponding to VM1 and VM2 are Eth-Trunk10.1 and Eth-Trunk10.2, respectively.) The following uses Leaf1 as an example. Configurations of Leaf2 are similar to those of Leaf1 and are not provided here.

    [~Leaf1] interface eth-trunk10.1 mode l2
    [~Leaf1-Eth-Trunk10.1] trust upstream ds1
    [*Leaf1-Eth-Trunk10.1] quit
    [*Leaf1] interface eth-trunk10.2 mode l2
    [*Leaf1-Eth-Trunk10.2] trust upstream ds2
    [*Leaf1-Eth-Trunk10.2] quit
    [*Leaf1] commit
    

  4. Verify the configuration.

    # Check queue statistics collected on the outbound interface. Packets are mapped to different queues. The following uses Leaf1 as an example.

    [~Leaf1] display qos queue statistics interface 10ge 1/0/1
     Queue   CIR/PIR              Passed     Pass Rate             Dropped     Drop Rate  Drop Time
              (kbps)     (Packets/Bytes)     (pps/bps)     (Packets/Bytes)     (pps/bps)
     ----------------------------------------------------------------------------------------------
         0         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
         1         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
         2         0            11295086         17516                   0             0          -
            10000000           114688668      14573986                   0             0          
     ----------------------------------------------------------------------------------------------
         3         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
         4         0            11511125         19563                   0             0          -
            10000000           112653485      15352321                   0             0          
     ----------------------------------------------------------------------------------------------
         5         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
         6         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
         7         0                   0             0                   0             0          -
            10000000                   0             0                   0             0          
     ----------------------------------------------------------------------------------------------
    

Configuration Files

  • Leaf1 configuration file

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable   //This step is required only for the CE12800.
    #
    dfs-group 1
     source ip 10.3.3.3
    #
    vlan batch 10 20
    #
    stp mode rstp
    stp v-stp enable
    #
    diffserv domain ds1
     8021p-inbound 0 phb af4 green
    #
    diffserv domain ds2
     8021p-inbound 0 phb af2 green
    #
    bridge-domain 10
     vxlan vni 5010
    #
    bridge-domain 20
     vxlan vni 5020
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
     trust upstream ds1
    #
    interface Eth-Trunk10.2 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
     trust upstream ds2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
    #
    interface LoopBack2
     ip address 10.3.3.3 255.255.255.255
    #
    interface Nve1
     source 10.2.2.2
     vni 5010 head-end peer-list 10.1.1.1
     vni 5020 head-end peer-list 10.1.1.1
     mac-address 0000-5e00-0101
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • Leaf2 configuration file

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable   //This step is required only for the CE12800.
    #
    dfs-group 1
     source ip 10.4.4.4
    #
    vlan batch 10 20
    #
    stp mode rstp
    stp v-stp enable
    #
    diffserv domain ds1
     8021p-inbound 0 phb af4 green
    #
    diffserv domain ds2
     8021p-inbound 0 phb af2 green
    #
    bridge-domain 10
     vxlan vni 5010
    #
    bridge-domain 20
     vxlan vni 5020
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
     trust upstream ds1
    #
    interface Eth-Trunk10.2 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
     trust upstream ds2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
    #
    interface LoopBack2
     ip address 10.4.4.4 255.255.255.255
    #
    interface Nve1
     source 10.2.2.2
     vni 5010 head-end peer-list 10.1.1.1
     vni 5020 head-end peer-list 10.1.1.1
     mac-address 0000-5e00-0101
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.4.4.4 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    return
  • Spine1 configuration file

    #
    sysname Spine1
    #
    assign forward nvo3 acl extend enable   //This step is required only for the CE12800.
    #
    bridge-domain 10
     vxlan vni 5010
    #
    bridge-domain 20
     vxlan vni 5020
    #
    interface Vbdif10
     ip address 192.168.10.1 255.255.255.0
    #
    interface Vbdif20
     ip address 192.168.20.1 255.255.255.0
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface LoopBack1
     ip address 10.1.1.1 255.255.255.255
    #
    interface Nve1
     source 10.1.1.1
     vni 5010 head-end peer-list 10.2.2.2
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-05

Document ID: EDOC1100004207

Views: 25157

Downloads: 65

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next