No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - DCN and Server Management

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Trill, FCoE, DCB, and NLB Server Cluster Association.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Deploying M-LAG on a Dual-Homing TRILL Network Through V-STP

Example for Deploying M-LAG on a Dual-Homing TRILL Network Through V-STP

Networking Requirements

As shown in Figure 1-32, the switch connects to a TRILL network. The requirements are as follows:

  • When one access link fails, traffic can be fast switched to the other link to ensure reliability.
  • The load balancing mode can be used to forward traffic to make full use of bandwidth and ensure that two links are in active state.
Figure 1-32 Dual homing to a TRILL network through M-LAG

You can configure M-LAG and connect the device to the TRILL network through two RBs. M-LAG is configured between the device and RBs to enhance device-level and link-level reliability. RB1 and RB2 use the same pseudo nickname to form a logical device. On RBs, the DFS group is associated with M-LAG and TRILL. M-LAG and TRILL ensure that service packets are correctly forwarded.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic TRILL functions on RBs to implement interworking of the TRILL network.

  2. Configure M-LAG on RB1 and RB2 so that the device is dual-homed to RB1 and RB2.

  3. On RB1 and RB2, associate uplink and downlink interfaces with the Monitor Link group to prevent a user-side traffic forwarding failure and traffic loss due to the uplink fault.

Procedure

  1. Configure basic TRILL functions on RBs.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] vlan batch 100
    [*RB1] trill
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100
    [*RB1-trill] carrier-vlan 2
    [*RB1-trill] ce-vlan 100
    [*RB1-trill] quit
    [*RB1] interface 10ge 1/0/1
    [*RB1-10GE1/0/1] port link-type trunk
    [*RB1-10GE1/0/1] trill enable
    [*RB1-10GE1/0/1] quit
    [*RB1] commit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan batch 100
    [*RB2] trill
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] carrier-vlan 2
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] quit
    [*RB2] interface 10ge 1/0/1
    [*RB2-10GE1/0/1] port link-type trunk
    [*RB2-10GE1/0/1] trill enable
    [*RB2-10GE1/0/1] quit
    [*RB2] commit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] trill
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 400
    [*RB3-trill] carrier-vlan 2
    [*RB3-trill] quit
    [*RB3] interface 10ge 1/0/1
    [*RB3-10GE1/0/1] port link-type trunk
    [*RB3-10GE1/0/1] trill enable
    [*RB3-10GE1/0/1] quit
    [*RB3] interface 10ge 1/0/2
    [*RB3-10GE1/0/2] port link-type trunk
    [*RB3-10GE1/0/2] trill enable
    [*RB3-10GE1/0/2] quit
    [*RB3] commit

    After the configuration is complete, run the display trill peer command to check TRILL peer information.

    [~RB1] display trill peer
                                                                                    
    Peer information for TRILL
    --------------------------------------------------------------------------------
    
    Total Peer(s): 1                                                                
    
    System ID/Trill Name  Interface      Circuit ID        State  HoldTime Type  PRI
    --------------------------------------------------------------------------------
    0000.0000.3333        10GE1/0/1      0000.0000.3333.02 Report       7s L1     64
                                                                                    

  2. On the switch, bind the uplink interface to an Eth-Trunk.

    # Configure the switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 100
    [*Switch] interface eth-trunk 20
    [*Switch-Eth-Trunk20] mode lacp-static
    [*Switch-Eth-Trunk20] port link-type trunk
    [*Switch-Eth-Trunk20] port trunk allow-pass vlan 100
    [*Switch-Eth-Trunk20] trunkport 10ge 1/0/1 to 1/0/4
    [*Switch-Eth-Trunk20] quit
    [*Switch] commit

  3. Configure the V-STP, DFS group, peer-link, and M-LAG interface on RB1 and RB2.

    # Configure RB1.

    [~RB1] stp mode rstp
    [*RB1] stp v-stp enable
    [*RB1] dfs-group 1
    [*RB1-dfs-group-1] source nickname 100
    [*RB1-dfs-group-1] pseudo-nickname 500
    [*RB1-dfs-group-1] priority 150
    [*RB1-dfs-group-1] quit
    [*RB1] interface eth-trunk 1
    [*RB1-Eth-Trunk1] trunkport 10ge 1/0/4
    [*RB1-Eth-Trunk1] trunkport 10ge 1/0/5
    [*RB1-Eth-Trunk1] mode lacp-static
    [*RB1-Eth-Trunk1] peer-link 1
    [*RB1-Eth-Trunk1] port vlan exclude 2
    [*RB1-Eth-Trunk1] quit
    [*RB1] interface eth-trunk 10
    [*RB1-Eth-Trunk10] mode lacp-static
    [*RB1-Eth-Trunk10] port link-type trunk
    [*RB1-Eth-Trunk10] port trunk allow-pass vlan 100
    [*RB1-Eth-Trunk10] trunkport 10ge 1/0/2
    [*RB1-Eth-Trunk10] trunkport 10ge 1/0/3
    [*RB1-Eth-Trunk10] dfs-group 1 m-lag 1
    [*RB1-Eth-Trunk10] quit
    [*RB1] commit

    # Configure RB2.

    [~RB2] stp mode rstp
    [*RB2] stp v-stp enable
    [*RB2] dfs-group 1
    [*RB2-dfs-group-1] source nickname 200
    [*RB2-dfs-group-1] pseudo-nickname 500
    [*RB2-dfs-group-1] priority 120
    [*RB2-dfs-group-1] quit
    [*RB2] interface eth-trunk 1
    [*RB2-Eth-Trunk1] trunkport 10ge 1/0/4
    [*RB2-Eth-Trunk1] trunkport 10ge 1/0/5
    [*RB2-Eth-Trunk1] mode lacp-static
    [*RB2-Eth-Trunk1] peer-link 1
    [*RB2-Eth-Trunk1] port vlan exclude 2
    [*RB2-Eth-Trunk1] quit
    [*RB2] interface eth-trunk 10
    [*RB2-Eth-Trunk10] mode lacp-static
    [*RB2-Eth-Trunk10] port link-type trunk
    [*RB2-Eth-Trunk10] port trunk allow-pass vlan 100
    [*RB2-Eth-Trunk10] trunkport 10ge 1/0/2
    [*RB2-Eth-Trunk10] trunkport 10ge 1/0/3
    [*RB2-Eth-Trunk10] dfs-group 1 m-lag 1
    [*RB2-Eth-Trunk10] quit
    [*RB2] commit

  4. On RB1 and RB2, associate uplink and downlink interfaces with the Monitor Link group.

    # Configure RB1.
    [~RB1] monitor-link group 1
    [*RB1-mtlk-group1] port 10ge 1/0/1 uplink
    [*RB1-mtlk-group1] port eth-trunk 10 downlink 1
    [*RB1-mtlk-group1] quit
    [*RB1] commit
    # Configure RB2.
    [~RB2] monitor-link group 1
    [*RB2-mtlk-group1] port 10ge 1/0/1 uplink
    [*RB2-mtlk-group1] port eth-trunk 10 downlink 1
    [*RB2-mtlk-group1] quit
    [*RB2] commit

  5. Verify the configuration.

    Run the display dfs-group command to check M-LAG information.

    # Check information about the M-LAG with DFS group 1.

    [~RB1] display dfs-group 1 m-lag
    *                : Local node
    Heart beat state : OK
    Node 1 *
      Dfs-Group ID   : 1
      Priority       : 150
      Address        : nickname 100
      State          : Master
      Causation      : -
      System ID      : 0025-9e95-7c31
      SysName        : RB1
      Version        : V100R006C00
      Device Type    : CE6850EI
    Node 2
      Dfs-Group ID   : 1
      Priority       : 120
      Address        : nickname 200
      State          : Backup
      Causation      : -
      System ID      : 0025-9e95-7c11
      SysName        : RB2
      Version        : V100R006C00
      Device Type    : CE6850EI

    # Check M-LAG information on RB1.

    [~RB1] display dfs-group 1 node 1 m-lag brief
    * - Local node
    
    M-Lag ID     Interface      Port State    Status
           1     Eth-Trunk 10   Up            active(*)-active

    # Check M-LAG information on RB2.

    [~RB1] display dfs-group 1 node 2 m-lag brief
    * - Local node
    
    M-Lag ID     Interface      Port State    Status
           1     Eth-Trunk 10   Up            active-active(*)

    In the preceding information, the value of Heart beat state is OK, indicating that the heartbeat is normal. RB1 is used as Node 1, its priority is 150, and its status is Master. RB2 is used as Node 2, its priority is 120, and its status is Backup. The value of Causation is -, the values of Port State of Node 1 and Node 2 are both Up, and the M-LAG status of both Node 1 and Node 2 is active, indicating that the M-LAG configuration is correct.

Configuration Files

  • RB1 configuration file

    #
    sysname RB1
    #
    dfs-group 1
     priority 150
     source nickname 100
     pseudo-nickname 500
    #
    vlan batch 100
    #
    stp mode rstp
    stp v-stp enable
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 2
     ce-vlan 100
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
     port vlan exclude 2
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port Eth-Trunk10 downlink 1
    #
    return
    
  • RB2 configuration file

    #
    sysname RB2
    #
    dfs-group 1
     priority 120
     source nickname 200
     pseudo-nickname 500
    #
    vlan batch 100
    #
    stp mode rstp
    stp v-stp enable
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 2
     ce-vlan 100
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
     port vlan exclude 2
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port Eth-Trunk10 downlink 1
    #
    return
    
  • RB3 configuration file

    #
    sysname RB3
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 400
     carrier-vlan 2
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    return
    
  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 100
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 100
     mode lacp-static
    #
    interface 10GE1/0/1
     eth-trunk 20
    #
    interface 10GE1/0/2
     eth-trunk 20
    #
    interface 10GE1/0/3
     eth-trunk 20
    #
    interface 10GE1/0/4
     eth-trunk 20
    #
    return
    
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004349

Views: 30482

Downloads: 120

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next