No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - DCN and Server Management

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Trill, FCoE, DCB, and NLB Server Cluster Association.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the TRILL Gateway Function

Example for Configuring the TRILL Gateway Function

Networking Requirements

In Figure 1-33, a CE device is single-homed to a TRILL network and needs to access external networks through Layer 3 forwarding. To support this access requirement, a gateway needs to be deployed on the TRILL network. Deploying a gateway device independently requires high costs and complex configurations. You can configure the TRILL gateway function on a core device to enable the core device to integrate the TRILL device functions and gateway functions. To improve reliability, deploy the Virtual Router Redundancy Protocol (VRRP) for gateway redundancy while deploying the TRILL gateway function.

Figure 1-33 Configuring the TRILL gateway function

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic TRILL functions on router bridges (RBs) for interconnection on the TRILL network.

  2. Configure VRRP to implement TRILL gateway redundancy.

  3. Configure the TRILL gateway function on the core device to enable the device to forward TRILL packets at Layer 3 after terminating the packets.

Procedure

  1. Configure basic TRILL functions on RBs.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] vlan batch 50 100
    [*RB1] trill
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100
    [*RB1-trill] carrier-vlan 2
    [*RB1-trill] ce-vlan 100
    [*RB1-trill] admin-vlan 50
    [*RB1-trill] quit
    [*RB1] interface 10ge 1/0/2
    [*RB1-10GE1/0/2] port link-type trunk
    [*RB1-10GE1/0/2] trill enable
    [*RB1-10GE1/0/2] quit
    [*RB1] commit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan batch 50 100
    [*RB2] trill
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] carrier-vlan 2
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] admin-vlan 50
    [*RB2-trill] quit
    [*RB2] interface 10ge 1/0/2
    [*RB2-10GE1/0/2] port link-type trunk
    [*RB2-10GE1/0/2] trill enable
    [*RB2-10GE1/0/2] quit
    [*RB2] commit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] vlan batch 50 100
    [~RB3] trill
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 300
    [*RB3-trill] carrier-vlan 2
    [*RB3-trill] ce-vlan 100
    [*RB3-trill] admin-vlan 50
    [*RB3-trill] quit
    [*RB3] interface 10ge 1/0/1
    [*RB3-10GE1/0/1] port link-type trunk
    [*RB3-10GE1/0/1] trill enable
    [*RB3-10GE1/0/1] quit
    [*RB3] interface 10ge 1/0/2
    [*RB3-10GE1/0/2] port link-type trunk
    [*RB3-10GE1/0/2] trill enable
    [*RB3-10GE1/0/2] quit
    [*RB3] commit

    After the preceding configurations are complete, you can run the display trill peer command to check TRILL neighbor information.

    [~RB3] display trill peer
                                                                                    
    Peer information for TRILL                                                      
    ------------------------------------------------------------------------------------  
                                                                                    
    Total Peer(s): 2                                                                
                                                                                    
    System ID/Trill Name  Interface          Circuit ID        State  HoldTime Type  PRI  
    ------------------------------------------------------------------------------------  
    0000.0000.1111        10GE1/0/1          0000000053        Report      26s L1     --  
    0000.0000.2222        10GE1/0/2          0000000055        Report      27s L1     --  
                                                                                    

  2. Configure OSPF to implement Layer 3 interconnection between the switch and TRILL gateway.

    # Configure the switch.

    <HUAWEI> system-view
    [~HUAWEI] sysname switch
    [*HUAWEI] commit
    [~switch] interface 10ge 1/0/1
    [~switch-10GE1/0/1] undo portswitch
    [*switch-10GE1/0/1] ip address 10.1.1.1 24
    [*switch-10GE1/0/1] quit
    [*switch] interface 10ge 1/0/2
    [*switch-10GE1/0/1] undo portswitch
    [*switch-10GE1/0/1] ip address 10.1.2.1 24
    [*switch-10GE1/0/1] quit
    [*switch] interface loopback 0
    [*switch-LoopBack0] ip address 10.1.5.1 32
    [*switch-LoopBack0] quit
    [*switch] ospf
    [*switch-ospf-1] area 0
    [*switch-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*switch-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*switch-ospf-1-area-0.0.0.0] network 10.1.5.1 0.0.0.0
    [*switch-ospf-1-area-0.0.0.0] quit
    [*switch-ospf-1] quit
    [*switch] commit

    # Configure RB1.

    [~RB1] interface 10ge 1/0/1
    [~RB1-10GE1/0/1] undo portswitch
    [*RB1-10GE1/0/1] ip address 10.1.1.2 24
    [*RB1-10GE1/0/1] quit
    [*RB1] interface vlanif 100
    [*RB1-Vlanif100] ip address 10.1.4.3 24
    [*RB1-Vlanif100] quit
    [*RB1] ospf
    [*RB1-ospf-1] area 0
    [*RB1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*RB1-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [*RB1-ospf-1-area-0.0.0.0] quit
    [*RB1-ospf-1] quit
    [*RB1] commit

    # Configure RB2.

    [~RB2] interface 10ge 1/0/1
    [~RB2-10GE1/0/1] undo portswitch
    [*RB2-10GE1/0/1] ip address 10.1.2.2 24
    [*RB2-10GE1/0/1] quit
    [*RB2] interface vlanif 100
    [*RB2-Vlanif100] ip address 10.1.4.4 24
    [*RB2-Vlanif100] quit
    [*RB2] ospf
    [*RB2-ospf-1] area 0
    [*RB2-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*RB2-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [*RB2-ospf-1-area-0.0.0.0] quit
    [*RB2-ospf-1] quit
    [*RB2] commit

  3. Configure the CE device to be single-homed to the TRILL network and configure a default route on the CE device.

    # Configure the CE device.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE
    [*HUAWEI] commit
    [~CE] vlan batch 100
    [*CE] interface 10ge 1/0/1
    [*CE-10GE1/0/1] port link-type trunk
    [*CE-10GE1/0/1] port trunk allow-pass vlan 100
    [*CE-10GE1/0/1] quit
    [*CE] interface vlanif 100
    [*CE-Vlanif100] ip address 10.1.4.2 24
    [*CE-Vlanif100] quit
    [*CE] ip route-static 0.0.0.0 0 10.1.4.1
    [*CE] commit

    # Configure RB3.

    [~RB3] interface 10ge 1/0/3
    [~RB3-10GE1/0/3] port link-type trunk
    [*RB3-10GE1/0/3] port trunk allow-pass vlan 100
    [*RB3-10GE1/0/3] quit
    [*RB3] commit

  4. Configure VRRP to implement gateway redundancy and improve reliability.

    # Configure RB1.

    [~RB1] interface vlanif 100
    [~RB1-Vlanif100] vrrp vrid 1 virtual-ip 10.1.4.1
    [*RB1-Vlanif100] vrrp vrid 1 priority 120
    [*RB1-Vlanif100] vrrp vrid 1 preempt timer delay 20
    [*RB1-Vlanif100] quit
    [*RB1] commit

    # Configure RB2.

    [~RB2] interface vlanif 100
    [~RB2-Vlanif100] vrrp vrid 1 virtual-ip 10.1.4.1
    [*RB2-Vlanif100] quit
    [*RB2] commit

  5. (CE switches excluding CE6870EI and CE6875EI)Configure the TRILL gateway function.

    # Configure RB1.

    [~RB1] interface eth-trunk 10
    [*RB1-Eth-Trunk10] trunkport 10ge1/0/4 to 1/0/5
    [*RB1-Eth-Trunk10] service type trill unicast
    [*RB1-Eth-Trunk10] quit
    [*RB1] trill gateway enable bind interface eth-trunk 10
    [*RB1] commit

    # Configure RB2.

    [~RB2] interface eth-trunk 10
    [*RB2-Eth-Trunk10] trunkport 10ge1/0/4 to 1/0/5
    [*RB2-Eth-Trunk10] service type trill unicast
    [*RB2-Eth-Trunk10] quit
    [*RB2] trill gateway enable bind interface eth-trunk 10
    [*RB2] commit
    NOTE:

    After you run the service type trill unicast command on an Eth-Trunk interface, the Eth-Trunk interface and its physical member interface can only be used for the TRILL gateway and cannot be configured with other services.

    Add sufficient physical member interfaces to the Eth-Trunk interface to ensure that the internal loopback interface can provide sufficient bandwidth to send TRILL packets to the gateway. For example, if traffic is sent from users to the gateway across the TRILL network at a rate of 10 Gbit/s, add a 10GE interface or ten GE interfaces to the Eth-Trunk interface that you want to use as the internal loopback interface.

  6. (CE6870EI and CE6875EI)Configure the TRILL gateway function.

    # Configure RB1.

    [*RB1] trill gateway enable
    [*RB1] commit

    # Configure RB2.

    [*RB2] trill gateway enable
    [*RB2] commit

  7. Verify the configuration.

    Run the ping command on the CE device to ping the switch. The command output shows that the CE device pings the switch successfully.

    [~CE] ping 10.1.5.1
      PING 10.1.5.1: 56  data bytes, press CTRL_C to break                         
        Reply from 10.1.5.1: bytes=56 Sequence=1 ttl=254 time=18 ms                
        Reply from 10.1.5.1: bytes=56 Sequence=2 ttl=254 time=6 ms                 
        Reply from 10.1.5.1: bytes=56 Sequence=3 ttl=254 time=5 ms                 
        Reply from 10.1.5.1: bytes=56 Sequence=4 ttl=254 time=4 ms                 
        Reply from 10.1.5.1: bytes=56 Sequence=5 ttl=254 time=6 ms                 
                                                                                    
      --- 10.1.5.1 ping statistics ---                                             
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 4/7/18 ms                                          

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #                                                                               
    interface 10GE1/0/1                                                            
     undo portswitch                                                                
     ip address 10.1.1.1 255.255.255.0                                              
    #                                                                               
    interface 10GE1/0/2                                                            
     undo portswitch                                                                
     ip address 10.1.2.1 255.255.255.0                                              
    #                                                                               
    interface LoopBack0                                                             
     ip address 10.1.5.1 255.255.255.255                                            
    #
    ospf 1                                                                          
     area 0.0.0.0                                                                   
      network 10.1.1.0 0.0.0.255                                                    
      network 10.1.2.0 0.0.0.255                                                    
      network 10.1.5.1 0.0.0.0                                                      
    #
    return
    
  • RB1(CE6870EI and CE6875EI) configuration file

    #
    sysname RB1
    #
    trill gateway enable
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 2
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif100
     ip address 10.1.4.3 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.4.1
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt timer delay 20
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
    
  • RB1(CE switches excluding CE6870EI and CE6875EI) configuration file

    #
    sysname RB1
    #
    vlan batch 50 100
    #
    trill gateway enable bind interface Eth-Trunk10
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 2
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif100
     ip address 10.1.4.3 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.4.1
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt timer delay 20
    #
    interface Eth-Trunk10
     service type trill unicast
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/4
     eth-trunk 10
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
    
  • RB2(CE6870EI and CE6875EI) configuration file

    #
    sysname RB2
    #
    trill gateway enable
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 2
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif100
     ip address 10.1.4.4 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.4.1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
    
  • RB2(CE switches excluding CE6870EI and CE6875EI) configuration file

    #
    sysname RB2
    #
    vlan batch 50 100
    #
    trill gateway enable bind interface Eth-Trunk10
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 2
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif100
     ip address 10.1.4.4 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.4.1
    #
    interface Eth-Trunk10
     service type trill unicast
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/4
     eth-trunk 10
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
    
  • RB3 configuration file

    #
    sysname RB3
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 300
     carrier-vlan 2
     admin-vlan 50
     ce-vlan 100
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
    
  • CE configuration file

    #
    sysname CE
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.4.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.4.1
    #
    return
    
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004349

Views: 30281

Downloads: 120

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next