No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - DCN and Server Management

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Trill, FCoE, DCB, and NLB Server Cluster Association.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic TRILL Functions

Example for Configuring Basic TRILL Functions

Networking Requirements

Figure 1-30 shows a data center network. It is required that an unblocked Layer network be constructed, multi-path forwarding be implemented, and each network node can implement line-speed forwarding.
NOTE:

In the figure, 10GE1 indicates 10GE1/0/1, 10GE2 indicates 10GE1/0/2, and 10GE3 indicates 10GE1/0/3.

Figure 1-30 Networking for configuring basic TRILL functions

Configuration Roadmap

Using TRILL to construct a Layer 2 network can meet the requirements. The configuration roadmap is as follows:

  1. Enable TRILL globally on five RBs so that the RBs can process TRILL packets.

  2. Configure mandatory parameters such as the VLAN, NET, and nickname.

  3. Enable TRILL on the interfaces connecting the five RBs so that the interfaces can send and receive TRILL packets.

  4. Configure an admin VLAN on each of five RBs so that the administrators can manage devices using the NMS.

Procedure

  1. Enable TRILL on each RB, and configure their VLANs, NETs, and nicknames. Core devices have high performance. Therefore, you need to set the root priority of the core device RB4 to 65535 to ensure that RB4 becomes the multicast tree root of the TRILL network.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] vlan 100
    [*RB1-vlan100] commit
    [~RB1-vlan100] quit
    [~RB1] trill
    [*RB1-trill] carrier-vlan 10
    [*RB1-trill] ce-vlan 100
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100
    [*RB1-trill] commit
    [~RB1-trill] quit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan 100
    [*RB2-vlan100] commit
    [~RB2-vlan100] quit
    [~RB2] trill
    [*RB2-trill] carrier-vlan 10
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] commit
    [~RB2-trill] quit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] vlan 100
    [*RB3-vlan100] commit
    [~RB3-vlan100] quit
    [~RB3] trill
    [*RB3-trill] carrier-vlan 10
    [*RB3-trill] ce-vlan 100
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 300
    [*RB3-trill] commit
    [~RB3-trill] quit

    # Configure RB4.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB4
    [*HUAWEI] commit
    [~RB4] trill
    [*RB4-trill] carrier-vlan 10
    [*RB4-trill] network-entity 00.0000.0000.4444.00
    [*RB4-trill] nickname 400 root-priority 65535
    [*RB4-trill] commit
    [~RB4-trill] quit

    # Configure RB5.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB5
    [*HUAWEI] commit
    [~RB5] trill
    [*RB5-trill] carrier-vlan 10
    [*RB5-trill] network-entity 00.0000.0000.5555.00
    [*RB5-trill] nickname 500 root-priority 65535
    [*RB5-trill] commit
    [~RB5-trill] quit

  2. Configure TRILL on each interface.

    # Enable TRILL on the interface of RB1.

    [~RB1] interface 10ge 1/0/1
    [~RB1-10GE1/0/1] undo shutdown
    [~RB1-10GE1/0/1] port link-type trunk
    [*RB1-10GE1/0/1] trill enable
    [*RB1-10GE1/0/1] quit
    [*RB1] interface 10ge 1/0/2
    [*RB1-10GE1/0/2] undo shutdown
    [*RB1-10GE1/0/2] port link-type trunk
    [*RB1-10GE1/0/2] trill enable
    [*RB1-10GE1/0/2] quit
    [*RB1] interface 10ge 1/0/3
    [*RB1-10GE1/0/3] undo shutdown
    [*RB1-10GE1/0/3] port default vlan 100
    [*RB1-10GE1/0/3] commit
    [~RB1-10GE1/0/3] quit

    The configurations on other RBs are similar to that on RB1. For detailed configurations, see Configuration Files.

  3. Configure admin VLAN

    # Configure an admin VLAN on each device of the TRILL network, configure VLANIF interfaces for the admin VLANs and configure an IP address for each VLANIF interface. RB1 is used as an example here.

    [~RB1] vlan 50
    [*RB1-vlan50] quit
    [*RB1] interface vlanif 50
    [*RB1-Vlanif50] ip address 192.168.10.1 24
    [*RB1-Vlanif50] quit
    [*RB1] trill
    [*RB1-trill] admin-vlan 50
    [*RB1-trill] commit
    [~RB1-trill] quit

    The configurations on other RBs are similar to that on RB1. For detailed configurations, see Configuration Files.

  4. Check the TRILL database and unicast routing table of each RB.

    # Run the display trill interface command to view information about the TRILL-enabled interface on each RB. RB1 is used as an example here.

    [~RB1] display trill interface
                                                                                    
    Interface information for TRILL                                                 
    ----------------------------------------------------------------------------    
    Total Interface(s): 2                                                           
                                                                                    
    Interface Circuit-ID   State            MTU Type  DRB-State DVLAN  Port-Type    
    ----------------------------------------------------------------------------    
    10GE1/0/1         001  UP              1497 L1    Non-DRB     --   p2p          
    10GE1/0/2         002  UP              1497 L1    Non-DRB     --   p2p          
    

    # Run the display trill nickname command to view the nickname of each RB. RB1 is used as an example here.

    [~RB1] display trill nickname
     
    Nickname information for TRILL
    ------------------------------------------------------------------
    *-Local Nickname, A-Advertised, S-Suppressed / S-Static, D-Dynamic
    
    Total Nickname(s): 5
    
      Nickname Source ID/Trill Name   State Priority RootPri
    --------------------------------------------------------
    *      100 0000.0000.1111         A/S        192   32768
           200 0000.0000.2222         A/S        192   32768
           300 0000.0000.3333         A/S        192   32768
           400 0000.0000.4444         A/S        192   32768
           500 0000.0000.5555         A/S        192   32768
    

    # Run the display trill route command to view the unicast routing table of each RB. RB1 is used as an example here.

    [~RB1] display trill route
     
    TRILL Unicast Routing Table
    --------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop            Hop
    -----------------------------------------------------------------------
         200       4000 D    10GE1/0/1            10 400/3609-b654-1220   2
                             10GE1/0/2            10 500/3609-b655-1220   2
         300       4000 D    10GE1/0/2            10 500/3609-b655-1220   2
         400       2000 D    10GE1/0/1            10 400/3609-b654-1220   1
         500       2000 D    10GE1/0/2            10 500/3609-b655-1220   1
    

  5. Disable load balancing on RB1 by setting the number of equal-cost routes for load balancing to 1.

    [~RB1] trill
    [*RB1-trill] maximum load-balance 1
    [*RB1-trill] commit

    # Check the unicast routing table of RB1.

    [~RB1-trill] display trill route
     
    TRILL Unicast Routing Table
    --------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop            Hop
    -----------------------------------------------------------------------
         200       4000 D    10GE1/0/1            10 400/3609-b654-1220   2
         300       4000 D    10GE1/0/2            10 500/3609-b655-1220   2
         400       2000 D    10GE1/0/1            10 400/3609-b654-1220   1
         500       2000 D    10GE1/0/2            10 500/3609-b655-1220   1
    

    The preceding table shows that the outbound interface of the route to Nickname 200 is 10GE1/0/1. After the maximum number of equal-cost routes for load balancing is configured to 1, the route with the next hop RB4 is selected as the optimal route because RB4 has a smaller interface index.

  6. Restore the default number of equal-cost routes for load balancing on RB1.

    [*RB1-trill] undo maximum load-balance
    [*RB1-trill] commit

    # Check the TRILL unicast routing table of RB1.

    [~RB1-trill] display trill route
     
    TRILL Unicast Routing Table
    --------------------------------------------------------------------
    Flags: D-Download To Fib
    
    Total Route(s): 4
    
    Nickname       Cost Flag OutInterface  OuterVlan NextHop            Hop
    -----------------------------------------------------------------------
         200       4000 D    10GE1/0/1            10 400/3609-b654-1220   2
                             10GE1/0/2            10 500/3609-b655-1220   2
         300       4000 D    10GE1/0/2            10 500/3609-b655-1220   2
         400       2000 D    10GE1/0/1            10 400/3609-b654-1220   1
         500       2000 D    10GE1/0/2            10 500/3609-b655-1220   1
    

    The preceding table shows the valid routes with the next hops RB4 (3609-b654-1220) and RB5 (3609-b655-1220) of RB1.

Configuration Files

  • Configurations files of RB1

    #
    sysname RB1
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.1 255.255.255.0 
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/3
     port default vlan 100
    #               
    return
  • Configurations files of RB2

    #
    sysname RB2
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.2 255.255.255.0 
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/3
     port default vlan 100
    #               
    return
  • Configurations files of RB3

    #
    sysname RB3
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 300
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 192.168.10.3 255.255.255.0 
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/3
     port default vlan 100
    #               
    return
  • Configurations files of RB4

    #
    sysname RB4
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.4444.00
     nickname 400 root-priority 65535
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
     ip address 192.168.10.4 255.255.255.0 
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #               
    return
  • Configurations files of RB5

    #
    sysname RB5
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.5555.00
     nickname 500 root-priority 65535
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
     ip address 192.168.10.5 255.255.255.0 
    #
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004349

Views: 30171

Downloads: 120

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next