No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - DCN and Server Management

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Trill, FCoE, DCB, and NLB Server Cluster Association.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Association Between MSTP and TRILL

Example for Configuring the Association Between MSTP and TRILL

Networking Requirements

As shown in Figure 1-31, an enterprise's data center network originally runs MSTP to avoid loops. The customer plans to expand the network capacity to construct a large Layer 2 network using TRILL. It is required that the original MSTP network be dual-homed to the TRILL network to implement seamless expansion.
NOTE:

RB5 is a core device. The configuration of RB5 is similar to that of RB1 and so is not mentioned here.

Figure 1-31 Networking for configuring the association between MSTP and TRILL

Configuration Roadmap

As the MSTP network needs to be dual-homed to the TRILL network, you are advised to configure the association between MSTP and TRILL to avoid loops. The configuration roadmap is as follows:

  1. Configure basic TRILL functions on devices in the new network so that the devices can communicate with each other using TRILL.

  2. Configure the association between MSTP and TRILL on the edge device connecting the TRILL network to the MSTP network so that loops are avoided and the TC packets of the MSTP network can be sent through the TRILL network.

Procedure

  1. Enable TRILL on each RB, and configure their VLANs, NETs, and nicknames. Core devices have high performance. Therefore, you need to set the root priority of the core device RB1 to 65535 to ensure that RB1 becomes the multicast tree root of the TRILL network.

    # Configure RB1.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB1
    [*HUAWEI] commit
    [~RB1] trill
    [*RB1-trill] carrier-vlan 10
    [*RB1-trill] network-entity 00.0000.0000.1111.00
    [*RB1-trill] nickname 100 root-priority 65535
    [*RB1-trill] commit
    [~RB1-trill] quit

    # Configure RB2.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB2
    [*HUAWEI] commit
    [~RB2] vlan 100
    [*RB2-vlan100] commit
    [~RB2-vlan100] quit
    [~RB2] trill
    [*RB2-trill] carrier-vlan 10
    [*RB2-trill] ce-vlan 100
    [*RB2-trill] network-entity 00.0000.0000.2222.00
    [*RB2-trill] nickname 200
    [*RB2-trill] commit
    [~RB2-trill] quit

    # Configure RB3.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB3
    [*HUAWEI] commit
    [~RB3] vlan 100
    [*RB3-vlan100] commit
    [~RB3-vlan100] quit
    [~RB3] trill
    [*RB3-trill] carrier-vlan 10
    [*RB3-trill] ce-vlan 100
    [*RB3-trill] network-entity 00.0000.0000.3333.00
    [*RB3-trill] nickname 300
    [*RB3-trill] commit
    [~RB3-trill] quit

    # Configure RB4.

    <HUAWEI> system-view
    [~HUAWEI] sysname RB4
    [*HUAWEI] commit
    [~RB4] vlan 100
    [*RB4-vlan100] commit
    [~RB4-vlan100] quit
    [~RB4] trill
    [*RB4-trill] carrier-vlan 10
    [*RB4-trill] ce-vlan 100
    [*RB4-trill] network-entity 00.0000.0000.4444.00
    [*RB4-trill] nickname 400
    [*RB4-trill] commit
    [~RB4-trill] quit

  2. Configure TRILL on each interface.

    # Configure RB1.

    [~RB1] interface 10ge 1/0/1
    [~RB1-10GE1/0/1] port link-type trunk
    [*RB1-10GE1/0/1] trill enable
    [*RB1-10GE1/0/1] quit
    [*RB1] interface 10ge 1/0/2
    [*RB1-10GE1/0/2] port link-type trunk
    [*RB1-10GE1/0/2] trill enable
    [*RB1-10GE1/0/2] quit
    [*RB1] interface 10ge 1/0/3
    [*RB1-10GE1/0/3] port link-type trunk
    [*RB1-10GE1/0/3] trill enable
    [*RB1-10GE1/0/3] commit
    [~RB1-10GE1/0/3] quit

    # Configure RB2.

    [~RB2] interface 10ge 1/0/2
    [~RB2-10GE1/0/2] port link-type trunk
    [*RB2-10GE1/0/2] trill enable
    [*RB2-10GE1/0/2] undo stp enable
    [*RB2-10GE1/0/2] commit
    [~RB2-10GE1/0/2] quit

    # Configure RB3.

    [~RB3] interface 10ge 1/0/2
    [~RB3-10GE1/0/2] port link-type trunk
    [*RB3-10GE1/0/2] trill enable
    [*RB3-10GE1/0/2] undo stp enable
    [*RB3-10GE1/0/2] commit
    [~RB3-10GE1/0/2] quit

    # Configure RB4.

    [~RB4] interface 10ge 1/0/1
    [*RB4-10GE1/0/1] port default vlan 100
    [*RB4-10GE1/0/1] quit
    [*RB4] interface 10ge 1/0/2
    [*RB4-10GE1/0/2] port link-type trunk
    [*RB4-10GE1/0/2] trill enable
    [*RB4-10GE1/0/2] commit
    [~RB4-10GE1/0/2] quit

  3. Configure the association between MSTP and TRILL.

    # Configure an admin VLAN on each device of the TRILL network, and configure VLANIF interfaces for the admin VLANs. RB1 is used as an example here.

    [~RB1] vlan 50
    [*RB1-vlan50] quit
    [*RB1] interface vlanif 50
    [*RB1-Vlanif50] ip address 10.1.1.1 24
    [*RB1-Vlanif50] quit
    [*RB1] trill
    [*RB1-trill] admin-vlan 50
    [*RB1-trill] commit
    [~RB1-trill] quit
    The configurations on RB2, RB3, and RB4 are the same as that on RB1.

    The VLANIF interface is configured for the admin VLAN; however, the admin VLAN still carries TRILL traffic, not Layer 3 traffic.

    # Add RB2 and RB3 to the MSTP region of the original network. Configure RB2 and RB3 as the root bridge of the MSTP instance, and configure the same bridge MAC address for them. In addition, configure 10GE1/0/1 to allow the traffic of the CE VLAN and admin VLAN to pass through. RB2 is used as an example here.

    [~RB2] stp region-configuration
    [*RB2-mst-region] region-name RG1
    [*RB2-mst-region] instance 1 vlan 100
    [*RB2-mst-region] quit
    [*RB2] stp instance 1 root primary
    [*RB2] stp bridge-address 39-39-39
    [*RB2] interface 10ge 1/0/1
    [~RB2-10GE1/0/1] port link-type trunk
    [*RB2-10GE1/0/1] port trunk allow-pass vlan 100
    [*RB2-10GE1/0/1] quit
    [*RB2] commit

    The configuration on RB3 is the same as that on RB2.

    # Enable the association between MSTP and TRILL on RB2 and RB3, and specify the VLAN that carries the association packets as the admin VLAN. RB2 is used as an example here. The configuration on RB3 is the same as that on RB2.

    [~RB2] stp tc-notify trill vlan 50
    [*RB2] commit

Configuration Files

  • Configurations files of RB1

    #
    sysname RB1
    #
    vlan batch 50
    #
    trill
     network-entity 00.0000.0000.1111.00
     nickname 100 root-priority 65535
     carrier-vlan 10
     admin-vlan 50
    #
    interface Vlanif50
     ip address 10.1.1.1 255.255.255.0
    #               
    interface 10GE1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #
    interface 10GE1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #               
    return
  • Configurations files of RB2

    #
    sysname RB2
    #
    vlan batch 50 100
    #
    stp bridge-address 0039-0039-0039
    stp tc-notify trill vlan 50
    stp instance 1 root primary
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 100
    #
    trill
     network-entity 00.0000.0000.2222.00
     nickname 200
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
     ip address 10.1.1.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     stp disable
     trill enable 
    #
    return
  • Configurations files of RB3

    #
    sysname RB3
    #
    vlan batch 50 100
    #
    stp bridge-address 0039-0039-0039
    stp tc-notify trill vlan 50
    stp instance 1 root primary
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 100
    #
    trill
     network-entity 00.0000.0000.3333.00
     nickname 300
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     stp disable
     trill enable 
    #               
    return
  • Configurations files of RB4

    #
    sysname RB4
    #
    vlan batch 50 100
    #
    trill
     network-entity 00.0000.0000.4444.00
     nickname 400
     carrier-vlan 10
     admin-vlan 50
     ce-vlan 100
    #
    interface Vlanif50
    #
    interface 10GE1/0/1
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     trill enable 
    #               
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004349

Views: 31668

Downloads: 120

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next