No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Link Aggregation in Manual Load Balancing Mode (CE Switches Excluding CE6870EI and CE6875EI)

Example for Configuring Link Aggregation in Manual Load Balancing Mode (CE Switches Excluding CE6870EI and CE6875EI)

Networking Requirements

In Figure 3-19, SwitchA and SwitchB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between SwitchA and SwitchB.

SwitchA and SwitchB can provide higher link bandwidth to implement inter-VLAN communication. Data transmission and link reliability need to be ensured.

Figure 3-19 Link aggregation in manual load balancing mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.

  2. Create VLANs and add interfaces to the VLANs.

  3. Configure a load balancing mode to ensure that traffic is load balanced among Eth-Trunk member interfaces.

Procedure

  1. Create an Eth-Trunk on SwitchA and SwitchB, and add member interfaces to the Eth-Trunk.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] mode manual load-balance 
    [*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit
    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] interface eth-trunk 1
    [*SwitchB-Eth-Trunk1] mode manual load-balance 
    [*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/1 to 1/0/3
    [*SwitchB-Eth-Trunk1] commit
    [~SwitchB-Eth-Trunk1] quit

  2. Create VLANs and add interfaces to the VLANs.

    # Create VLAN 10 and VLAN 20, and add interfaces to them. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type trunk
    [*SwitchA-10GE1/0/4] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/4] quit
    [*SwitchA] interface 10ge 1/0/5
    [*SwitchA-10GE1/0/5] port link-type trunk
    [*SwitchA-10GE1/0/5] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/5] quit
    [*SwitchA] commit

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface eth-trunk 1
    [~SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit

  3. Configure a load balancing mode for Eth-Trunk 1. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface eth-trunk 1
    [~SwitchA-Eth-Trunk1] load-balance src-dst-mac
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit
    
    NOTE:

  4. Verify the configuration.

    Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.

    [~SwitchA] display eth-trunk 1
    Eth-Trunk1's state information is: 
    Working Mode: Normal           Hash Arithmetic: src-dst-mac
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 16
    Operating Status: up           Number of Up Ports in Trunk: 3
    --------------------------------------------------------------------------------
    PortName                Status       Weight
    10GE1/0/1               Up           1
    10GE1/0/2               Up           1
    10GE1/0/3               Up           1
    

    The preceding command output shows that Eth-Trunk 1 has three member interfaces: 10GE1/0/1, 10GE1/0/2, and 10GE1/0/3. The member interfaces are all in Up state. The Operating Status of Eth-Trunk 1 is Up.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface 10GE1/0/1 
     eth-trunk 1
    # 
    interface 10GE1/0/2 
     eth-trunk 1
    # 
    interface 10GE1/0/3 
     eth-trunk 1
    #
    interface 10GE1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 125976

Downloads: 295

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next