No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MQC-based VLAN Mapping

Example for Configuring MQC-based VLAN Mapping

Networking Requirements

As shown in Figure 7-9, on a data center network, servers store video and data information. Users are classified into gold and silver users, and gold and silver users belong to VLAN 200 and VLAN 300 respectively and access servers through the enterprise backbone network. The enterprise backbone network allocates VLAN 2 to gold users and VLAN 3 to silver users. Switch2 and Switch3 are edge devices of the enterprise backbone network. VLAN IDs planned by the video and data servers and enterprise backbone network are different. To ensure that gold users can access the video server and silver users can access the data server, configure MQC-based VLAN mapping on Switch2 and Switch3.

Figure 7-9 Networking for configuring MQC-based VLAN mapping

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLAN 2 and VLAN 3 on Switch2 and Switch3.

  2. Configure traffic classifiers, traffic behaviors, and traffic policies on Switch2 and Switch3.

  3. Configure types of interfaces on Switch2 and Switch3, and add the interfaces to corresponding VLANs.

  4. Apply MQC to interfaces on Switch2 and Switch3 to implement VLAN mapping.

Procedure

  1. Create VLANs.

    # Create VLAN 200 and VLAN 300 on Switch1 and add interfaces connected to servers to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 200 300
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port default vlan 200
    [*Switch1-10GE1/0/2] quit
    [*Switch1] interface 10ge 1/0/3
    [*Switch1-10GE1/0/3] port default vlan 300
    [*Switch1-10GE1/0/3] quit
    [*Switch1] commit
    

    # Create VLAN 200 and VLAN 300 on Switch4 and add interfaces connected to users to VLAN 200 and VLAN 300. The configuration of Switch1 is similar to the configuration of Switch4, and the configuration details are not mentioned here.

    # On Switch2, create VLAN 2 and VLAN 3.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan batch 2 3
    [*Switch2] commit

    # On Switch3, create VLAN 2 and VLAN 3.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 2 3
    [*Switch3] commit

  2. Configure traffic classifiers, traffic behaviors, and traffic policies on Switch2 and Switch3.

    # Configure traffic classifiers, traffic behaviors, and traffic policies on Switch2.

    [~Switch2] traffic classifier name1
    [*Switch2-classifier-name1] if-match vlan 200
    [*Switch2-classifier-name1] quit
    [*Switch2] traffic behavior name1
    [*Switch2-behavior-name1] vlan-mapping vlan 2
    [*Switch2-behavior-name1] quit
    [*Switch2] traffic classifier name2
    [*Switch2-classifier-name2] if-match vlan 300
    [*Switch2-classifier-name2] quit
    [*Switch2] traffic behavior name2
    [*Switch2-behavior-name2] vlan-mapping vlan 3
    [*Switch2-behavior-name2] quit
    [*Switch2] traffic policy name1
    [*Switch2-trafficpolicy-name1] classifier name1 behavior name1
    [*Switch2-trafficpolicy-name1] classifier name2 behavior name2
    [*Switch2-trafficpolicy-name1] quit
    [*Switch2] commit
    

    # Configure traffic classifiers, traffic behaviors, and traffic policies on Switch3.

    [~Switch3] traffic classifier name1
    [*Switch3-classifier-name1] if-match vlan 2
    [*Switch3-classifier-name1] quit
    [*Switch3] traffic behavior name1
    [*Switch3-behavior-name1] vlan-mapping vlan 200
    [*Switch3-behavior-name1] quit
    [*Switch3] traffic classifier name2
    [*Switch3-classifier-name2] if-match vlan 3
    [*Switch3-classifier-name2] quit
    [*Switch3] traffic behavior name2
    [*Switch3-behavior-name2] vlan-mapping vlan 300
    [*Switch3-behavior-name2] quit
    [*Switch3] traffic policy name1
    [*Switch3-trafficpolicy-name1] classifier name1 behavior name1
    [*Switch3-trafficpolicy-name1] classifier name2 behavior name2
    [*Switch3-trafficpolicy-name1] quit
    [*Switch3] commit
    

  3. Apply traffic policies to interfaces to implement VLAN mapping.

    # Configure 10GE1/0/1 on Switch2.

    [~Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] traffic-policy name1 inbound
    [*Switch2-10GE1/0/1] quit
    [*Switch2] commit

    # Configure 10GE1/0/2 on Switch3.

    [~Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] traffic-policy name1 inbound
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit

  4. Configure other interfaces.

    # Add 10GE1/0/1 on Switch1 to VLAN 200 and VLAN 300. The configuration of 10GE1/0/1 on Switch4 is similar to the configuration of Switch1, and the configuration details are not mentioned here.

    [~Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port link-type trunk
    [*Switch1-10GE1/0/1] port trunk allow-pass vlan 200 300
    [*Switch1-10GE1/0/1] quit
    [*Switch1] commit

  5. Verify the configuration.

    After the preceding configuration is complete, gold users can access the video server and silver users can access the data server.

Configuration Files

  • Configuration file of Switch1

    #
    sysname Switch1
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
  • Configuration file of Switch2

    #
    sysname Switch2
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 type or
     if-match vlan 200
    #
    traffic classifier name2 type or
     if-match vlan 300
    #
    traffic behavior name1
     vlan-mapping vlan 2
    #
    traffic behavior name2
     vlan-mapping vlan 3
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/1
     traffic-policy name1 inbound
    #
    return
  • Configuration file of Switch3

    #
    sysname Switch3
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 type or
     if-match vlan 2
    #
    traffic classifier name2 type or
     if-match vlan 3
    #
    traffic behavior name1
     vlan-mapping vlan 200
    #
    traffic behavior name2
     vlan-mapping vlan 300
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/2
     traffic-policy name1 inbound
    #
    return
  • Configuration file of Switch4

    #
    sysname Switch4
    #
     vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 125286

Downloads: 295

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next