No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MQC-based Selective QinQ

Example for Configuring MQC-based Selective QinQ

Networking Requirements

As shown in Figure 6-9, servers on a data center network store video and data information. The MAC addresses of data and video servers are 0003-0003-0003 and 0004-0004-0004 respectively. A school network transmits teachers' office and multimedia services, and servers are connected through the enterprise backbone network. The enterprise backbone network allocates VLAN 2 to teachers' office service and VLAN 3 to multimedia service. SwitchB and SwitchC are edge devices of the enterprise backbone network.

The requirements are as follows:

  • Video and data servers are allocated to different VLANs, so they do not affect each other.

  • Traffic is transparently transmitted on the enterprise backbone network. Teachers' office service is only transmitted to the data server and multimedia service is only transmitted to the video server so that services can be differentiated.

MQC-based selective QinQ can be configured on SwitchB to meet the preceding requirements.

Figure 6-9 Networking of MQC-based selective QinQ

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs on SwitchB and configure SwitchB to add different VLAN tags to packets of different services.

  2. Configure traffic classifiers, traffic behaviors, and bind them in a traffic policy on SwitchB.

  3. Apply the traffic policy to interfaces of SwitchB to implement selective QinQ.

Procedure

  1. Create VLANs.

    # Create VLAN 200 and VLAN 300 on SwitchA and add interfaces connected to servers to VLAN 200 and VLAN 300. The configuration of SwitchD is similar to the configuration of SwitchA, and is not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 200 300
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 200
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port default vlan 300
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # On SwitchB, create VLAN 2 and VLAN 3, that is, outer VLAN IDs added to packets.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 2 3
    [*SwitchB] commit

    # On SwitchC, create VLAN 2 and VLAN 3.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] vlan batch 2 3
    [*SwitchC] commit

  2. Configure traffic classifiers, traffic behaviors, and bind them in a traffic policy on SwitchB.

    [~SwitchB] traffic classifier name1
    [*SwitchB-classifier-name1] if-match source-mac 0003-0003-0003
    [*SwitchB-classifier-name1] quit
    [*SwitchB] traffic behavior name1
    [*SwitchB-behavior-name1] vlan-stacking vlan 2
    [*SwitchB-behavior-name1] quit
    [*SwitchB] traffic classifier name2
    [*SwitchB-classifier-name2] if-match source-mac 0004-0004-0004
    [*SwitchB-classifier-name2] quit
    [*SwitchB] traffic behavior name2
    [*SwitchB-behavior-name2] vlan-stacking vlan 3
    [*SwitchB-behavior-name2] quit
    [*SwitchB] traffic policy name1
    [*SwitchB-trafficpolicy-name1] classifier name1 behavior name1
    [*SwitchB-trafficpolicy-name1] classifier name2 behavior name2
    [*SwitchB-trafficpolicy-name1] quit
    [*SwitchB] commit
    

  3. Apply the traffic policy on SwitchB to implement selective QinQ.

    # Configure 10GE1/0/1 on SwitchB.

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 2 3
    [*SwitchB-10GE1/0/1] traffic-policy name1 inbound
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit

    # Configure 10GE1/0/1 on SwitchC.

    [~SwitchC] interface 10ge 1/0/1
    [~SwitchC-10GE1/0/1] port link-type hybrid
    [*SwitchC-10GE1/0/1] port hybrid untagged vlan 2 3
    [*SwitchC-10GE1/0/1] quit
    [*SwitchC] commit

  4. Configure other interfaces.

    # Add 10GE 1/0/1 on SwitchA to VLAN 200 and VLAN 300. The configuration of SwitchD is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 200 300
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # Add 10GE1/0/2 on SwitchB to VLAN 2 and VLAN 3.

    [~SwitchB] interface 10ge 1/0/2
    [~SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 2 3
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] commit

    # Add 10GE1/0/2 on SwitchC to VLAN 2 and VLAN 3.

    [~SwitchC] interface 10ge 1/0/2
    [~SwitchC-10GE1/0/2] port link-type hybrid
    [*SwitchC-10GE1/0/2] port hybrid untagged vlan 2 3
    [*SwitchC-10GE1/0/2] quit
    [*SwitchC] commit

  5. Verify the configuration.

    • Ping a teacher's office PC from the data server. The ping operation succeeds, indicating that the teacher's office PC can access the data server.

    • Ping a PC in the multimedia room from the video server. The ping operation succeeds, indicating that the PC can access the video server.

    Here, the ping to a teacher's office PC from the data server is used as an example. The data server and teacher's office PC are configured on the same network segment. For example, the IP address of the data server is 172.16.0.1/16, and the IP address of the teacher's office PC is 172.16.0.7/16. Assume that the PC runs the Window XP operating system.

    C:\Documents and Settings\Administrator> ping 172.16.0.7
    Pinging 172.16.0.7 with 32 bytes of data:
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.7: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.7:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port default vlan 200
    #
    interface 10GE1/0/3
     port default vlan 300
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 type or
     if-match source-mac 0003-0003-0003 ffff-ffff-ffff
    #
    traffic classifier name2 type or
     if-match source-mac 0004-0004-0004 ffff-ffff-ffff
    #
    traffic behavior name1
     vlan-stacking vlan 2
    #
    traffic behavior name2
     vlan-stacking vlan 3
    #
    traffic policy name1
     classifier name1 behavior name1 precedence 5
     classifier name2 behavior name2 precedence 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     traffic-policy name1 inbound
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
    #
    interface 10GE1/0/2
     port link-type hybrid
     port hybrid untagged vlan 2 to 3
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 200 300
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 81601

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next