No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN-based 2 to 2 VLAN Mapping

Example for Configuring VLAN-based 2 to 2 VLAN Mapping

Networking Requirements

As shown in Figure 7-8, two branches of a data center are deployed in different positions and located on the same network segment. To plan private VLAN IDs in the data center, QinQ is used. That is, packets from Switch2 to the ISP network carry double tags. Because the two VLAN IDs are different from VLAN IDs on the ISP network, packets from branches cannot pass through the ISP network. As a result, branches cannot communicate. It is required that branches 1 and 2 communicate.

Figure 7-8 Networking for configuring 2 to 2 VLAN mapping

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add the downlink interface on Switch1 connected to branch 1 to VLAN 10 and downlink interface on Switch6 connected to branch 2 to VLAN 30.

  2. Configure QinQ on Switch2 and Switch5 so that packets sent to the ISP network carry double tags.

  3. Deploy 2 to 2 VLAN mapping on Switch3 and Switch4 to map inner and outer VLAN IDs of packets to VLAN IDs allowed by the ISP network so that branches can communicate.

Procedure

  1. Add downlink interfaces on Switch1 and Switch6 to VLANs and configure the uplink interfaces to allow the VLANs.

    # Configure Switch1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan 10
    [*Switch1-vlan10] quit
    [*Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port default vlan 10
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port link-type trunk
    [*Switch1-10GE1/0/2] port trunk allow-pass vlan 10
    [*Switch1-10GE1/0/2] quit
    [*Switch1] commit

    # Configure Switch6.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch6
    [*HUAWEI] commit
    [~Switch6] vlan 30
    [*Switch6-vlan30] quit
    [*Switch6] interface 10ge 1/0/1
    [*Switch6-10GE1/0/1] port default vlan 30
    [*Switch6-10GE1/0/1] quit
    [*Switch6] interface 10ge 1/0/2
    [*Switch6-10GE1/0/2] port link-type trunk
    [*Switch6-10GE1/0/2] port trunk allow-pass vlan 30
    [*Switch6-10GE1/0/2] quit
    [*Switch6] commit

  2. Configure QinQ on Switch2 and Switch5 so that packets sent to the ISP network carry double tags.

    # Configure the type of 10GE1/0/1 on Switch2 as QinQ and the outer VLAN tag as VLAN 20.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan 20
    [*Switch2-vlan20] quit
    [*Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch2-10GE1/0/1] port default vlan 20
    [*Switch2-10GE1/0/1] quit
    [*Switch2] interface 10ge 1/0/2
    [*Switch2-10GE1/0/2] port link-type trunk
    [*Switch2-10GE1/0/2] port trunk allow-pass vlan 20
    [*Switch2-10GE1/0/2] quit
    [*Switch2] commit
    

    # Configure the type of 10GE1/0/1 on Switch5 as QinQ and the outer VLAN tag as VLAN 40.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch5
    [*HUAWEI] commit
    [~Switch5] vlan 40
    [*Switch5-vlan40] quit
    [*Switch5] interface 10ge 1/0/1
    [*Switch5-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch5-10GE1/0/1] port default vlan 40
    [*Switch5-10GE1/0/1] quit
    [*Switch5] interface 10ge 1/0/2
    [*Switch5-10GE1/0/2] port link-type trunk
    [*Switch5-10GE1/0/2] port trunk allow-pass vlan 40
    [*Switch5-10GE1/0/2] quit
    [*Switch5] commit
    

  3. Configure VLAN mapping on Switch3 and Switch4.

    # Configure Switch3.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 50
    [*Switch3] interface 10ge 1/0/1
    [*Switch3-10GE1/0/1] port link-type trunk
    [*Switch3-10GE1/0/1] port trunk allow-pass vlan 50
    [*Switch3-10GE1/0/1] port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    [*Switch3-10GE1/0/1] quit
    [*Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 50
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit
    

    # Configure Switch4.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch4
    [*HUAWEI] commit
    [~Switch4] vlan batch 50
    [*Switch4] interface 10ge 1/0/1
    [*Switch4-10GE1/0/1] port link-type trunk
    [*Switch4-10GE1/0/1] port trunk allow-pass vlan 50
    [*Switch4-10GE1/0/1] port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    [*Switch4-10GE1/0/1] quit
    [*Switch4] interface 10ge 1/0/2
    [*Switch4-10GE1/0/2] port link-type trunk
    [*Switch4-10GE1/0/2] port trunk allow-pass vlan 50
    [*Switch4-10GE1/0/2] quit
    [*Switch4] commit
    

  4. Verify the configuration.

    Configure Server1 in branch 1 and Server2 in branch 2 on the same network segment. For example, configure IP addresses 172.16.0.5/16 and 172.16.0.6/16 for Server1 and Server2 respectively so that branch 1 can communication with branch 2. This example pings Server2 in branch 2 from Server1 in branch 1.
    <Server1> ping 172.16.0.6
    Pinging 172.16.0.6 with 32 bytes of data:
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.6: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.6:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration Files

  • Configuration file of Switch1

    #
    sysname Switch1
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Switch2

    #
    sysname Switch2
    #
    vlan batch 20
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of Switch3

    #
    sysname Switch3
    #
    vlan batch 50
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
     port vlan-mapping vlan 20 inner-vlan 10 map-vlan 50 map-inner-vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Configuration file of Switch4

    #
    sysname Switch4
    #
    vlan batch 50
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
     port vlan-mapping vlan 40 inner-vlan 30 map-vlan 50 map-inner-vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • Configuration file of Switch5

    #
    sysname Switch5
    #
    vlan batch 40
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
  • Configuration file of Switch6

    #
    sysname Switch6
    #
    vlan batch 30
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 125260

Downloads: 295

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next