No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN-based 2 to 1 VLAN Mapping

Example for Configuring VLAN-based 2 to 1 VLAN Mapping

Networking Requirements

As shown in Figure 7-7, on a data center network, the office server and production server in the old branch belong to VLAN 2 and VLAN 3 respectively, and the servers are connected to the core network through the access and aggregation switches. The network administrator plans a new branch. The office server and production server belong to VLAN 2 and VLAN 3 respectively. Devices transmitting the same service on old and new branches are located on the same network segment. To ensure that the same servers can communicate and different servers are isolated, and save VLAN resources, configure QinQ on aggregation switches. To retain VLAN deployment of core switch, configure VLAN mapping on the core switch.

Figure 7-7 Networking for configuring 2 to 1 VLAN mapping

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add interfaces on Switch1 and Switch2 connected to servers to VLANs.

  2. Deploy QinQ on Switch3 and Switch4 to save VLAN resources.

  3. Configure 2 to 1 VLAN mapping on Switch5 so that the same service can be transmitted and different services are isolated in old and new branches.

Procedure

  1. Add downlink interfaces on Switch1 and Switch2 to VLANs and configure the uplink interfaces to allow the VLANs.

    # Configure Switch1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch1
    [*HUAWEI] commit
    [~Switch1] vlan batch 2 3
    [*Switch1] interface 10ge 1/0/1
    [*Switch1-10GE1/0/1] port default vlan 2
    [*Switch1-10GE1/0/1] quit
    [*Switch1] interface 10ge 1/0/2
    [*Switch1-10GE1/0/2] port default vlan 3
    [*Switch1-10GE1/0/2] quit
    [*Switch1] interface 10ge 1/0/3
    [*Switch1-10GE1/0/3] port link-type trunk
    [*Switch1-10GE1/0/3] port trunk allow-pass vlan 2 3
    [*Switch1-10GE1/0/3] quit
    [*Switch1] commit

    # Configure Switch2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch2
    [*HUAWEI] commit
    [~Switch2] vlan batch 2 3
    [*Switch2] interface 10ge 1/0/1
    [*Switch2-10GE1/0/1] port default vlan 2
    [*Switch2-10GE1/0/1] quit
    [*Switch2] interface 10ge 1/0/2
    [*Switch2-10GE1/0/2] port default vlan 3
    [*Switch2-10GE1/0/2] quit
    [*Switch2] interface 10ge 1/0/3
    [*Switch2-10GE1/0/3] port link-type trunk
    [*Switch2-10GE1/0/3] port trunk allow-pass vlan 2 3
    [*Switch2-10GE1/0/3] quit
    [*Switch2] commit

  2. Configure QinQ on Switch3 and Switch4.

    # Configure the type of 10GE1/0/1 on Switch3 as QinQ and the outer VLAN tag as VLAN 201.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch3
    [*HUAWEI] commit
    [~Switch3] vlan batch 201
    [*Switch3] interface 10ge 1/0/1
    [*Switch3-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch3-10GE1/0/1] port default vlan 201
    [*Switch3-10GE1/0/1] quit
    [*Switch3] interface 10ge 1/0/2
    [*Switch3-10GE1/0/2] port link-type trunk
    [*Switch3-10GE1/0/2] port trunk allow-pass vlan 201
    [*Switch3-10GE1/0/2] quit
    [*Switch3] commit
    

    # Configure the type of 10GE1/0/1 on Switch4 as QinQ and the outer VLAN tag as VLAN 201.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch4
    [*HUAWEI] commit
    [~Switch4] vlan batch 201
    [*Switch4] interface 10ge 1/0/1
    [*Switch4-10GE1/0/1] port link-type dot1q-tunnel
    [*Switch4-10GE1/0/1] port default vlan 201
    [*Switch4-10GE1/0/1] quit
    [*Switch4] interface 10ge 1/0/2
    [*Switch4-10GE1/0/2] port link-type trunk
    [*Switch4-10GE1/0/2] port trunk allow-pass vlan 201
    [*Switch4-10GE1/0/2] quit
    [*Switch4] commit
    

  3. Configure VLAN mapping on Switch5.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch5
    [*HUAWEI] commit
    [~Switch5] vlan batch 501 502
    [*Switch5] interface 10ge 1/0/1
    [*Switch5-10GE1/0/1] port link-type trunk
    [*Switch5-10GE1/0/1] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/1] port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
    [*Switch5-10GE1/0/1] port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    [*Switch5-10GE1/0/1] quit
    [*Switch5] interface 10ge 1/0/2
    [*Switch5-10GE1/0/2] port link-type trunk
    [*Switch5-10GE1/0/2] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/2] port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
    [*Switch5-10GE1/0/2] port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    [*Switch5-10GE1/0/2] quit
    [*Switch5] interface 10ge 1/0/3
    [*Switch5-10GE1/0/3] port link-type trunk
    [*Switch5-10GE1/0/3] port trunk allow-pass vlan 501 502
    [*Switch5-10GE1/0/3] quit
    [*Switch5] commit
    

  4. Verify the configuration.

    • Configure office server Server1 in the new branch and office server Server2 in the old branch on the same network segment. For example, configure IP addresses 172.16.0.1/24 and 172.16.0.2/24 for Server1 and Server2 respectively.
    • Configure production server Server3 in the new branch and production server Server4 in the old branch on the same network segment. For example, configure IP addresses 172.16.1.1/24 and 172.16.1.2/24 for Server3 and Server4 respectively.

    Server1 and Server2, and Server 3 and Server 4 can communicate, and Server1 and Server2 are isolated from Server3 and Server4.

    This example pings Server2 in the old branch from Server1 in the new branch.
    <Server1> ping 172.16.0.2
    Pinging 172.16.0.2 with 32 bytes of data:
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.0.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.0.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    This example pings Server4 in the old branch from Server1 in the new branch.
    <Server1> ping 172.16.1.2
    Pinging 172.16.1.2 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 172.16.1.2:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Configuration Files

  • Configuration file of Switch1

    #
    sysname Switch1
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port default vlan 2
    #
    interface 10GE1/0/2
     port default vlan 3
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Configuration file of Switch2

    #
    sysname Switch2
    #
    vlan batch 2 to 3
    #
    interface 10GE1/0/1
     port default vlan 2
    #
    interface 10GE1/0/2
     port default vlan 3
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Configuration file of Switch3

    #
    sysname Switch3
    #
    vlan batch 201
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 201
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    return
  • Configuration file of Switch4

    #
    sysname Switch4
    #
    vlan batch 201
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 201
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    return
  • Configuration file of Switch5

    #
    sysname Switch5
    #
    vlan batch 501 to 502
    #
    interface 10GE1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
     port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
     port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    #
    interface 10GE1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
     port vlan-mapping vlan 201 inner-vlan 2 map-vlan 501
     port vlan-mapping vlan 201 inner-vlan 3 map-vlan 502
    #
    interface 10GE1/0/3
     port link-type trunk 
     port trunk allow-pass vlan 501 to 502
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 129355

Downloads: 297

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next