No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic QinQ

Example for Configuring Basic QinQ

Networking Requirements

As shown in Figure 6-7, tenant 1 and tenant 2 in a data center are located in different positions. SwitchA and SwitchB are at the edge of the data center and connected through the core/backbone network.

The requirements are as follows:
  • Tenant 1 and tenant 2 plan their VLANs independently.
  • Traffic of the two tenants is transparently transmitted on the core/backbone network. Devices using the same services in the two branches are allowed to communicate and devices using different services are isolated.
You can configure QinQ to meet the preceding requirements. VLAN 100 and VLAN 200 provided by the core/backbone network can be used to implement communication of tenant 1 and tenant 2 respectively.
Figure 6-7 Networking diagram for configuring QinQ

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure VLAN 100 and VLAN 200 on both SwitchA and SwitchB, and set the link type of interfaces connected to tenants to QinQ and add the interfaces to VLAN so that different outer VLAN tags are added to different tenants.

  2. Add interfaces connected to the core/backbone network on SwitchA and SwitchB to VLAN 100 and VLAN 200 to permit packets from these VLANs to pass through.

Procedure

  1. Create VLANs.

    # Create VLAN 100 and VLAN 200 on SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 200
    [*SwitchA] commit
    

    # Create VLAN 100 and VLAN 200 on SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100 200
    [*SwitchB] commit
    

  2. Set the link type of interfaces to QinQ.

    # Configure 10GE1/0/1 and 10GE1/0/2 on SwitchA as QinQ interfaces, and set outer VLAN tags of 10GE1/0/1 and 10GE1/0/2 to VLAN 100 and VLAN 200 respectively. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type dot1q-tunnel
    [*SwitchA-10GE1/0/1] port default vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type dot1q-tunnel
    [*SwitchA-10GE1/0/2] port default vlan 200
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

  3. Configure the interface connected to the core/backbone network on the switch.

    # Add 10GE1/0/3 on SwitchA to VLAN 100 and VLAN 200. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface 10ge 1/0/3
    [~SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 100 200
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  4. Verify the configuration.

    On a server in a VLAN of tenant 1, ping another server in the same VLAN. The ping operation succeeds, indicating that devices in tenant 1 can communicate with each other.

    On a server in a VLAN of tenant 2, ping another server in the same VLAN. The ping operation succeeds, indicating that devices in tenant 2 can communicate with each other.

    On a server in a VLAN of tenant 2, ping another server in the same VLAN. The ping operation fails, indicating that tenants are isolated.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 79551

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next