No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Transparent Transmission of Protocol Packets in a VLAN

Example for Configuring Transparent Transmission of Protocol Packets in a VLAN

Networking Requirements

In Figure 5-29, a data center network has office servers ServerA and ServerB. ServerA and ServerB belong to VLAN 10 and obtain IP addresses through DHCP. SwitchB is a Layer 2 switching device and has DHCP snooping enabled to defend against DHCP-oriented attacks. In this case, protocol packets in all VLANs are sent to the CPU for processing, and the CPU needs to forward the packets to other devices. This affects the forwarding speed and efficiency of protocol packets. To address this issue, enable transparent transmission of protocol packets in VLAN 10 on SwitchB. After protocol packets from VLAN 10 reach SwitchB, SwitchB directly forwards the protocol packets without sending them to the CPU. This accelerates forwarding of protocol packets.

Figure 5-29 Networking for configuring transparent transmission of protocol packets in a VLAN

Configuration Roadmap

  1. Allocate the downlink interfaces of SwitchA connected to office servers to VLAN 10.

  2. Enable transparent transmission of protocol packets in a VLAN on SwitchB. When protocol packets from a specified VLAN reach SwitchB, SwitchB directly forwards the protocol packets without sending them to the CPU.

Procedure

  1. Add the downlink interfaces on SwitchA to VLAN 10 and configure the uplink interfaces to allow VLAN 10.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit

  2. Enable transparent transmission of protocol packets in a VLAN on SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 10
    [*SwitchB-vlan10] quit
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] vlan 10
    [*SwitchB-vlan10] protocol-transparent
    [*SwitchB-vlan10] quit
    [*SwitchB] commit

  3. Verify the configuration.

    Run the display this command in the view of VLAN 10 on SwitchB. You can see that transparent transmission of protocol packets is enabled in VLAN 10.

    [~SwitchB] vlan 10
    [~SwitchB-vlan10] display this
    #
    vlan 10
     protocol-transparent
    #
    return
    

Configuration Files

Configuration file of SwitchA

#
sysname SwitchA
#
vlan batch 10
#
interface 10GE1/0/1
 port default vlan 10
#
interface 10GE1/0/2
 port default vlan 10
#
interface 10GE1/0/3
 port link-type trunk
 port trunk allow-pass vlan 10
#
return

Configuration file of SwitchB

#
sysname SwitchB
#
vlan batch 10
#
vlan 10
 protocol-transparent
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 10
#
return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 117234

Downloads: 290

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next