No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, MUX VLAN, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN ID-based Selective QinQ

Example for Configuring VLAN ID-based Selective QinQ

Networking Requirements

As shown in Figure 6-8, in a data center, tenants lease office and production service servers. Production services are transmitted in VLANs 10 to 30, and office services are transmitted in VLANs 31 to 50. Tenants are located in positions A and B, and tenant devices are connected through SwitchA and SwitchB of the core/backbone network. The following requirements need to be met to ensure service security and save VLAN IDs of the core/backbone network:
  • Traffic in positions A and B is transmitted through the core/backbone network.
  • Devices transmitting the same service are allowed to communicate, and devices transmitting different services are isolated.
Figure 6-8 Networking for configuring VLAN ID-based selective QinQ

Configuration Roadmap

You can configure VLAN ID-based selective QinQ to meet the preceding requirements. Production service servers communicate in VLAN 100 and office service servers communicate in VLAN 200 of the core/backbone network, and different service servers are isolated.

The configuration roadmap is as follows:

  1. Create VLAN 100 and VLAN 200 on SwitchA and SwitchB, and configure selective QinQ on interfaces of SwitchA and SwitchB so that different VLAN tags are added to different packets of services.

  2. Add interfaces of SwitchA and SwitchB connected to the core/backbone network to VLANs so that packets from VLAN 100 and VLAN 200 are allowed to pass through.

Procedure

  1. Create VLANs.

    # Create VLAN 100 and VLAN 200 on SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 200
    [*SwitchA] commit
    

    # Create VLAN 100 and VLAN 200 on SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100 200
    [*SwitchB] commit
    

  2. Configure selective QinQ on interfaces.

    # Configure 10GE1/0/1 on SwitchA.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type hybrid
    [*SwitchA-10GE1/0/1] port hybrid untagged vlan 100 200
    [*SwitchA-10GE1/0/1] port vlan-stacking vlan 10 to 30 stack-vlan 100
    [*SwitchA-10GE1/0/1] port vlan-stacking vlan 31 to 50 stack-vlan 200
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit
    

    # Configure 10GE1/0/1 on SwitchB.

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] port link-type hybrid
    [*SwitchB-10GE1/0/1] port hybrid untagged vlan 100 200
    [*SwitchB-10GE1/0/1] port vlan-stacking vlan 10 to 30 stack-vlan 100
    [*SwitchB-10GE1/0/1] port vlan-stacking vlan 31 to 50 stack-vlan 200
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit
    

  3. Configure interfaces of SwitchA and SwitchB connected to the core/backbone network.

    # Add 10GE1/0/2 on SwitchA to VLAN 100 and VLAN 200. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100 200
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit

  4. Verify the configuration.

    From a production service server in VLANs 10 to 30 in position A, ping a production service server in the same VLAN in position B. The ping operation succeeds, indicating that production service servers can communicate with each other.

    From an office service server in VLANs 31 to 50 in position A, ping an office service server in the same VLAN in position B. The ping operation succeeds, indicating that office service servers can communicate with each other.

    From a production service server in VLANs 10 to 30 in position A, ping an office service server in VLANs 31 to 50 in position B. The ping operation fails, indicating that services are isolated.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 to 30 stack-vlan 100
     port vlan-stacking vlan 31 to 50 stack-vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface 10GE1/0/1
     port link-type hybrid
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 10 to 30 stack-vlan 100
     port vlan-stacking vlan 31 to 50 stack-vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004351

Views: 80905

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next