No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring ARP

Example for Configuring ARP

Networking Requirements

As shown in Figure 2-20, 10GE1/0/1 of the switch connects to hosts through the LAN Switch (LSW). 10GE1/0/2 connects the Router and visit the server through the Internet. Requirements:
  • 10GE1/0/1 and 10GE1/0/2 should belong to VLAN2 and VLAN3 respectively.
  • Dynamic ARP parameters should be configured for VLANIF2 of the Switch so that packets are transmitted correctly regardless of network typology change.
  • A static ARP entry should be configured on 10GE1/0/2 of the switch to ensure secure communication with the server and prevent illegal ARP packets. The IP address of the router should be 10.2.2.3 and the corresponding MAC address is 00e0-fc01-0000.
Figure 2-20 Networking diagram for configuring ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and add interfaces to the VLANs.
  2. Set dynamic ARP parameters for the user-side VLANIF interface.
  3. Configure a static ARP entry.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Create VLAN2 and VLAN3.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 2 3
    [*Switch] commit
    

    # Add 10GE1/0/1 to VLAN2 and 10GE1/0/2 to VLAN3.

    [~Switch] interface 10ge 1/0/1
    [~Switch-10GE1/0/1] port link-type trunk
    [*Switch-10GE1/0/1] port trunk allow-pass vlan 2
    [*Switch-10GE1/0/1] quit
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port link-type trunk
    [*Switch-10GE1/0/2] port trunk allow-pass vlan 3
    [*Switch-10GE1/0/2] quit
    [*Switch] commit
    

  2. Set dynamic ARP parameters for the VLANIF interface.

    # Create VLANIF2.

    [~Switch] interface vlanif 2

    # Configure an IP address for VLANIF2.

    [*Switch-Vlanif2] ip address 10.1.1.1 255.255.255.0

    # Set the aging time of ARP entries to 60s.

    [*Switch-Vlanif2] arp timeout 60

    # Set the number of probes to ARP entries to 2.

    [*Switch-Vlanif2] arp detect times 2
    [*Switch-Vlanif2] quit
    [*Switch] commit
    

  3. Configure a static ARP entry.

    # Create VLANIF3.

    [~Switch] interface vlanif 3

    # Configure an IP address for VLANIF3.

    [*Switch-Vlanif3] ip address 10.2.2.2 255.255.255.0
    [*Switch-Vlanif3] quit
    [*Switch] commit
    

    # Configure a static ARP entry with IP address 10.2.2.3, MAC address 00e0-fc01-0000, VLAN ID 3, and outbound interface 10GE1/0/2.

    [~Switch] arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10ge 1/0/2
    [*Switch] commit
    [~Switch] quit

  4. # Verify the configuration.

    # Run the display current-configuration command to check the aging time, number of probes, and ARP mapping entries.

    <Switch> display current-configuration | include arp
     arp detect times 2
     arp timeout 60
    arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10GE1/0/2

Configuration File

Configuration file of Switch.

#
sysname Switch
#
vlan batch 2 to 3
#
interface Vlanif2
 ip address 10.1.1.1 255.255.255.0
 arp detect times 2
 arp timeout 60
#
interface Vlanif3
 ip address 10.2.2.2 255.255.255.0
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 2
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 3
#
arp static 10.2.2.3 00e0-fc01-0000 vlan 3 interface 10GE1/0/2
#
return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004354

Views: 72655

Downloads: 147

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next