No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic IPv6 Functions

Example for Configuring Basic IPv6 Functions

Networking Requirements

As shown in Figure 7-16, 10GE1/0/1 of SwitchA connects to 10GE1/0/1 of SwitchB. The two interfaces belong to VLAN 100. An IPv6 global unicast address is configured for VLANIF 100 to allow SwitchA to communicate with SwitchB.

Figure 7-16 Networking diagram for configuring basic IPv6 functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the IPv6 function on switch interfaces.

  2. Configure global unicast IPv6 addresses for the interfaces.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit
    

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 100
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit
    

  2. Enable the IPv6 function on interfaces and configure global unicast addresses for the interfaces.

    # Configure SwitchA.

    [~SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address fc00:1::1/64
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] quit

    # Configure SwitchB.

    [~SwitchB] interface vlanif 100
    [*SwitchB-Vlanif100] ipv6 enable
    [*SwitchB-Vlanif100] ipv6 address fc00:1::2/64
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit
    [~SwitchB] quit

  3. Verify the configuration.

    If the preceding configurations are successful, you can view the configured global unicast addresses. The interface status and the IPv6 protocol are Up. You can also check the neighbor of the interfaces.

    # Check interface information on SwitchA.

    <SwitchA> display ipv6 interface vlanif 100
    Vlanif100 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::C964:0:B8B6:1
      Global unicast address(es):
        FC00:1::1, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF00:1
        FF02::1:FFB6:1
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1
      ND reachable time is 1200000 milliseconds
      ND retransmit interval is 1000 milliseconds
      Hosts use stateless autoconfig for addresses

    # Check interface information on SwitchB.

    <SwitchB> display ipv6 interface vlanif 100
    Vlanif100 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::2D6F:0:7AF3:1
      Global unicast address(es):
        FC00:1::2, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF00:2
        FF02::1:FFF3:1
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1
      ND reachable time is 1200000 milliseconds
      ND retransmit interval is 1000 milliseconds
      Hosts use stateless autoconfig for addresses

    # Ping the link-local address of SwitchB from SwitchA. You must use the parameter -i to specify the interface with the link-local address.

    <SwitchA> ping ipv6 FE80::2D6F:0:7AF3:1 -i vlanif 100
      PING FE80::2D6F:0:7AF3:1 : 56  data bytes, press CTRL_C to break
        Reply from FE80::2D6F:0:7AF3:1
        bytes=56 Sequence=1 hop limit=64  time = 7 ms
        Reply from FE80::2D6F:0:7AF3:1
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FE80::2D6F:0:7AF3:1
        bytes=56 Sequence=3 hop limit=64  time = 3 ms
        Reply from FE80::2D6F:0:7AF3:1
        bytes=56 Sequence=4 hop limit=64  time = 3 ms
        Reply from FE80::2D6F:0:7AF3:1
        bytes=56 Sequence=5 hop limit=64  time = 3 ms
    
      --- FE80::2D6F:0:7AF3:1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/3/7 ms
    

    # Ping the global unicast IPv6 address of SwitchB from SwitchA. The global unicast IPv6 address can be pinged successfully.

    <SwitchA> ping ipv6 FC00:1::2
      PING FC00:1::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::2
        bytes=56 Sequence=1 hop limit=64  time = 12 ms
        Reply from FC00:1::2
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=3 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=4 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=5 hop limit=64  time = 3 ms
    
      --- FC00:1::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/4/12 ms
    

Configuration File

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:1::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:1::2/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004354

Views: 72995

Downloads: 147

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next