No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Routed Proxy ARP

Example for Configuring Routed Proxy ARP

Networking Requirements

In Figure 2-21, Ethernet interfaces 10GE1/0/1 and 10GE1/0/2 connect to two LANs respectively. The two LANs are at the same network segment 172.16.0.0/16. ServerA and ServerB have no default gateway. Routed proxy ARP is required to be configured on the switch so that servers on two LANs can communicate.

Figure 2-21 Networking diagram for configuring routed proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces.

  2. Enable routed proxy ARP on interfaces.

Procedure

  1. Create VLAN2 and add 10GE1/0/2 to VLAN2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] quit
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port default vlan 2
    [*Switch-10GE1/0/2] quit
    [*Switch] commit

  2. Create and configure VLANIF2.

    [~Switch] interface vlanif 2
    [*Switch-Vlanif2] ip address 172.16.1.1 255.255.255.0

  3. Enable routed proxy ARP on VLANIF2.

    [*Switch-Vlanif2] arp proxy enable
    [*Switch-Vlanif2] quit
    [*Switch] commit

  4. Create VLAN3 and add 10GE1/0/1 to VLAN3.

    [~Switch] vlan batch 3
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port default vlan 3
    [*Switch-10GE1/0/1] quit
    [*Switch] commit

  5. Create and configure VLANIF3.

    [~Switch] interface vlanif 3
    [*Switch-Vlanif3] ip address 172.16.2.1 255.255.255.0

  6. Enable routed proxy ARP on VLANIF3.

    [*Switch-Vlanif3] arp proxy enable
    [*Switch-Vlanif3] quit
    [*Switch] commit

  7. Configure servers.

    # Configure IP address 172.16.1.2/16 for ServerA.

    # Configure IP address 172.16.2.2/16 for ServerB.

  8. Verify the configuration.

    # Ping ServerB from ServerA. ServerA can ping ServerB successfully.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 3
#
interface Vlanif2
 ip address 172.16.1.1 255.255.255.0
 arp proxy enable
#
interface Vlanif3
 ip address 172.16.2.1 255.255.255.0
 arp proxy enable
#
interface 10GE1/0/1
 port default vlan 3 
#
interface 10GE1/0/2
 port default vlan 2 
#
return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004354

Views: 72234

Downloads: 147

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next