No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Proxy ARP Anyway

Example for Configuring Proxy ARP Anyway

This section provides an example for configuring proxy ARP anyway.

Networking Requirements

Two VMs on the same network segment are physically divided into two subnets. The gateways connected to the VMs have the same IP address. The two VMs are required to communicate with each other.

As shown in Figure 2-22, there is a reachable route between DeviceA and DeviceB. If DeviceA or DeviceB is not required to determine whether a route to a destination VM exists and the other VMs in the same subnet will not respond to an ARP request from a source VM, you can configure proxy ARP anyway on the gateways to allow the two VMs in different subnets to communicate with each other.

Figure 2-22 Networking diagram for configuring proxy ARP anyway

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a VLAN so that the VMs which need to communicate with each other reside in the same VLAN.

  2. Configure interface attributes and bind the interfaces to the VLAN.

  3. Configure IP addresses for interfaces.

  4. Configure proxy ARP anyway on VLANIF interfaces to which VMs are connected. After receiving an ARP request (for a destination VM's MAC address) from a source VM, the gateway enabled with proxy ARP anyway responds with its own MAC address for subsequent data forwarding.

  5. Configure the function of advertising host routes generated based on ARP entries on the VLANIF interface of the devices.

  6. Block the broadcast of outgoing ARP request packets on the device.

Data Preparation

To complete the configuration, you need the following data:

  • ID of the VLAN to which devices and VMs belong.

  • Same IP address of the interfaces to which VMs are connected

  • IP addresses of VMs

Procedure

  1. Create a VLAN.

    NOTE:

    Configure the same VLAN ID on DeviceA and DeviceB.

    # Configure DeviceA.
    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] vlan 10
    [*DeviceA-vlan10] commit
    [~DeviceA-vlan10] quit
    # Configure DeviceB.
    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] vlan 10
    [*DeviceB-vlan10] commit
    [~DeviceB-vlan10] quit

  2. Configure interface attributes and bind interfaces to the VLAN.

    # Configure DeviceA.
    [~DeviceA] interface 10ge 1/0/1
    [~DeviceA-10GE1/0/1] port link-type access
    [*DeviceA-10GE1/0/1] commit
    [~DeviceA-10GE1/0/1] quit
    [~DeviceA] vlan 10
    [~DeviceA-vlan10] port 10ge 1/0/1
    [*DeviceA-vlan10] commit
    [~DeviceA-vlan10] quit
    # Configure DeviceB.
    [~DeviceB] interface 10ge 1/0/1
    [~DeviceB-10GE1/0/1] port link-type access
    [*DeviceB-10GE1/0/1] commit
    [~DeviceB-10GE1/0/1] quit
    [~DeviceB] vlan 10
    [~DeviceB-vlan10] port 10ge 1/0/1
    [*DeviceB-vlan10] commit
    [~DeviceB-vlan10] quit

  3. Configure IP addresses for interfaces.

    NOTE:

    Configure the same VLANIF interface address on DeviceA and DeviceB.

    # Configure DeviceA.
    [~DeviceA] interface vlanif 10
    [*DeviceA-Vlanif10] ip address 172.16.1.1 24
    [*DeviceA-Vlanif10] commit
    [~DeviceA-Vlanif10] quit
    # Configure DeviceB.
    [~DeviceB] interface vlanif 10
    [*DeviceB-Vlanif10] ip address 172.16.1.1 24
    [*DeviceB-Vlanif10] commit
    [~DeviceB-Vlanif10] quit

  4. Configure proxy ARP anyway and the function of advertising host routes that are generated based on ARP entries.

    # Configure DeviceA.
    [~DeviceA] interface vlanif 10
    [~DeviceA-Vlanif10] arp proxy anyway enable
    [*DeviceA-Vlanif10] arp direct-route enable
    [*DeviceA-Vlanif10] commit
    [~DeviceA-Vlanif10] quit
    # Configure DeviceB.
    [~DeviceB] interface vlanif 10
    [~DeviceB-Vlanif10] arp proxy anyway enable
    [*DeviceB-Vlanif10] arp direct-route enable
    [*DeviceB-Vlanif10] commit
    [~DeviceB-Vlanif10] quit

  5. Block the broadcast of outgoing ARP request packets on the device.

    NOTE:
    After the proxy ARP anyway function is enabled, broadcasting outgoing ARP request packets needs to be blocked.
    • If only ARP request packets need to be broadcast, run the storm suppression broadcast block outbound command on the physical interface where proxy ARP anyway is enabled to block outgoing broadcast packets. For example, if proxy ARP anyway is enabled on a VLANIF interface, run the storm suppression broadcast block outbound command on the VLAN member interface corresponding to the VLANIF interface.
    • If other packets in addition to ARP request packets need to be broadcast, configure an MQC traffic policy to block the broadcast of outgoing ARP request packets and allow other packets to be broadcast.

    This example lists configuration steps for blocking all broadcast packets. For blocking the broadcast of only ARP request packets, deploy MQC traffic policies according to the actual network environment.

    # Configure DeviceA.
    [~DeviceA] interface 10ge 1/0/1
    [~DeviceA-10GE1/0/1] storm suppression broadcast block outbound
    [*DeviceA-10GE1/0/1] commit
    [~DeviceA-10GE1/0/1] quit
    # Configure DeviceB.
    [~DeviceB] interface 10ge 1/0/1
    [~DeviceB-10GE1/0/1] storm suppression broadcast block outbound
    [*DeviceB-10GE1/0/1] commit
    [~DeviceB-10GE1/0/1] quit

  6. Configure VMs.

    # Configure the IP address of VM1 as 172.16.1.2/24.

    # Configure the IP address of VM2 as 172.16.1.4/24.

  7. Verify the configuration.

    # Ping the IP address of VM2 on VM1 to check whether the IP address is reachable.

Configuration Files

  • Configuration file of DeviceA.

    #
    sysname DeviceA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     arp proxy anyway enable
     arp direct-route enable
    #
    interface 10GE1/0/1
     port default vlan 10
     storm suppression broadcast block outbound
    #
    return
  • Configuration file of DeviceB.

    #
    sysname DeviceB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     arp proxy anyway enable
     arp direct-route enable
    #
    interface 10GE1/0/1
     port default vlan 10
     storm suppression broadcast block outbound
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004354

Views: 72908

Downloads: 147

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next