No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Link Redundancy in a Smart Link Group

Example for Configuring Link Redundancy in a Smart Link Group

Networking Requirements

As shown in Figure 5-16, a dual-homing networking is used to enhance network reliability. The customer wants to eliminate loops on the network while implementing link redundancy and fast convergence.

Figure 5-16 Link redundancy in a Smart Link group

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and configure related interfaces to allow packets of these VLANs to pass through.

  2. Create a Smart Link group on SwitchA and specify the master and slave interfaces.

  3. Enable revertive switching on SwitchA to enable traffic to be switched back to the original active link after the active link recovers.

  4. Enable SwitchA to send Flush packets.

  5. Enable interfaces on SwitchB, SwitchC, and SwitchD to receive Flush packets.

  6. Enable the Smart Link group on SwitchA.

Procedure

  1. Configure VLANs

    # Create VLANs on SwitchA and configure related interfaces to allow packets of these VLANs to pass through. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 to 30 
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10 to 30
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10 to 30
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    

  2. Create a Smart Link group on SwitchA and specify the master and slave interfaces.

    # Configure SwitchA.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] stp disable
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] stp disable
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    [~SwitchA] smart-link group 1
    [*SwitchA-smlk-group1] port 10ge 1/0/1 master
    [*SwitchA-smlk-group1] port 10ge 1/0/2 slave
    [*SwitchA-smlk-group1] commit

  3. Enable revertive switching and set the WTR time.

    # Configure SwitchA.

    [~SwitchA-smlk-group1] restore enable
    [*SwitchA-smlk-group1] timer wtr 120
    [*SwitchA-smlk-group1] commit

  4. Enable SwitchA to send Flush packets.

    # Configure SwitchA to send Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchA-smlk-group1] flush send control-vlan 10 password hmac-sha256 123
    [*SwitchA-smlk-group1] commit

  5. Enable interfaces on SwitchB, SwitchC, and SwitchD to receive Flush packets.

    # Enable SwitchB to receive Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] stp disable
    [*SwitchB-10GE1/0/1] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit
    [~SwitchB] interface 10ge 1/0/2
    [~SwitchB-10GE1/0/2] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchB-10GE1/0/2] commit
    [~SwitchB-10GE1/0/2] quit
    

    # Enable SwitchC to receive Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchC] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] stp disable
    [*SwitchC-10GE1/0/1] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchC-10GE1/0/1] commit
    [~SwitchC-10GE1/0/1] quit
    [~SwitchC] interface 10ge 1/0/2
    [~SwitchC-10GE1/0/2] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchC-10GE1/0/2] commit
    [~SwitchC-10GE1/0/2] quit
    

    # Enable SwitchD to receive Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchD] interface 10ge 1/0/1
    [~SwitchD-10GE1/0/1] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchD-10GE1/0/1] commit
    [~SwitchD-10GE1/0/1] quit
    [~SwitchD] interface 10ge 1/0/2
    [~SwitchD-10GE1/0/2] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchD-10GE1/0/2] commit
    [~SwitchD-10GE1/0/2] quit
    

  6. Enable the Smart Link group on SwitchA.

    [~SwitchA-smlk-group1] smart-link enable
    [*SwitchA-smlk-group1] commit
    [~SwitchA-smlk-group1] quit

  7. Verify the configuration.

    # Run the display smart-link group command to view information about the Smart Link group on SwitchA. If the following information is displayed, the configuration is successful:

    • The Smart Link function is enabled.
    • The WTR time is 120s.
    • The control VLAN ID is 10.
    • 10GE1/0/1 is the master interface and is in Active state, whereas 10GE1/0/2 is the slave interface and is in Inactive state.
    [~SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 120 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/0/1    Master           0  Active               0  0000/00/00 00:00:00 UTC+00:00
      10GE1/0/2    Slave            0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
    

    # Run the shutdown command to shut down 10GE1/0/1. Then 10GE1/0/1 changes to Inactive state and 10GE1/0/2 changes to Active state.

    [~SwitchA] system-view
    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 120 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      ------------------------------------------------------------------------------------
      10GE1/0/1    Master           0  Inactive             0  0000/00/00 00:00:00 UTC+00:00
      10GE1/0/2    Slave            0  Active               1  2013/05/05 10:34:46 UTC+00:00
    

    # Run the undo shutdown command to restore 10GE1/0/1.

    [~SwitchA-10GE1/0/1] undo shutdown
    [*SwitchA-10GE1/0/1] commit

    # After 120s, 10GE1/0/1 is in Active state and 10GE1/0/2 is in Inactive state.

    [~SwitchA-10GE1/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 120 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      -----------------------------------------------------------------------------------
      10GE1/0/1    Master           0  Active               1  2013/05/05 10:35:46 UTC+00:00
      10GE1/0/2    Slave            0  Inactive             1  2013/05/05 10:34:46 UTC+00:00
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 to 30
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    smart-link group 1
     restore enable
     smart-link enable
     port 10GE1/0/1 master
     port 10GE1/0/2 slave
     timer wtr 120
     flush send control-vlan 10 password hmac-sha256 
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 to 30
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#Ep7t@o-'kXRUn$Lwgf22l+{8Ryqof3i+6z&$V\</%^%#
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#iu+l&X\dP3}",:H'1F#PBIp`1a3GB'v0sUK]2zxO%^%#
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10 to 30
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#[:95Guh"OENC;];s3nN8K++m=^Bg*ZtRBRO0ZV66%^%#
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#yQWMQ~1a{,`#C)IvAvt16~MDIzYY!.\E#Q>6qE=~%^%#
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10 to 30
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#;Bw$EMeC,".A@u1Xd%CO];DdK'+'Q*Xi,0'M%46+%^%#
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#w~T5!@We"Pj1w*Ch$%-27+B.Y~~D&+=H>(%!{s\'%^%#
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004359

Views: 61850

Downloads: 128

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next