No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Combining Monitor Link and Smart Link on a Network

Example for Combining Monitor Link and Smart Link on a Network

Networking Requirements

As shown in Figure 5-18, SwitchC is connected to user networks and is dual-homed to SwitchA and SwitchB, which are connected to the backbone network.

A monitoring mechanism is required to prevent service interruption caused by uplink failures. If an uplink fails, the downlinks can rapidly detect the failure and trigger link switching immediately to minimize the service interruption time.

Figure 5-18 Combination of Smart Link and Monitor Link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a Smart Link group on SwitchA and SwitchC and add corresponding interfaces to the Smart Link groups.
  2. Enable SwitchA and SwitchC to send Flush packets.
  3. Enable SwitchA and SwitchB to receive Flush packets.
  4. Configure a Monitor Link group on SwitchA and configure the Smart Link group as an uplink. In this way, the Smart Link group improves the uplink reliability in the Monitor Link group.
  5. Configure a Monitor Link group on SwitchB to enable the Smart Link group on SwitchC to rapidly detect uplink failures. This configuration widens the application scope of Smart Link.

Procedure

  1. Configure the control VLAN on SwitchA, SwitchB and SwitchC. Add the interfaces of the Smart Link or Monitor Link groups to this VLAN.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here. For details, see the configuration files.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 2/0/1
    [*SwitchA-10GE2/0/1] port link-type trunk
    [*SwitchA-10GE2/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE2/0/1] quit
    [*SwitchA] interface 10ge 2/0/2
    [*SwitchA-10GE2/0/2] port link-type trunk
    [*SwitchA-10GE2/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE2/0/2] quit
    [*SwitchA] commit

  2. Create Smart Link groups.

    # Configure SwitchA.

    [~SwitchA] smart-link group 1
    [*SwitchA-smlk-group1] commit
    [~SwitchA-smlk-group1] quit

    # Configure SwitchC.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] smart-link group 2
    [*SwitchC-smlk-group2] commit
    [~SwitchC-smlk-group2] quit

  3. Add interfaces to the Smart Link groups and specify the master and slave interfaces.

    # Configure SwitchA.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] stp disable
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] stp disable
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    [~SwitchA] smart-link group 1
    [*SwitchA-smlk-group1] port 10ge 1/0/1 master
    [*SwitchA-smlk-group1] port 10ge 1/0/2 slave
    [*SwitchA-smlk-group1] commit

    # Configure SwitchC.

    [~SwitchC] interface 10ge 1/0/1
    [~SwitchC-10GE1/0/1] stp disable
    [*SwitchC-10GE1/0/1] commit
    [~SwitchC-10GE1/0/1] quit
    [~SwitchC] interface 10ge 1/0/2
    [~SwitchC-10GE1/0/2] stp disable
    [*SwitchC-10GE1/0/2] commit
    [~SwitchC-10GE1/0/2] quit
    [~SwitchC] smart-link group 2
    [*SwitchC-smlk-group2] port 10ge 1/0/1 master
    [*SwitchC-smlk-group2] port 10ge 1/0/2 slave
    [*SwitchC-smlk-group2] commit

  4. Enable revertive switching and set the WTR time.

    # Configure SwitchA.

    [*SwitchA-smlk-group1] restore enable
    [*SwitchA-smlk-group1] timer wtr 120
    [*SwitchA-smlk-group1] commit

    # Configure SwitchC.

    [*SwitchC-smlk-group2] restore enable
    [*SwitchC-smlk-group2] timer wtr 120
    [*SwitchC-smlk-group2] commit

  5. Enable SwitchA and SwitchC to send Flush packets, and enable SwitchA and SwitchB to receive Flush packets.

    # Configure SwitchA to send and receive Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchA-smlk-group1] flush send control-vlan 10 password hmac-sha256 123
    [*SwitchA-smlk-group1] commit
    [~SwitchA-smlk-group1] quit
    [~SwitchA] interface 10ge 2/0/1
    [~SwitchA-10GE2/0/1] stp disable
    [*SwitchA-10GE2/0/1] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchA-10GE2/0/1] commit
    [~SwitchA-10GE2/0/1] quit
    [~SwitchA] interface 10ge 2/0/2
    [~SwitchA-10GE2/0/2] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchA-10GE2/0/2] commit
    [~SwitchA-10GE2/0/2] quit
    

    # Configure SwitchB to receive Flush packets containing an HMAC-SHA256-encrypted password.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] interface 10ge 2/0/1
    [~SwitchB-10GE2/0/1] stp disable
    [*SwitchB-10GE2/0/1] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchB-10GE2/0/1] commit
    [~SwitchB-10GE2/0/1] quit
    [~SwitchB] interface 10ge 2/0/2
    [~SwitchB-10GE2/0/2] smart-link flush receive control-vlan 10 password hmac-sha256 123
    [*SwitchA-10GE2/0/2] commit
    [~SwitchB-10GE2/0/2] quit
    

    # Configure SwitchC to receive Flush packets containing an HMAC-SHA256-encrypted password.

    [~SwitchC-smlk-group2] flush send control-vlan 10 password hmac-sha256 123
    [*SwitchC-smlk-group2] commit
    [~SwitchC-smlk-group2] quit

  6. Enable the Smart Link groups.

    # Configure SwitchA.

    [~SwitchA] smart-link group 1
    [*SwitchA-smlk-group1] smart-link enable
    [*SwitchA-smlk-group1] commit
    [~SwitchA-smlk-group1] quit

    # Configure SwitchC.

    [~SwitchC] smart-link group 2
    [*SwitchC-smlk-group2] smart-link enable
    [*SwitchC-smlk-group2] commit
    [~SwitchC-smlk-group2] quit

  7. Create a Monitor Link group and add uplink and downlink interfaces to the Monitor Link group.

    # Configure SwitchA.

    [~SwitchA] monitor-link group 1
    [*SwitchA-mtlk-group1] smart-link group 1 uplink
    [*SwitchA-mtlk-group1] port 10ge 2/0/1 downlink 1
    [*SwitchA-mtlk-group1] commit

    # Configure SwitchB.

    [~SwitchB] monitor-link group 2
    [*SwitchB-mtlk-group2] port 10ge 1/0/1 uplink
    [*SwitchB-mtlk-group2] port 10ge 2/0/1 downlink 1
    [*SwitchB-mtlk-group2] commit

  8. Set the WTR time of the Monitor Link group.

    # Configure SwitchA.

    [~SwitchA-mtlk-group1] timer recover-time 10
    [*SwitchA-mtlk-group1] commit
    [*SwitchA-mtlk-group1] quit

    # Configure SwitchB.

    [~SwitchB-mtlk-group2] timer recover-time 10
    [*SwitchB-mtlk-group2] commit
    [*SwitchB-mtlk-group2] quit

  9. Verify the configuration.

    [~SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group: enabled
      Wtr-time is: 120 sec.
      Load-Balance Instance: --                                                                                                         
      Protected-VLAN reference-instance: --
      DeviceID: 0018-2000-0083  Control-VLAN ID: 10
      Member       Role    InstanceID  State      Flush Count  Last-Flush-Time
      ------------------------------------------------------------------------
      10GE1/0/1    Master           0  Active               0  0000/00/00 00:00:00 UTC+05:00
      10GE1/0/2    Slave            0  Inactive             0  0000/00/00 00:00:00 UTC+05:00
    
    [~SwitchA] display monitor-link group 1
    Monitor Link group 1 information : 
      Recover-timer is 10 sec.                                                       
        Member   Role     State Last-up-time                       Last-down-time 
     Smart-link1 UpLk     UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
     10GE2/0/1   DwLk[1]  UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#~c+p$W[eADi"zB!@-Nh"jtHO)L7YQ2V~wcC27#D/%^%#
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#Ep7t@o-'kXRUn$Lwgf22l+{8Ryqof3i+6z&$V\</%^%#
    #
    smart-link group 1
     restore enable
     smart-link enable 
     port 10GE1/0/1 master
     port 10GE1/0/2 slave 
     timer wtr 120
     flush send control-vlan 10 password hmac-sha256 %^%#iu+l&X\dP3}",:H'1F#PBIp`1a3GB'v0sUK]2zxO%^%#
    #
    monitor-link group 1
     smart-link group 1 uplink
     port 10GE2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#[:95Guh"OENC;];s3nN8K++m=^Bg*ZtRBRO0ZV66%^%#
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     smart-link flush receive control-vlan 10 password hmac-sha256 %^%#yQWMQ~1a{,`#C)IvAvt16~MDIzYY!.\E#Q>6qE=~%^%#
    #
    monitor-link group 2
     port 10GE1/0/1 uplink
     port 10GE2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    smart-link group 2
     restore enable
     smart-link enable 
     port 10GE1/0/1 master
     port 10GE1/0/2 slave 
     timer wtr 120
     flush send control-vlan 10 password hmac-sha256 %^%#;Bw$EMeC,".A@u1Xd%CO];DdK'+'Q*Xi,0'M%46+%^%#
    #
    return
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004359

Views: 66032

Downloads: 129

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next