No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R003C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VRRP Group in Active/Standby Mode

Example for Configuring a VRRP Group in Active/Standby Mode

Networking Requirements

In Figure 3-18, HostA is dual-homed to SwitchA and SwitchB through the switch. The requirements are as follows:
  • The host uses SwitchA as the default gateway to connect to the Internet. When SwitchA becomes faulty, SwitchB functions as the gateway. This implements gateway backup.

  • After SwitchA recovers, it becomes the gateway again.

Figure 3-18 Networking diagram for configuring a VRRP group

Device

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/1

VLANIF 300

192.168.1.1/24

10GE1/0/2

VLANIF 100

10.1.1.1/24

SwitchB

10GE1/0/1

VLANIF 200

192.168.2.1/24

10GE1/0/2

VLANIF 100

10.1.1.2/24

SwitchC

10GE1/0/1

VLANIF 300

192.168.1.2/24

10GE1/0/2

VLANIF 200

192.168.2.2/24

10GE1/0/3

VLANIF 400

172.16.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP group on SwitchA and SwitchB and set a higher priority for SwitchA so that SwitchA functions as the master to forward traffic. Then, set the preemption delay to 20s on SwitchA, and set a lower priority for SwitchB so that SwitchB functions as the backup.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 300
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 300
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/2] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 300
    [*SwitchA-Vlanif300] ip address 192.168.1.1 24
    [*SwitchA-Vlanif300] quit
    [*SwitchA] commit

    # Configure OSPF between SwitchA, SwitchB, and SwitchC. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [~SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Configure VRRP groups.

    # Configure VRRP group 1 on SwitchA, and set the priority of SwitchA to 120 and the preemption delay to 20s.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*SwitchA-Vlanif100] vrrp vrid 1 priority 120
    [*SwitchA-Vlanif100] vrrp vrid 1 preempt timer delay 20
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

    # Configure VRRP group 1 on SwitchB. SwitchB uses the default priority of 100.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

  3. Verify the configuration.

    # After the configuration is complete, run the display vrrp command on SwitchA and SwitchB. You can see that SwitchA is in Master state and SwitchB is in Backup state.

    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.111
    Master IP      : 10.1.1.1
    PriorityRun    : 120
    PriorityConfig : 120                                                        
    MasterPriority : 120                                                        
    Preempt        : YES   Delay Time : 20s   Remain : --    
    TimerRun       : 1s                                                              
    TimerConfig    : 1s                                                           
    Auth Type      : NONE                                                            
    Virtual MAC    : 0000-5e00-0101                                                
    Check TTL      : YES                                                             
    Config Type    : Normal                                                   
    Create Time       : 2012-05-11 11:39:18                                           
    Last Change Time  : 2012-05-26 11:38:58 
    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Backup
    Virtual IP     : 10.1.1.111
    Master IP      : 10.1.1.1
    PriorityRun    : 100
    PriorityConfig : 100                                                        
    MasterPriority : 120                                                        
    Preempt        : YES   Delay Time : 0s   Remain : --     
    TimerRun       : 1s                                                        
    TimerConfig    : 1s                                                        
    Auth Type      : NONE                                                       
    Virtual MAC    : 0000-5e00-0101                                             
    Check TTL      : YES                                                        
    Config Type    : Normal                                                
    Create Time      : 2012-05-11 11:39:18                                      
    Last Change Time : 2012-05-26 11:38:58 

    # Run the shutdown command on 10GE1/0/2 of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] shutdown
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit

    Run the display vrrp command on SwitchB to view the VRRP status. The command output shows that SwitchB is in Master state.

    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.111
    Master IP      : 10.1.1.2
    PriorityRun    : 100
    PriorityConfig : 100                                                        
    MasterPriority : 100                                                        
    Preempt        : YES   Delay Time : 0s   Remain : --     
    TimerRun       : 1s                                                        
    TimerConfig    : 1s                                                        
    Auth Type      : NONE                                                       
    Virtual MAC    : 0000-5e00-0101                                             
    Check TTL      : YES                                                        
    Config Type    : Normal                                                
    Create Time      : 2012-05-11 11:39:18                                      
    Last Change Time : 2012-05-26 11:38:58 

    # Run the undo shutdown command on 10GE1/0/2 of SwitchA. After 20s, run the display vrrp command on SwitchA to view the VRRP status. SwitchA restores the Master state.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] undo shutdown
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State        : Master
    Virtual IP     : 10.1.1.111
    Master IP      : 10.1.1.1
    PriorityRun    : 120
    PriorityConfig : 120                                                        
    MasterPriority : 120                                                        
    Preempt        : YES   Delay Time : 20s   Remain : --    
    TimerRun       : 1s                                                        
    TimerConfig    : 1s                                                        
    Auth Type      : NONE                                                       
    Virtual MAC    : 0000-5e00-0101                                             
    Check TTL      : YES                                                        
    Config Type    : Normal                                                
    Create Time      : 2012-05-11 11:39:18                                      
    Last Change Time : 2012-05-26 11:38:58 

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 300
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt timer delay 20
    #
    interface Vlanif300
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif400
     ip address 172.16.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-05-08

Document ID: EDOC1100004359

Views: 61585

Downloads: 128

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next