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eSight V300R009C00 Single-Node System Software Installation Guide (SUSE Linux) 09

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Data Backup Fails When a Non-default SQL Server Database Instance Is Used to Install the eSight

Data Backup Fails When a Non-default SQL Server Database Instance Is Used to Install the eSight

Symptom

On Windows operating system, a non-default instance of the SQL Server database is used to install the eSight system. Backing up the eSight data fails and the illegal user or keyvalue message is displayed.

Possible Causes

  • A hidden instance is configured on the SQL Server. When the maintenance tool attempts to connect to the database using IP address and database instance (for example, osql -S127.0.0.1\MSSQLSERVER -Usa -PChangeme@@123), the connection fails.
  • The SQL Server Browser service is disabled by default. But the maintenance tool attempts to connect to the database using IP address and database instance (for example, osql -S127.0.0.1\MSSQLSERVER -Usa -PChangeme@@123).

Procedure

  1. Open the SQL Server configuration manager of the SQL Server database.
  2. In the Sql Server Configuration Manager window, choose SQL Server Network Configuration > Protocols for xxx, right-click and choose Properties from the shortcut menu.

    NOTE:

    Here, xxx indicates the name of the database instance.

  3. In the dialog box that is displayed, select NO from the Hide Instance drop-down list box and click OK.
  4. In the Sql Server Configuration Manager window, in the left navigation pane, click SQL Server Services.
  5. In the Sql Server Configuration Manager window, right-click SQL Server Browser and choose Properties from the shortcut menu.
  6. In the SQL Server Browser Properties window, click the Service tab.

    Set Start Mode to Automatic and click OK, as shown in the following figure:

  7. Right-click SQL Server Browser and choose Start from the shortcut menu.

  8. Perform a backup again.
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Updated: 2019-05-17

Document ID: EDOC1100011860

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