No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - MPLS 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the IP-Prefix Tunnel Function to Automatically Establish MPLS TE Tunnels in a Batch

Example for Configuring the IP-Prefix Tunnel Function to Automatically Establish MPLS TE Tunnels in a Batch

This section provides an example for configuring the ip-prefix tunnel function to automatically establish MPLS TE tunnels in a batch.

Networking Requirements

In Figure 3-24, a customer expects to establish MPLS TE tunnels to form a full-mesh network and configure Auto FRR for each tunnel. Establishing tunnels one by one is laborious and complex. In this case, the ip-prefix tunnel function can be configured to automatically establish MPLS tunnels in a batch.

Figure 3-24  Configuring the ip-prefix tunnel function to automatically establish MPLS TE tunnels in a batch
Table 3-16  Interfaces and their IP addresses on each device

Device Name

Interface Name

IP Address and Mask

LSRA

Loopback0

1.1.1.9/32

GE 1/0/0

10.1.1.1/24

GE 1/0/1

10.1.2.1/24

LSRB

Loopback0

2.2.2.9/32

GE 1/0/0

10.1.1.2/24

GE 1/0/1

10.1.3.1/24

LSRC

Loopback0

3.3.3.9/32

GE 1/0/1

10.1.2.2/24

GE 1/0/2

10.1.3.2/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IS-IS and IS-IS TE.

  2. Enable MPLS TE and BFD globally on each device.

  3. Configure an IP prefix list.

  4. Configure a P2P TE tunnel template.

  5. Configure the automatic primary tunnel function.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of each interface on each node: values shown in Figure 3-24

  • LSR ID of each node: loopback addresses shown in Figure 3-24

  • IS-IS process number (1), IS-IS level (level-2), and network entity name of each node:

    • LSRA: 10.0000.0000.0001.00
    • LSRC: 10.0000.0000.0002.00
    • LSRB: 10.0000.0000.0003.00
  • IP prefix name on each node: te-tunnel

  • P2P TE tunnel template name on each node: te-tunnel

Procedure

  1. Assign an IP address to each interface. For configuration details, see Configuration Files in this section.
  2. Configure IS-IS and IS-IS TE. For configuration details, see Configuration Files in this section.
  3. Enable MPLS TE and Auto FRR globally on each device. For configuration details, see Configuration Files in this section.
  4. Configure an IP prefix list.

    # Configure LSRA.

    [~LSRA] ip ip-prefix te-tunnel permit 2.2.2.9 32
    [*LSRA] ip ip-prefix te-tunnel permit 3.3.3.9 32
    [*LSRA] commit

    The configurations on LSRB and LSRC are similar to the configuration on LSRA. For configuration details, see Configuration Files in this section.

  5. Configure a P2P TE tunnel template.

    # Configure LSRA.

    [~LSRA] mpls te p2p-template te-tunnel 
    [*LSRA-te-p2p-template-te-tunnel] bandwidth ct0 1000
    [*LSRA-te-p2p-template-te-tunnel] fast-reroute
    [*LSRA-te-p2p-template-te-tunnel] commit
    [~LSRA-te-p2p-template-te-tunnel] quit

    The configurations on LSRB and LSRC are similar to the configuration on LSRA. For configuration details, see Configuration Files in this section.

  6. Configure the automatic primary tunnel function.

    # Configure LSRA.

    [~LSRA] mpls te auto-primary-tunnel ip-prefix te-tunnel p2p-template te-tunnel 
    [*LSRA] commit

    The configurations on LSRB and LSRC are similar to the configuration on LSRA. For configuration details, see Configuration Files in this section.

  7. Verify the configuration.

    # After completing the preceding configuration, run the display mpls te tunnel command on LSRA. The command output shows that MPLS TE tunnels have been established.
    [~LSRA] display mpls te tunnel
    -------------------------------------------------------------------------------
    Ingress LsrId   Destination     LSPID In/OutLabel     R Tunnel-name
    -------------------------------------------------------------------------------
    1.1.1.9         2.2.2.9         1     -/3             I AutoTunnel32769
    2.2.2.9         1.1.1.9         1     3/-             E AutoTunnel32769
    3.3.3.9         1.1.1.9         1     3/-             E AutoTunnel32769
    1.1.1.9         3.3.3.9         2     -/3             I AutoTunnel32770
    1.1.1.9         3.3.3.9         3     -/32828         I AutoTunnel32771
    2.2.2.9         3.3.3.9         3     32828/3         T AutoTunnel32771
    3.3.3.9         2.2.2.9         3     32829/3         T AutoTunnel32771
    1.1.1.9         2.2.2.9         4     -/32828         I AutoTunnel32772
    2.2.2.9         1.1.1.9         4     3/-             E AutoTunnel32772
    3.3.3.9         1.1.1.9         4     3/-             E AutoTunnel32772
    -------------------------------------------------------------------------------
    R: Role, I: Ingress, T: Transit, E: Egress

    Obtain a tunnel name, for example, AutoTunnel32769, displayed in the Tunnel-name column. Run the display mpls te tunnel-interface auto-primary-tunnel AutoTunnel32769 command to view detailed information about the specified tunnel.

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     mpls te
     mpls te auto-frr
     mpls rsvp-te
     mpls te cspf
    #
    mpls te p2p-template te-tunnel
     record-route label
     bandwidth ct0 1000
     fast-reroute
    #
    mpls te auto-primary-tunnel ip-prefix te-tunnel p2p-template te-tunnel
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0001.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface LoopBack0
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
     #
    ip ip-prefix te-tunnel index 10 permit 2.2.2.9 32 
    ip ip-prefix te-tunnel index 20 permit 3.3.3.9 32 
    #
    return
    
  • LSRB configuration file

    #
    sysname LSRB
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
     mpls te
     mpls te auto-frr
     mpls rsvp-te
     mpls te cspf
    #
    mpls te p2p-template te-tunnel
     record-route label
     bandwidth ct0 1000
     fast-reroute
    #
    mpls te auto-primary-tunnel ip-prefix te-tunnel p2p-template te-tunnel
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0002.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.3.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface LoopBack0
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #               
    ip ip-prefix te-tunnel index 10 permit 1.1.1.9 32 
    ip ip-prefix te-tunnel index 20 permit 3.3.3.9 32 
    #
    return
    
  • LSRC configuration file

    #
    sysname LSRC
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
     mpls te
     mpls te auto-frr
     mpls rsvp-te
     mpls te cspf
    #
    mpls te p2p-template te-tunnel
     record-route label
     bandwidth ct0 1000
     fast-reroute
    #
    mpls te auto-primary-tunnel ip-prefix te-tunnel p2p-template te-tunnel
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0003.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.1.3.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 10000
     mpls te bandwidth bc0 10000
     mpls rsvp-te
    #
    interface LoopBack0
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    ip ip-prefix te-tunnel index 10 permit 1.1.1.9 32 
    ip ip-prefix te-tunnel index 20 permit 2.2.2.9 32 
    #
    return
    
Download
Updated: 2018-07-12

Document ID: EDOC1100028530

Views: 101344

Downloads: 336

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next