No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - MPLS 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local LDP Sessions

Example for Configuring Local LDP Sessions

This section provides an example for configuring local LDP sessions. The configuration procedure involves enabling MPLS and MPLS LDP on each LSR and interface.

Networking Requirements

In Figure 4-12, LSRA, LSRB, and LSRC function as core or edge devices on a backbone network. To deploy MPLS LDP services on the backbone network, configure local LDP sessions between LSRA and LSRB, and between LSRB and LSRC. Each pair of LSRs distributes labels to each other and establishes LDP LSPs.

Figure 4-12  Local LDP sessions

Table 4-3  Interface IP addresses

Device Name

Interface Name

IP Address

LSRA

Loopback1

1.1.1.9/32

GigabitEthernet1/0/0

10.1.1.1/30

LSRB

Loopback1

2.2.2.9/32

GigabitEthernet1/0/0

10.1.1.2/30

GigabitEthernet2/0/0

10.2.1.1/30

LSRC

Loopback1

3.3.3.9/32

GigabitEthernet1/0/0

10.2.1.2/30

Configuration Notes

When configuring local LDP sessions, note the following:

  • An LSR ID must be configured before you run other MPLS commands.

  • An LSR ID of an LSR must be manually configured because no default LSR ID is available.

  • Using the IP address of a reachable loopback interface on an LSR as an LSR ID is recommended.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure OSPF to advertise the route to the network segment to which each interface is connected and the host route to each LSR ID.

  2. Enable MPLS and MPLS LDP globally on each LSR.

  3. Enable MPLS on interfaces of each LSR.

  4. Enable MPLS LDP on the interfaces of both ends of each local LDP session.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of each interface on each LSR as shown in Figure 4-12, OSPF process ID, and OSPF area ID

  • LSR ID of each LSR

Procedure

  1. Assign an IP address to each interface and configure OSPF to advertise the route to the network segment to which each interface is connected and the host route to each LSR ID.

    According to Figure 4-12, assign an IP address to each interface, configure the loopback interface addresses as LSR IDs, and configure OSPF to advertise the route to the network segment to which each interface is connected and the host route to each LSR ID. For configuration details, see Configuration Files in this section.

  2. Enable MPLS and MPLS LDP globally on each LSR.

    # Configure LSRA.

    <LSRA> system-view 
    [*LSRA] mpls lsr-id 1.1.1.9
    [*LSRA] mpls
    [*LSRA-mpls] quit
    [*LSRA] mpls ldp
    [*LSRA-mpls-ldp] commit
    [~LSRA-mpls-ldp] quit

    # Configure LSRB.

    <LSRB> system-view 
    [*LSRB] mpls lsr-id 2.2.2.9
    [*LSRB] mpls
    [*LSRB-mpls] quit
    [*LSRB] mpls ldp
    [*LSRB-mpls-ldp] commit
    [~LSRB-mpls-ldp] quit

    # Configure LSRC.

    <LSRC> system-view 
    [*LSRC] mpls lsr-id 3.3.3.9
    [*LSRC] mpls
    [*LSRC-mpls] quit
    [*LSRC] mpls ldp
    [*LSRC-mpls-ldp] commit
    [~LSRC-mpls-ldp] quit

  3. Enable MPLS and MPLS LDP on the interfaces of each LSR.

    # Configure LSRA.

    [~LSRA] interface gigabitethernet 1/0/0
    [~LSRA-GigabitEthernet1/0/0] mpls
    [*LSRA-GigabitEthernet1/0/0] mpls ldp
    [*LSRA-GigabitEthernet1/0/0] commit
    [~LSRA-GigabitEthernet1/0/0] quit

    # Configure LSRB.

    [~LSRB] interface gigabitethernet 1/0/0
    [~LSRB-GigabitEthernet1/0/0] mpls
    [*LSRB-GigabitEthernet1/0/0] mpls ldp
    [*LSRB-GigabitEthernet1/0/0] commit
    [~LSRB-GigabitEthernet1/0/0] quit
    [~LSRB] interface gigabitethernet 2/0/0
    [~LSRB-GigabitEthernet2/0/0] mpls
    [*LSRB-GigabitEthernet2/0/0] mpls ldp
    [*LSRB-GigabitEthernet2/0/0] commit
    [~LSRB-GigabitEthernet2/0/0] quit

    # Configure LSRC.

    [~LSRC] interface gigabitethernet 1/0/0
    [*LSRC-GigabitEthernet1/0/0] mpls
    [*LSRC-GigabitEthernet1/0/0] mpls ldp
    [*LSRC-GigabitEthernet1/0/0] commit
    [~LSRC-GigabitEthernet1/0/0] quit

  4. Verify the configuration.

    # After completing the configuration, run the display mpls ldp session command on an LSR. The command output shows that the status of the local LDP session between LSRA and LSRB, or between LSRB and LSRC is Operational.

    The following example uses the command output on LSRA.

    <LSRA> display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
    --------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge       KASent/Rcv
    --------------------------------------------------------------------------
    2.2.2.9:0           Operational DU   Passive  0000:00:22   91/91
    --------------------------------------------------------------------------
    TOTAL: 1 Session(s) Found.
    

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls ldp
    #
     ipv4-family
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.252
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.3
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
    #
     ipv4-family
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.252
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.2.1.0 0.0.0.3
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.252
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.3
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028530

Views: 101987

Downloads: 336

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next