No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - System Monitor 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Collecting Statistics About IPv4 Flows Aggregated Based on the AS Number

Example for Collecting Statistics About IPv4 Flows Aggregated Based on the AS Number

This section provides an example for configuring NetStream to collect statistics about IPv4 flows aggregated based on the AS number. NetStream allows flows to be aggregated based on the AS number, which makes accounting or management easier.

Networking Requirements

On the network shown in Figure 3-18, Device D connects network A and network B to the wide area network (WAN). Device D samples and aggregates flows before sending them to the NetStream Collector (NSC).

Figure 3-18  Networking diagram for collecting statistics about IPv4 flows aggregated based on the AS number
NOTE:
  • Interfaces 1 through 4 in this example are GE1/0/0 , GE2/0/0, GE3/0/0, and GE4/0/0, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reachable routes between the egress router of the LAN and the WAN.

  2. Configure reachable routes between the ingress router of the LAN and the NSC.

  3. Configure the ingress router of the LAN to sent traffic statistics to the specified NSC.

  4. Configure the ingress router of the LAN to sent traffic statistics to the inbound interface on the NSC.

  5. Aggregate sampled flows to reduce the data sent to the NSC.

  6. Enable NetStream on the inbound interface of the ingress router.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of each interface

  • IP address of the NSC

  • Output format of NetStream flows

  • NetStream sampling ratio

  • Number of the slot in which the NetStream service processing board resides (In this example, the NetStream service processing board is in slot 1.)

Procedure

  1. Assign an IP address to each interface on each router. For configuration details, see Configuration Files in this section.
  2. Configure reachable routes between the WAN, router A, and router B.

    # Configure reachable routes between router A and router D.

    [*DeviceA] ip route-static 1.1.1.1 24 GigabitEthernet 1/0/0

    # Configure reachable routes between router B and router D.

    [*DeviceB] ip route-static 1.1.1.1 24 GigabitEthernet 1/0/0
    [*DeviceB] commit

  3. Configure reachable routes between router D and the NSC.

    # Configure reachable routes between router D and router C.

    [*DeviceD] ip route-static 2.2.2.1 24 3.3.3.2

  4. Enable NetStream on router D.

    # Configure the interface board on router D to process NetStream services in distributed mode.
    <DeviceD> system-view
    [*DeviceD] slot 1
    [*DeviceD-slot-1] ip netstream sampler to slot self
    [*DeviceD-slot-1] return
    NOTE:

    If the current interface board does not support statistics collection but the NetStream function is required, run the ip netstream sampler to slot slot-id command to configure the interface board to process NetStream services in centralized mode so that the packets of the interface board are replicated to the NetStream service processing board.

    # Enable the NetStream statistics function.

    [*DeviceD] interface gigabitethernet 3/0/0
    [*DeviceD-GigabitEthernet3/0/0] ip
    netstream inbound

    # Output aggregated flows in V9 format.

    [*DeviceD] ip netstream aggregation as 
    [*DeviceD-aggregation-as] enable
    [*DeviceD-aggregation-as] ip
    netstream export host 2.2.2.1 3000
    [*DeviceD-aggregation-as] ip netstream export source 3.3.3.1
    [*DeviceD-aggregation-as] export version 9

    # Enable the NetStream packet sampling function.

    [*DeviceD-GigabitEthernet3/0/0] ip netstream sampler fix-packets 1000 inbound
    [*DeviceD-GigabitEthernet3/0/0] quit
    [*DeviceD] commit

  5. Verify the configuration.

    # Run the display ip netstream cache command to view information about flows in the NetStream flow buffer on router D.

    <HUAWEI> display ip netstream cache as slot 2
     DstIf   
     SrcIf  
     DstAs      Streams    Packets    Direction     SrcAs   
     --------------------------------------------------------------------------
     GI2/0/0        
     Unknown         
     0          985988     985988     out           0

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    interface GigabitEthernet1/0/0
     ip address 172.16.0.1 255.255.255.0
    #
    ip route-static 1.1.1.1 255.255.255.0 GigabitEthernet1/0/0
    #
    return
  • Device B configuration file

    #
     sysname DeviceB
    #
    interface GigabitEthernet1/0/0
     ip address 172.17.1.1 255.255.255.0
    #
    ip route-static 1.1.1.1 255.255.255.0 GigabitEthernet1/0/0
    #
    return
  • Device C configuration file
    #
     sysname DeviceC
    #
    interface GigabitEthernet1/0/0
     ip address 3.3.3.2 255.255.255.0
    #
    return
  • Device D configuration file

    # 
    slot 1
     ip netstream sampler to slot self
    #
     sysname DeviceD
    #
    interface GigabitEthernet1/0/0
     ip address 172.16.0.2 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.1.2 255.255.255.0 
    #
    interface GigabitEthernet3/0/0
     ip address 1.1.1.1 255.255.255.0
     ip
    netstream inbound
     ip netstream sampler fix-packets 1000 inbound
    #
    interface GigabitEthernet4/0/0
     ip address 3.3.3.1 255.255.255.0
    #
    ip netstream aggregation as
     enable
     export version 9
     ip netstream export source 3.3.3.1
     ip
    netstream export host 2.2.2.1 3000
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028538

Views: 28058

Downloads: 212

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next