No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - System Monitor 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an NQA LSP Ping Test to Monitor MPLS Network Connectivity

Example for Configuring an NQA LSP Ping Test to Monitor MPLS Network Connectivity

This section provides an example for configuring an NQA LSP ping test to monitor MPLS network connectivity.

Networking Requirements

On the MPLS network shown in Figure 4-8, Device A and Device C are PEs. An NQA LSP ping test can be configured to periodically monitor the connectivity between these two PEs.

Figure 4-8  Networking diagram for an NQA LSP ping test to monitor MPLS network connectivity
NOTE:
  • Interfaces 1 through 2 in this example are GE1/0/0, and GE2/0/0, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an LSP ping test instance on Device A.
  2. Start the test instance.

Data Preparation

To complete the configuration, you need the IP addresses of Device A and Device C.

Procedure

  1. Create an LSP ping test instance.

    <DeviceA> system-view
    [~DeviceA] nqa test-instance admin lspping
    [*DeviceA-nqa-admin-lspping] test-type lspping
    [*DeviceA-nqa-admin-lspping] lsp-type ipv4
    [*DeviceA-nqa-admin-lspping] destination-address ipv4 3.3.3.9 lsp-masklen 32

  2. Start the test instance.

    [*DeviceA-nqa-admin-lspping] start now
    [*DeviceA-nqa-admin-lspping] commit

  3. Verify the test result.

    Run the display nqa results test-instance admin lspping command on Device A. The command output shows that the ping is successful.

    [~DeviceA-nqa-admin-lspping] display nqa results test-instance admin lspping
     NQA entry(admin, lspping) :testFlag is inactive ,testtype is  lspping
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       Destination ip address:3.3.3.9
       Min/Max/Average Completion Time: 1/1/1
       Sum/Square-Sum  Completion Time: 3/3
       Last Good Probe Time: 2007-1-30 15:32:56.1
       Lost packet ratio:0% 

  4. Configure the test instance to start at 10:00 o'clock every day.

    [*DeviceA-nqa-admin-lspping] stop
    [*DeviceA-nqa-admin-lspping] start daily 10:00:00 to 10:30:00  
    [*DeviceA-nqa-admin-lspping] commit

Configuration Files

  • Device A configuration file

    #
     sysname DeviceA
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 1.1.1.9 0.0.0.0
    #
    nqa test-instance admin lspping
     test-type lspping
     destination-address ipv4 3.3.3.9 lsp-masklen 32
     start daily 10:00:00 to 10:30:00  
    #
    return
  • Device B configuration file

    #
     sysname DeviceB
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • Device C configuration file

    #
     sysname DeviceC
    #
    mpls lsr-id 3.3.3.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028538

Views: 28281

Downloads: 213

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next