No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - System Monitor 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring a General Flow Test in a Native Ethernet Scenario

Configuring a General Flow Test in a Native Ethernet Scenario

This section describes how to configure a general flow test in a native Ethernet scenario. A general flow test is used to monitor the native Ethernet network performance.

Networking Requirements

A general flow test needs to be configured to monitor the performance of an Ethernet virtual connection (EVC) between Device A and Device B on the network shown in Figure 4-10.

Figure 4-10  General flow test in a native Ethernet scenario

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reflector Device B to loop traffic with a specified destination MAC address through reflector interface GE 1/0/1 to the initiator.
  2. Configure initiator Device A and test the throughput, latency, and packet loss rate.
  3. Configure Device C's interface to join the specified VLAN.

Data Preparation

To complete the configuration, you need the following data:

  • On reflector Device B: MAC address (1-1-1) of the interface directly connected to GE 1/0/1
  • On initiator Device A:

    • Destination MAC address (1-1-1) of the interface directly connected to Device B's GE 1/0/1
    • Throughput test parameters: upper rate threshold (100000 Kbit/s), lower rate threshold (10000 Kbit/s), throughput precision (1000 Kbit/s), packet loss rate (81), interval (5s) at which test packets are transmitted at a specified rate, data size (70 bytes) of each test packet, and test duration (100s)
    • Delay test parameters: packet rate (99000 Kbit/s), test duration (100s), and interval (5s) at which the initiator sends test packets
    • Packet loss rate test parameters: packet rate (99000 Kbit/s), and test duration (100s)

Procedure

  1. Configure reachable Layer 2 links between the initiator and reflector and add Layer 2 interfaces to VLAN 10. For configuration details, see "Configuration Files" in this section.
  2. Configure the reflector.

    <DeviceB> system-view
    [~DeviceB] nqa reflector 1 interface gigabitethernet 1/0/1 mac 1-1-1 vlan 10

  3. Configure the initiator to conduct a throughput test and check the test results.

    <DeviceA> system-view
    [~DeviceA] nqa test-instance admin throughput
    [*DeviceA-nqa-admin-throughput] test-type generalflow
    [*DeviceA-nqa-admin-throughput] measure throughput
    [*DeviceA-nqa-admin-throughput] destination-address mac 1-1-1
    [*DeviceA-nqa-admin-throughput] forwarding-simulation inbound-interface gigabitethernet 1/0/1
    [*DeviceA-nqa-admin-throughput] rate 10000 100000
    [*DeviceA-nqa-admin-throughput] interval seconds 5
    [*DeviceA-nqa-admin-throughput] precision 1000
    [*DeviceA-nqa-admin-throughput] fail-ratio 81
    [*DeviceA-nqa-admin-throughput] datasize 70
    [*DeviceA-nqa-admin-throughput] duration 100
    [*DeviceA-nqa-admin-throughput] vlan 10
    [*DeviceA-nqa-admin-throughput] start now
    [*DeviceA-nqa-admin-throughput] commit
    [~DeviceA-nqa-admin-throughput] display nqa results test-instance admin throughput
    NQA entry(admin, throughput) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is throughput
       ID Size Throughput(Kbps) Precision(Kbps) LossRatio Completion
       1  70   100000            1000            0.00%     success   
    

  4. Configure the initiator to conduct a latency test and check the test results.

    [*DeviceA] nqa test-instance admin delay
    [*DeviceA-nqa-admin-delay] test-type generalflow
    [*DeviceA-nqa-admin-delay] measure delay
    [*DeviceA-nqa-admin-delay] destination-address mac 1-1-1
    [*DeviceA-nqa-admin-delay] forwarding-simulation inbound-interface gigabitethernet 1/0/1
    [*DeviceA-nqa-admin-delay] datasize 64
    [*DeviceA-nqa-admin-delay] rate 99000
    [*DeviceA-nqa-admin-delay] interval seconds 5
    [*DeviceA-nqa-admin-delay] duration 100
    [*DeviceA-nqa-admin-delay] vlan 10
    [*DeviceA-nqa-admin-delay] start now
    [*DeviceA-nqa-admin-delay] commit
    [~DeviceA-nqa-admin-delay] display nqa results test-instance admin delay
    NQA entry(admin, delay) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is delay
       ID Size Min/Max/Avg RTT(us)     Min/Max/Avg Jitter(us)  Completion
       1  64   1/12/5                  2/15/8                   finished  

  5. Configure the initiator to conduct a packet loss rate test and check the test results.

    [*DeviceA] nqa test-instance admin loss
    [*DeviceA-nqa-admin-loss] test-type generalflow
    [*DeviceA-nqa-admin-loss] measure loss
    [*DeviceA-nqa-admin-loss] destination-address mac 1-1-1
    [*DeviceA-nqa-admin-loss] forwarding-simulation inbound-interface gigabitethernet 1/0/1
    [*DeviceA-nqa-admin-loss] datasize 64
    [*DeviceA-nqa-admin-loss] rate 99000
    [*DeviceA-nqa-admin-loss] duration 100
    [*DeviceA-nqa-admin-loss] vlan 10
    [*DeviceA-nqa-admin-loss] start now
    [*DeviceA-nqa-admin-loss] commit
    [~DeviceA-nqa-admin-loss] display nqa results test-instance admin loss
    NQA entry(admin, loss) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is loss
       ID Size TxRate/RxRate(Kbps) TxCount/RxCount             LossRatio Completion
       1  64   99000/99000         653265345/653265345         0.00%     finished  
    

Configuration Files

  • Configuration file of Device A

    #
    sysname DeviceA
    # 
    vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10#
    interface GigabitEthernet 1/0/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    nqa test-instance admin throughput
     test-type generalflow
     duration 100
     measure throughput
     fail-ratio 81
     destination-address mac 0001-0001-0001
     datasize 70
     rate 10000 100000
     precision 1000
     forwarding-simulation inbound-interface GigabitEthernet1/0/1
     vlan 10
    nqa test-instance admin loss
     test-type generalflow
     duration 100
     measure loss
     destination-address mac 0001-0001-0001
     datasize 64
     rate 99000
     forwarding-simulation inbound-interface GigabitEthernet1/0/1
     vlan 10
    nqa test-instance admin delay
     test-type generalflow
     duration 100
     measure delay
     interval seconds 5
     destination-address mac 0001-0001-0001
     datasize 64
     rate 99000
     forwarding-simulation inbound-interface GigabitEthernet1/0/1
     vlan 10
    #
    return
  • Configuration file of Device B

    #
    sysname DeviceB
    # 
    vlan 10
    nqa reflector 1 interface gigabitethernet 1/0/1 mac 0001-0001-0001 vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 1/0/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Device C

    #
    sysname DeviceC
    # 
    vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 1/0/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028538

Views: 28420

Downloads: 213

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next