No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - System Monitor 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring a General Flow Test in the IP gateway Scenario

Configuring a General Flow Test in the IP gateway Scenario

This section describes how to configure a general flow test in the IP gateway scenario. The general flow test monitors the Ethernet network performance.

Usage Scenario

A general flow test needs to be configured to monitor the performance of the Ethernet network shown in Figure 4-11 between Device A and IP gateway Device B.

Figure 4-11  General flow test in the IP gateway scenario
NOTE:
  • Interfaces 1 through 2 in this example are GE1/0/1, and GE1/0/2, respectively.


Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure reflector Device A .
  2. Configure initiator Device B and monitor the latency time.

Data Preparation

To complete the configuration, you need the following data:

  • On reflector Device A: Set the simulated IP address to 10.1.1.1 (CE's IP address) and the reflector interface to GE 1/0/1.
  • On initiator Device B:

    • Destination IP address: (10.1.1.1) of the CE connected to Device A's GE 1/0/1
    • Source IP address: an address that resides on the same network segment as the IP address of the initiator
    • Latency test parameters: packet rate (99000 Kbit/s), packet loss ratio (81%), test duration (100s), and interval (5s) at which the initiator sends test packets

Procedure

  1. Configure Layer 2 devices so that Layer 3 routes between the CE and Device B are reachable. For configuration details, see "Configuration Files" in this section.
  2. Configure the reflector.

    [*DeviceA] vlan 10
    [*DeviceA-vlan10] commit
    [~DeviceA-vlan10] quit
    [~DeviceA] nqa reflector 1 interface gigabitethernet 1/0/1 ipv4 10.1.1.1 vlan 10 
    [*DeviceA] commit

  3. Configure the initiator to conduct a latency test and view test results.

    [*DeviceB] vlan 10
    [*DeviceB-vlan10] commit
    [~DeviceB-vlan10] quit
    [~DeviceB] interface gigabitethernet 1/0/2.1
    [*DeviceB-GigabitEthernet1/0/2.1] vlan-type dot1q 10
    [*DeviceB-GigabitEthernet1/0/2.1] ip address 10.1.1.2 24
    [*DeviceB-GigabitEthernet1/0/2.1] quit
    [*DeviceB] arp static 10.1.1.1 0001-0002-0003 vid 10 interface GigabitEthernet 1/0/2.1
    [*DeviceB] nqa test-instance admin delay
    [*DeviceB-nqa-admin-delay] test-type generalflow
    [*DeviceB-nqa-admin-delay] measure delay
    [*DeviceB-nqa-admin-delay] destination-address ipv4 10.1.1.1
    [*DeviceB-nqa-admin-delay] source-address ipv4 10.1.1.2
    [*DeviceB-nqa-admin-delay] source-interface gigabitethernet 1/0/2.1
    [*DeviceB-nqa-admin-delay] rate 99000
    [*DeviceB-nqa-admin-delay] interval seconds 5
    [*DeviceB-nqa-admin-delay] datasize 64
    [*DeviceB-nqa-admin-delay] duration 100
    [*DeviceB-nqa-admin-delay] start now
    [*DeviceB-nqa-admin-delay] commit
    [~DeviceB-nqa-admin-delay] display nqa results test-instance admin delay
    NQA entry(admin, delay) :testflag is inactive ,testtype is generalflow
      1 . Test 1 result: The test is finished, test mode is delay
       ID Size Min/Max/Avg RTT(us)     Min/Max/Avg Jitter(us)  Completion
       1  64   1/12/5                  2/15/8                   finished  

Configuration Files

  • Configuration file of Device A

    #
    sysname DeviceA
    # 
    vlan 10
    #
    nqa reflector 1 interface GigabitEthernet 1/0/1 ipv4 10.1.1.1 vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 1/0/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Configuration file of Device B

    #
    sysname DeviceB
    #
    vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 1/0/2.1
     vlan-type dot1q 10
     ip address 10.1.1.2 255.255.255.0
    #
    nqa test-instance admin delay
     test-type generalflow
     destination-address ipv4 10.1.1.1
     source-address ipv4 10.1.1.2
     duration 100
     measure delay
     interval seconds 5
     datasize 64
     rate 99000
     source-interface GigabitEthernet1/0/2.1
    #
    return
  • Configuration file of Device C

    #
    sysname DeviceC
    # 
    vlan 10
    #
    interface GigabitEthernet 1/0/1
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet 1/0/2
     portswitch
     undo shutdown
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028538

Views: 29536

Downloads: 221

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next