No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - System Monitor 01

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Ethernet Service Activation Test in a Layer 3 Scenario

Example for Configuring an Ethernet Service Activation Test in a Layer 3 Scenario

This section provides an example for configuring an Ethernet service activation test in a Layer 3 scenario to check whether network performance meets SLAs.

Networking Requirements

The network shown in Figure 4-13 requires a check of the Ethernet frame transmission between Device B and Device C to determine whether the performance parameters meet SLAs.

Figure 4-13  Configuring an Ethernet service activation test in a Layer 3 scenario
NOTE:
  • In this example, Interface 1 and Interface 2 stand for GE 1/0/1 and GE1/0/2, respectively.


Configuration Roadmap

  1. Configure Device C as the reflector and set filter criteria based on flows.
  2. Configure Device B as the initiator and execute configuration tests and performance tests.

Data Preparation

To complete the configuration, you need the following data:

  • Configurations of reflector Device C: Configure the reflector to reflect traffic based on flows.
  • Configurations of initiator Device B:

    • Configure service flow and service flow characteristics.

      • Destination MAC address: 2-2-2, that is, the MAC address of GE1/0/1 on Device D connected to UNI B
      • Source MAC address: 1-1-1, that is, the MAC address of GE1/0/1 on Device A connected to UNI A
      • Destination IP address: IP address of the downstream device or the IP address of the network segment where UNI B resides. An example of the IP address of the downstream device is 10.1.3.2.

      • Source IP address: IP address of the downstream device or the IP address of the network segment where UNI A resides. An example of the IP address of the downstream device is 10.1.1.1.

    • Configure the bandwidth template: CIR as 500000 kbit/s and EIR as 20000 kbit/s

    • Configure service acceptance criteria: with the FLR set to 1000/100000, FTD set to 1 microsecond, and FDV set to 10000000 microseconds.

NOTE:
The link between the two user networks must be reachable. Otherwise, static ARP entries must be configured.

Procedure

  1. Configure the Layer 3 link reachability for the initiator and reflector.
  2. Configure the reflector.

    [*DeviceC] nqa test-flow 1
    [*DeviceC-nqa-testflow-1] traffic-type mac destination 2-2-2
    [*DeviceC-nqa-testflow-1] traffic-type mac source 1-1-1
    [*DeviceC-nqa-testflow-1] traffic-type ipv4 destination 10.1.3.2
    [*DeviceC-nqa-testflow-1] traffic-type ipv4 source 10.1.1.1
    [*DeviceC-nqa-testflow-1] traffic-policing test enable
    [*DeviceC-nqa-testflow-1] quit
    [*DeviceC] nqa reflector 1 interface GigabitEthernet 1/0/1.1 test-flow 1 exchange-port agetime 0
    [*DeviceC] commit

  3. Configure the initiator to initiate a configuration test and a performance test and view the test results.

    [*DeviceB] nqa test-flow 1
    [*DeviceB-nqa-testflow-1] bandwidth cir 500000 eir 20000
    [*DeviceB-nqa-testflow-1] sac flr 1000 ftd 10000 fdv 10000000
    [*DeviceB-nqa-testflow-1] traffic-type mac destination 2-2-2
    [*DeviceB-nqa-testflow-1] traffic-type mac source 1-1-1
    [*DeviceB-nqa-testflow-1] traffic-type ipv4 destination 10.1.3.2
    [*DeviceB-nqa-testflow-1] traffic-type ipv4 source 10.1.1.1
    [*DeviceB-nqa-testflow-1] traffic-policing test enable
    [*DeviceB-nqa-testflow-1] quit
    [*DeviceB] nqa test-instance admin ethernet
    [*DeviceB-nqa-admin-ethernet] test-type ethernet-service
    [*DeviceB-nqa-admin-ethernet] forwarding-simulation inbound-interface GigabitEthernet 1/0/1.1
    [*DeviceB-nqa-admin-ethernet] test-flow 1
    [*DeviceB-nqa-admin-ethernet] start now
    [*DeviceB-nqa-admin-ethernet] commit
    [~DeviceB-nqa-admin-ethernet] display nqa results test-instance admin ethernet
    NQA entry(admin, ethernet) :testflag is inactive ,testtype is ethernet-service
      1 . Test 1 result   The test is finished                                      
       Status           : Pass                                                      
       Test-flow number : 1                                                         
       Mode             : Round-trip                                                
       Last step        : Performance-test                                          
       Estimated total time  :6
       Real test time        :6
       1 . Configuration-test                                                       
        Test-flow 1, CIR simple test                                                
         Begin                    : 2014-06-25 16:22:45.8                           
         End                      : 2014-06-25 16:22:48.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9961/10075/10012                                
         Min/Max/Mean FTD(us)     : 99/111/104                                      
         Min/Max/Mean FDV(us)     : 0/7/3                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
        Test-flow 1, CIR/EIR test, Green                                            
         Begin                    : 2014-06-25 16:23:15.8                           
         End                      : 2014-06-25 16:23:18.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9979/10054/10012                                
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 0/10/3                                          
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
        Test-flow 1, CIR/EIR test, Yellow                                           
         Begin                    : 2014-06-25 16:23:15.8                           
         End                      : 2014-06-25 16:23:18.8                           
         Status                   : --                                              
         Min/Max/Mean IR(kbit/s)    : 9979/10057/10013                                
         Min/Max/Mean FTD(us)     : 98/111/104                                      
         Min/Max/Mean FDV(us)     : 1/11/5                                          
         FL Count/FLR             : 0/0.000%                                        
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%
        Test-flow 1, Traffic policing test, Green                                   
         Begin                    : 2014-06-25 16:23:45.8                           
         End                      : 2014-06-25 16:23:48.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 10039/10054/10045                               
         Min/Max/Mean FTD(us)     : 96/110/104                                      
         Min/Max/Mean FDV(us)     : 1/9/4                                           
         FL Count/FLR             : 0/0.000% 
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                       
        Test-flow 1, Traffic policing test, Yellow                                  
         Begin                    : 2014-06-25 16:23:45.8                           
         End                      : 2014-06-25 16:23:48.8                           
         Status                   : --                                              
         Min/Max/Mean IR(kbit/s)    : 12544/12566/12554                               
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 1/8/3                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%                                        
       2 . Performance-test                                                         
        Test-flow 1, Performance-test                                               
         Begin                    : 2014-06-25 16:24:15.8                           
         End                      : 2014-06-25 16:39:15.8                           
         Status                   : Pass                                            
         Min/Max/Mean IR(kbit/s)    : 9888/10132/10004                                
         Min/Max/Mean FTD(us)     : 101/111/105                                     
         Min/Max/Mean FDV(us)     : 0/8/2                                           
         FL Count/FLR             : 0/0.000%
         Disorder packets         : 0
         Unavail Count/AVAIL      : 0/0.000%

Configuration Files

  • DeviceB configuration file

    #
    sysname DeviceB
    # 
    interface GigabitEthernet 1/0/1
     undo shutdown
    #
    interface GigabitEthernet 1/0/1.1
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet 1/0/2
     undo shutdown
     ip address 10.1.2.1 255.255.255.0
    #
    nqa test-flow 1
     bandwidth cir 500000 eir 20000
     sac flr 1000 ftd 10000 fdv 10000000
     traffic-type mac destination 2-2-2
     traffic-type mac source 1-1-1
     traffic-type ipv4 destination 10.1.3.2 
     traffic-type ipv4 source 10.1.1.1 
     traffic-policing test enable
    #
    nqa test-instance admin ethernet
     test-type ethernet-service
     forwarding-simulation inbound-interface GigabitEthernet 1/0/1.1
     test-flow 1
    #
    return
  • DeviceC configuration file

    #
    sysname DeviceC
    # 
    interface GigabitEthernet 1/0/1
     undo shutdown
    #
    interface GigabitEthernet 1/0/1.1
     ip address 10.1.3.1 255.255.255.0
    #
    interface GigabitEthernet 1/0/2
     undo shutdown
     ip address 10.1.2.2 255.255.255.0
    #
    nqa test-flow 1
     traffic-type mac destination 2-2-2
     traffic-type mac source 1-1-1
     traffic-type ipv4 destination 10.1.3.2 
     traffic-type ipv4 source 10.1.1.1 
     traffic-policing test enable
    #
    nqa reflector 1 interface GigabitEthernet 1/0/1.1 test-flow 1 exchange-port agetime 0
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028538

Views: 29086

Downloads: 220

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next