No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - Virtual Access 01

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Virtual Cluster Access

Example for Configuring Virtual Cluster Access

This section provides an example for configuring virtual cluster access.

Networking Requirements

A large number of devices are deployed on the access ring of an IP radio access network (RAN), and the existing bearer techniques are complex in deployment. This situation causes high operation and maintenance (O&M) costs and poor network scalability. To reduce O&M costs and improve network scalability, configure virtual cluster access to carry access services.

As shown in Figure 2-8, AP1 and AP2 are connected to the base stations, and the primary and secondary masters are deployed on the access ring. Configure virtual cluster access on AP1, AP2, and the primary and secondary masters, and establish virtual paths (VPs) and virtual circuits (VCs) from AP1 and AP2 to the primary and secondary masters to carry packets from the base stations.
Figure 2-8  Virtual cluster access networking
Table 2-3  Interface IP addresses

Device Name

Interface Name

IP Address

AP1

Loopback0

1.1.1.1/32

GigabitEthernet1/0/1

10.1.2.1/30

GigabitEthernet1/0/2

10.1.3.1/30

GigabitEthernet1/0/3

192.168.0.1/24

AP2

Loopback0

2.2.2.2/32

GigabitEthernet1/0/1

10.1.2.2/30

GigabitEthernet1/0/2

10.2.4.1/30

GigabitEthernet1/0/3

192.168.1.1/24

MasterA

Loopback0

3.3.3.3/32

GigabitEthernet1/0/1

10.1.3.2/30

GigabitEthernet1/0/2

10.3.4.1/30

MasterB

Loopback0

4.4.4.4/32

GigabitEthernet1/0/1

10.2.4.2/30

GigabitEthernet1/0/2

10.3.4.2/30

NOTE:

Virtual cluster access is deployed on the access ring of an IP RAN, and the APs have the same virtual cluster access configurations for different services, such as Ethernet and asynchronous transfer mode (ATM)/time division multiplexing (TDM) services. This example provides only virtual cluster access configurations.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a loopback interface address as a management IP address on each node.

  2. Enable virtual cluster access globally on each node to establish a virtual cluster access Intermediate System to Intermediate System (IS-IS) process.

  3. Assign a management IP address to each node and configure the primary and secondary masters to which each AP belongs to establish Master Slave Control Protocol (MSCP) channels and VP protection groups.

  4. Enable virtual cluster access on each node's interfaces.

  5. Establish Remote-AP interfaces on the primary and secondary masters and bind the interfaces to the APs' AC interfaces to establish VCs.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of directly connected interfaces and loopback interface addresses on each node

  • Management IP address of the primary master to which AP1 and AP2 belong: 3.3.3.3; management IP address of the secondary master to which AP1 and AP2 belong: 4.4.4.4

  • Number of the Remote-AP interface on the primary master connected to AP1: 11; number of the Remote-AP interface on the primary master connected to AP2: 21; number of the Remote-AP interface on the secondary master connected to AP1: 12; number of the Remote-AP interface on the secondary master connected to AP2: 22

Procedure

  1. Assign an IP address to each interface and configure a loopback interface address as a management IP address on each node.

    For configuration details, see "Configuration Files" in this section.

  2. Enable virtual cluster access globally on each node.

    # Configure AP1.

    <HUAWEI> systerm-view
    [HUAWEI]sysname AP1
    [AP1] virtual-cluster-access

    # Configure AP2.

    <HUAWEI> systerm-view
    [HUAWEI]sysname AP2
    [AP2] virtual-cluster-access

    # Configure the primary master.

    <HUAWEI> systerm-view
    [~HUAWEI] sysname MasterA
    [*MasterA] virtual-cluster-access
    [*MasterA] commit

    # Configure the MasterB.

    <HUAWEI> systerm-view
    [~HUAWEI] sysname MasterB
    [*MasterB] virtual-cluster-access
    [*MasterB-virtual-cluster-access] commit

  3. Assign a management IP address to each node, specify primary and secondary masters for each AP, and specify master roles.

    # Configure AP1.

    [AP1-virtual-cluster-access] admin 1.1.1.1
    [AP1-virtual-cluster-access] master primary 3.3.3.3
    [AP1-virtual-cluster-access] master secondary 4.4.4.4
    [AP1-virtual-cluster-access] quit

    # Configure AP2.

    [AP2-virtual-cluster-access] admin 2.2.2.2
    [AP2-virtual-cluster-access] master primary 3.3.3.3
    [AP2-virtual-cluster-access] master secondary 4.4.4.4
    [AP2-virtual-cluster-access] quit

    # Configure the primary master.

    [~MasterA-virtual-cluster-access] admin 3.3.3.3
    [*MasterA-virtual-cluster-access] role master
    [*MasterA-virtual-cluster-access] commit
    [~MasterA-virtual-cluster-access] quit

    # Configure the secondary master.

    [~MasterB-virtual-cluster-access] admin 4.4.4.4
    [*MasterB-virtual-cluster-access] role master
    [*MasterB-virtual-cluster-access] commit
    [~MasterB-virtual-cluster-access] quit

  4. Enable virtual cluster access on each node's interfaces.

    # Configure AP1.

    [AP1] interface loopback 0
    [AP1-LoopBack0] isis enable 65534
    [AP1-LoopBack0] quit

    # Configure AP2.

    [AP2] interface loopback 0
    [AP2-LoopBack0] isis enable 65534
    [AP2-LoopBack0] quit

    # Configure the primary master.

    [~MasterA] interface gigabitethernet 1/0/1
    [~MasterA-GigabitEthernet1/0/1] virtual-cluster-access enable 
    [*MasterA-GigabitEthernet1/0/1] mpls
    [*MasterA-GigabitEthernet1/0/1] quit
    [*MasterA] interface gigabitethernet 1/0/2
    [*MasterA-GigabitEthernet1/0/2] virtual-cluster-access enable 
    [*MasterA-GigabitEthernet1/0/2] mpls
    [*MasterA-GigabitEthernet1/0/2] quit
    [*MasterA] interface loopback 0
    [*MasterA-LoopBack0] isis enable 65534
    [*MasterA-LoopBack0] commit
    [~MasterA-LoopBack0] quit

    # Configure the secondary master.

    [~MasterB] interface gigabitethernet 1/0/1
    [~MasterB-GigabitEthernet1/0/1] virtual-cluster-access enable 
    [*MasterB-GigabitEthernet1/0/1] mpls
    [*MasterB-GigabitEthernet1/0/1] quit
    [*MasterB] interface gigabitethernet 1/0/2
    [*MasterB-GigabitEthernet1/0/2] virtual-cluster-access enable 
    [*MasterB-GigabitEthernet1/0/2] mpls
    [*MasterB-GigabitEthernet1/0/2] quit
    [*MasterB] interface loopback 0
    [*MasterB-LoopBack0] isis enable 65534
    [*MasterB-LoopBack0] commit
    [~MasterB-LoopBack0] quit

  5. Establish Remote-AP interfaces on the primary and secondary masters and bind the interfaces to the APs' AC interfaces.

    # Configure the primary master.

    [~MasterA] interface Remote-Ap 11
    [*MasterA-Remote-Ap11] ip address 192.168.0.2 24
    [*MasterA-Remote-Ap11] connect-slot 9
    [*MasterA-Remote-Ap11] bind ap ip 1.1.1.1 interface GigabitEthernet1/0/3
    [*MasterA-Remote-Ap11] commit
    [~MasterA-Remote-Ap11] quit
    [~MasterA] interface Remote-Ap 21
    [*MasterA-Remote-Ap21] ip address 192.168.1.2 24
    [*MasterA-Remote-Ap21] connect-slot 9
    [*MasterA-Remote-Ap21] bind ap ip 2.2.2.2 interface GigabitEthernet1/0/3
    [*MasterA-Remote-Ap21] commit
    [~MasterA-Remote-Ap21] quit

    # Configure the secondary master.

    [~MasterB] interface Remote-Ap 12
    [*MasterB-Remote-Ap12] ip address 192.168.0.3 24
    [*MasterB-Remote-Ap12] connect-slot 9
    [*MasterB-Remote-Ap12] bind ap ip 1.1.1.1 interface GigabitEthernet1/0/3
    [*MasterB-Remote-Ap12] commit
    [~MasterB-Remote-Ap12] quit
    [~MasterB] interface Remote-Ap 22
    [*MasterB-Remote-Ap22] ip address 192.168.1.3 24
    [*MasterB-Remote-Ap22] connect-slot 9
    [*MasterB-Remote-Ap22] bind ap ip 2.2.2.2 interface GigabitEthernet1/0/3
    [*MasterB-Remote-Ap22] commit
    [~MasterB-Remote-Ap22] quit

  6. Verify the configuration.

    After completing the configurations, run the display virtual-cluster-access command on each node to view virtual cluster access status. The following example uses the command output on AP1. The command output shows that virtual cluster access has been implemented on AP1.

    [AP1] display virtual-cluster-access
                           Virtual Cluster Access Information
     -------------------------------------------------------------------------------
     Mode            : Slave       AdminIP        : 1.1.1.1
    
                           Label Space Information
     Total 2 record(s) found :
     -------------------------------------------------------------------------------
     Master                  BaseValue           Size
     -------------------------------------------------------------------------------
     3.3.3.3                 16                  504
     4.4.4.4                 520                 504
    
                           Master Information
     Total 2 record(s) found :
     -------------------------------------------------------------------------------
     Master          Role      State     GrState   UpTime
     -------------------------------------------------------------------------------
     *3.3.3.3        Primary   Running   Idle      2012-12-19 10:20:59-08:00
      4.4.4.4        Secondary Running   Idle      2012-12-19 10:21:15-08:00 

Configuration Files

  • Configuration file of AP1

    #
    sysname AP1
    #
    bfd
    #
    virtual-cluster-access
     role ap
     admin 1.1.1.1
     master primary 3.3.3.3
     master secondary 4.4.4.4
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.2.1 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.1.3.1 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet1/0/3
     shutdown
     ip address 192.168.0.1 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 65534
    #
    return
  • Configuration file of AP2

    #
    sysname AP2
    #
    virtual-cluster-access
     role ap
     admin 2.2.2.2
     master primary 3.3.3.3
     master secondary 4.4.4.4
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 10.0000.0000.0004.00
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.2.2 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.2.4.1 255.255.255.252
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet1/0/3
     shutdown
     ip address 192.168.1.1 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 65534
    #
    return
  • Configuration file of the primary master

    #
    sysname MasterA
    #
    bfd
    #
    virtual-cluster-access
     role master
     admin 3.3.3.3
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 00.38ba.34f3.5802.00
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.1.3.2 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.3.4.1 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap11
     undo shutdown
     ip address 192.168.0.2 255.255.255.0
     bind ap ip 1.1.1.1 interface GigabitEthernet1/0/3
     connect-slot 9
    #
    interface Remote-Ap21
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     bind ap ip 2.2.2.2 interface GigabitEthernet1/0/3
     connect-slot 9 
    #
    return
  • Configuration file of the secondary master

    #
    sysname MasterB
    #
    bfd
    #
    virtual-cluster-access
     role master
     admin 4.4.4.4
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-1
     cost-style wide
     auto-cost enable
     virtual-cluster-access enable
     network-entity 00.38ba.62dd.f403.00
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.2.4.2 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface GigabitEthernet1/0/2
     undo shutdown
     ip address 10.3.4.2 255.255.255.252
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap12
     undo shutdown
     ip address 192.168.0.3 255.255.255.0
     bind ap ip 1.1.1.1 interface GigabitEthernet1/0/3
     connect-slot 9
    #
    interface Remote-Ap22
     undo shutdown
     ip address 192.168.1.3 255.255.255.0
     bind ap ip 2.2.2.2 interface GigabitEthernet1/0/3
     connect-slot 9
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028541

Views: 7885

Downloads: 92

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next