No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

NE40E V800R010C00 Configuration Guide - Virtual Access 01

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring L2VPN Access over VCs

Example for Configuring L2VPN Access over VCs

This section provides an example for configuring L2VPN access over VCs in IP RAN virtual cluster access scenarios.

Networking Requirements

In the virtual cluster access scenario shown in Figure 2-11, AP1 transmits packets received from the base transceiver station (BTS) over a VC (carried over a VP) to each master. To implement end-to-end time division multiplexing (TDM) service bearing, configure L2VPN access over VCs on the masters.
Figure 2-11  Configuring L2VPN access over VCs
NOTE:
  • Interfaces 1, 2, 3, and 4 stand for GE 1/0/0, GE 2/0/0, E1 1/0/0, and CPOS1/0/0, respectively.


Table 2-6  Interfaces and their IP addresses on each device

Device

Interface

IP Address

AP1

Loopback 0

1.1.1.1/32

GE 1/0/0

10.1.1.1/24

GE 2/0/0

10.10.1.1/24

E1 1/0/0

-

Master1

Loopback0

2.2.2.2/32

GE 1/0/0

10.1.1.2/24

GE 2/0/0

10.20.1.1/24

Master2

Loopback0

3.3.3.3/32

GE 1/0/0

10.10.1.2/24

GE 2/0/0

10.30.1.1/24

RSG1

Loopback0

4.4.4.4/32

GE 1/0/0

10.40.1.1/24

GE 2/0/0

10.20.1.2/24

E1 1/0/0

-

CPOS 1/0/0

-

RSG2

Loopback0

5.5.5.5/32

GE 1/0/0

10.40.1.2/24

GE 2/0/0

10.30.1.2/24

E1 1/0/0

-

CPOS1/0/0

-

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a loopback interface address as the management IP address on each node.

  2. Enable virtual cluster both globally and per interface on the masters and AP, configure management IP addresses on the masters and AP, and specify the primary and secondary masters for the AP.

  3. Configure Interior Gateway Protocol (IGP) routes used for communication between the masters and radio network controller site gateways (RSGs).

  4. Configure Label Distribution Protocol (LDP) label switched paths (LSPs) between the masters and RSGs.

  5. Configure virtual private wire service (VPWS) PWs between the masters and RSGs, and a bypass PW between RSG1 and RSG2.

Data Preparation

To complete the configuration, you need the following data:

  • IP addresses of directly connected interfaces and loopback interface addresses on each node

  • Primary and secondary masters for AP1 (Master1 and Master2)

  • Remote-AP interface numbers (2) for Master1 and Master2

Procedure

  1. Assign an IP address to each interface and configure a loopback interface address as the management IP address on each node.

    For configuration details, see Configuration Files in this section.

  2. Enable virtual cluster both globally and per interface on the masters and AP, configure management IP addresses on the masters and AP, and specify the primary and secondary masters for the AP.

    For configuration details, see Configuration Files in this section.

  3. Configure IGP routes for aggregation-side devices. The following example uses Open Shortest Path First (OSPF) as the IGP.

    For configuration details, see Configuration Files in this section.

  4. Configure LDP LSPs between the masters and RSGs.

    # Configure Master1.

    <Master1> system-view
    [~Master1] mpls
    [*Master1-mpls-ldp] mpls ldp
    [*Master1-mpls-ldp] quit
    [*Master1] interface gigabitethernet 2/0/0
    [*Master1-GigabitEthernet2/0/0] mpls
    [*Master1-GigabitEthernet2/0/0] mpls ldp
    [*Master1-GigabitEthernet2/0/0] quit
    [*Master1] commit

    # Configure Master2.

    <Master2> system-view
    [~Master2] mpls
    [*Master2-mpls-ldp] mpls ldp
    [*Master2-mpls-ldp] quit
    [*Master2] interface gigabitethernet 2/0/0
    [*Master2-GigabitEthernet2/0/0] mpls
    [*Master2-GigabitEthernet2/0/0] mpls ldp
    [*Master2-GigabitEthernet2/0/0] quit
    [*Master2] commit

    # Configure RSG1.

    <RSG1> system-view
    [~RSG1] mpls
    [*RSG1-mpls-ldp] mpls ldp
    [*RSG1-mpls-ldp] quit
    [*RSG1] interface gigabitethernet 1/0/0
    [*RSG1-GigabitEthernet1/0/0] mpls
    [*RSG1-GigabitEthernet1/0/0] mpls ldp
    [*RSG1-GigabitEthernet1/0/0] quit
    [*RSG1] interface gigabitethernet 2/0/0
    [*RSG1-GigabitEthernet2/0/0] mpls
    [*RSG1-GigabitEthernet2/0/0] mpls ldp
    [*RSG1-GigabitEthernet2/0/0] quit
    [*RSG1] commit

    # Configure RSG2.

    <RSG2> system-view
    [~RSG2] mpls
    [*RSG2-mpls-ldp] mpls ldp
    [*RSG2-mpls-ldp] quit
    [*RSG2] interface gigabitethernet 1/0/0
    [*RSG2-GigabitEthernet1/0/0] mpls
    [*RSG2-GigabitEthernet1/0/0] mpls ldp
    [*RSG2-GigabitEthernet1/0/0] quit
    [*RSG2] interface gigabitethernet 2/0/0
    [*RSG2-GigabitEthernet2/0/0] mpls
    [*RSG2-GigabitEthernet2/0/0] mpls ldp
    [*RSG2-GigabitEthernet2/0/0] quit
    [*RSG2] commit

  5. Configure VPWS PWs between the masters and RSGs, and a bypass PW between RSG1 and RSG2.

    # Configure Master1.

    [~Master1] interface remote-ap 2
    [*Master1-Remote-Ap2] mpls l2vc encapsulation cesopsn-basic 4.4.4.4 4 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
    [*Master1-Remote-Ap2] bind ap ip 1.1.1.1 interface serial 1/0/0:1
    [*Master1-Remote-Ap2] quit
    [*Master1] commit

    # Configure Master2.

    [~Master2] interface remote-ap 2
    [*Master2-Remote-Ap2] mpls l2vc encapsulation cesopsn-basic 5.5.5.5 5 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
    [*Master2-Remote-Ap2] bind ap ip 1.1.1.1 interface serial 1/0/0:1
    [*Master2-Remote-Ap2] quit
    [*Master2] commit

    Configure RSG1.

    [~RSG1] interface cpos-trunk 1
    [*RSG1-Cpos-Trunk1] quit
    [*RSG1] controller cpos 1/0/0
    [*RSG1-Cpos1/0/0] cpos-trunk 1
    [*RSG1-Cpos1/0/0] quit
    [~RSG1] interface cpos-trunk 1
    [*RSG1-Cpos-Trunk1] e1 2 channel-set 1 timeslot-list 1-31
    [*RSG1-Cpos-Trunk11/0/0] quit
    [*RSG1] interface gigabitethernet 1/0/0
    [*RSG1-GigabitEthernet1/0/0] mpls
    [*RSG1-GigabitEthernet1/0/0] mpls ldp
    [*RSG1-GigabitEthernet1/0/0] quit
    [*RSG1] interface gigabitethernet 2/0/0
    [*RSG1-GigabitEthernet2/0/0] mpls
    [*RSG1-GigabitEthernet2/0/0] mpls ldp
    [*RSG1-GigabitEthernet2/0/0] quit
    [*RSG1] interface trunk-serial 1/2:1
    [*RSG1-Serial1/0/0] link-protocol tdm
    [*RSG1-Serial1/0/0] mpls l2vc 2.2.2.2 4 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
    [*RSG1-Serial1/0/0] mpls l2vc 5.5.5.5 3 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa bypass
    [*RSG1-Serial1/0/0] quit
    [*RSG1] commit

    # Configure RSG2.

    [*RSG2] interface cpos-trunk 1
    [*RSG2-Cpos-Trunk1] quit
    [*RSG2] controller cpos 1/0/0
    [*RSG2-Cpos1/0/0] cpos-trunk 1
    [*RSG2-Cpos1/0/0] quit
    [*RSG2] interface cpos-trunk 1
    [*RSG2-Cpos-Trunk1] e1 2 channel-set 1 timeslot-list 1-31
    [*RSG2-Cpos-Trunk11/0/0] quit
    [*RSG2] interface gigabitethernet 1/0/0
    [*RSG2-GigabitEthernet1/0/0] mpls
    [*RSG2-GigabitEthernet1/0/0] mpls ldp
    [*RSG2-GigabitEthernet1/0/0] quit
    [*RSG2] interface gigabitethernet 2/0/0
    [*RSG2-GigabitEthernet2/0/0] mpls
    [*RSG2-GigabitEthernet2/0/0] mpls ldp
    [*RSG2-GigabitEthernet2/0/0] quit
    [*RSG2] interface trunk-serial 1/2:1
    [*RSG2-Serial1/0/0] link-protocol tdm
    [*RSG2-Serial1/0/0] mpls l2vc 3.3.3.3 5 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
    [*RSG2-Serial1/0/0] mpls l2vc 4.4.4.4 3 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa bypass
    [*RSG2-Serial1/0/0] quit
    [*RSG1] commit

  6. Verify the configuration.

    After completing the configurations, run the display virtual-cluster-access vc command on each node. The command output shows that the VC status is Up. The following example uses the command output on Master1.

    [~Master1] display virtual-cluster-access vc
    --------------------------------------------------------------------------------
    MasterID        ApID            State ApIF
    --------------------------------------------------------------------------------
    2.2.2.2         1.1.1.1         Up    Serial1/0/0:1 

    Run the display mpls l2vc command on each master. The command output shows that an LDP VPWS PW has been established. The following example uses the command output on Master1.

    [~Master1] display mpls l2vc interface remote-ap 2
    *client interface             : Remote-Ap2 is up
     Administrator PW             : no
     session state                : up
     AC status                    : up
     VC state                     : up
     Label state                  : 0
     Token state                  : 0
     VC ID                        : 4
     VC type                      : cesopsn-basic
     destination                  : 4.4.4.4
     local group ID               : 0         remote group ID      : 0
     local VC label               : 32828     remote VC label      : 32828
     local AC OAM State           : up
     local PSN OAM State          : up
     local forwarding state       : forwarding
     local status code            : 0x0 (forwarding)
     remote AC OAM State          : up
     remote PSN OAM state         : up
     remote forwarding state      : forwarding
     remote status code           : 0x0 (forwarding)
     ignore standby state         : no
     Dynamic BFD for PW           : disable
     Detect Multipier             : 3
     Min Transit Interval         : 1000
     Min Receive Interval         : 1000
     Dynamic BFD Session          : built
     BFD for PW                   : available
       BFD sessionIndex           : --  BFD state : up
     VCCV State                   : --
     manual fault                 : not set
     active state                 : active
     forwarding entry             : exist
     OAM Protocol                 : --
     OAM Status                   : --
     OAM Fault Type               : --
     PW APS ID                    : --
     PW APS Status                : --
     TTL Value                    : 1
     link state                   : up
     local VC MTU                 : --        remote VC MTU        : --
     local VCCV                   : alert ttl lsp-ping bfd
     remote VCCV                  : alert ttl lsp-ping bfd
     local control word           : enable    remote control word  : enable
     tunnel policy name           : --
     PW template name             : --
     primary or secondary         : primary
     load balance type            : flow
     Access-port                  : false
     Switchover Flag              : false
     VC tunnel info               : 1 tunnels
        NO.0 TNL type             : ldp, TNL ID : 0x0000000001004c4b43
     create time                  : 0 days, 1 hours, 2 minutes, 56 seconds
     up time                      : 0 days, 1 hours, 1 minutes, 48 seconds
     last change time             : 0 days, 1 hours, 1 minutes, 48 seconds
     VC last up time              : 2015/1/28 02:50:41
     VC total up time             : 0 days, 1 hours, 1 minutes, 48 seconds
     CKey                         : 1
     NKey                         : 1493172332
     PW redundancy mode           : frr
     AdminPw interface            : --
     AdminPw link state           : --
     Forward state                : send inactive, receive inactive 
     Diffserv Mode                : uniform
     Service Class                : --
     Color                        : --
     DomainId                     : --
     Domain Name                  : --

Configuration Files

  • AP1 configuration file

    #
    sysname AP1
    #
    bfd
    #
    virtual-cluster-access
     role ap
     admin 1.1.1.1
     master primary 2.2.2.2
     master secondary 3.3.3.3
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-cluster-access enable
     network-entity 00.38ba.103a.2c01.00
    #
    controller E11/0/0
     channel-set 1 timeslot-list 1-31
     undo shutdown
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.10.1.1 255.255.255.0
     virtual-cluster-access enable
     isis enable 65534
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 65534
    #
    interface Serial1/0/0:1
     undo shutdown
     link-protocol tdm
    #
    return
  • Master1 configuration file

    #
    sysname Master1
    #
    bfd
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
     #
     ipv4-family    
    #
    virtual-cluster-access
     role master
     admin 2.2.2.2
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-cluster-access enable
     network-entity 00.38ba.103a.2c02.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.20.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.70.1.1 255.255.255.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap2
     mpls l2vc encapsulation cesopsn-basic 4.4.4.4 4 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
     bind ap ip 1.1.1.1 interface Serial1/0/0:1
    #               
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.20.1.0 0.0.0.255
      network 10.70.1.0 0.0.0.255  
      network 2.2.2.2 0.0.0.0
      mpls-te enable
    #
    return
    
  • Master2 configuration file
    #
    sysname Master2
    #
    bfd
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
     #
     ipv4-family    
    #
    virtual-cluster-access
     role master
     admin 3.3.3.3
    #
    isis 65534
     description auto-generated for virtual-cluster-access
     is-level level-2
     cost-style wide
     virtual-cluster-access enable
     network-entity 00.38ba.103a.2c03.00
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.10.1.2 255.255.255.0
     isis enable 65534
     mpls
     virtual-cluster-access enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.30.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.70.1.2 255.255.255.0
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 65534
    #
    interface Remote-Ap2
     mpls l2vc encapsulation cesopsn-basic 5.5.5.5 5 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
     bind ap ip 1.1.1.1 interface Serial1/0/0:1
    #               
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.30.1.0 0.0.0.255
      network 10.70.1.0 0.0.0.255  
      network 3.3.3.3 0.0.0.0
    #
    return
  • RSG1 configuration file
    #
    sysname RSG1
    #
    mpls lsr-id 4.4.4.4
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
     #
     ipv4-family
    #
    controller CPOS1/0/0
     undo shutdown
     cpos-trunk 1
    #
    controller CPOS-Trunk1
     undo shutdown
     e1 2 channel-set 1 timeslot-list 1-31
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.40.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.20.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface TVCrunk-Serial1/2:1
     link-protocol tdm
     mpls l2vc 2.2.2.2 4 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
     mpls l2vc 5.5.5.5 3 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa bypass
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.20.1.0 0.0.0.255
      network 10.40.2.0 0.0.0.255
    #
    return
  • RSG2 configuration file
    #
    sysname RSG2
    #
    mpls lsr-id 5.5.5.5
    #
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
     #
     ipv4-family
    # 
    #
    controller CPOS1/0/0
     undo shutdown
     cpos-trunk 1
    #
    controller CPOS-Trunk1
     undo shutdown
     e1 2 channel-set 1 timeslot-list 1-31
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.40.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.30.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Trunk-Serial1/2:1
     link-protocol tdm
     mpls l2vc 3.3.3.3 5 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa
     mpls l2vc 4.4.4.4 3 tdm-encapsulation-number 16 jitter-buffer 32 idle-code fa bypass
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.40.1.0 0.0.0.255
      network 10.30.1.0 0.0.0.255
    #
    return
Download
Updated: 2018-07-12

Document ID: EDOC1100028541

Views: 7368

Downloads: 92

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next