No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MCE

Example for Configuring MCE

Networking Requirements

The headquarters and branches of a company need to communicate through MPLS VPN, and two services of the company must be isolated. To reduce hardware costs, the company wants the branches to connect to the PE through one CE.

As shown in Figure 7-50, the networking requirements are as follows:

  • CE1 and CE2 connect to the headquarters. CE1 belongs to vpna, and CE2 belongs to vpnb.
  • The multi-VPN-instance CE (MCE) device connects to vpna and vpnb of the branches through CE3 and CE4.

Users in the same VPN need to communicate with each other, but users in different VPNs must be isolated.

Figure 7-50  Networking diagram for configuring MCE

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure OSPF between PEs to implement interworking between them and configure MP-IBGP to exchange VPN routing information.
  2. Configure basic MPLS capabilities and MPLS LDP on the PEs to set up LDP LSPs.
  3. Create VPN instances vpna and vpnb on the MCEs and PEs to isolate services.
  4. Set up EBGP peer relationships between PE1 and its connected CEs, and import BGP routes to the VPN routing table on PE1.
  5. Configure routing between the MCE and VPN sites and between the MCE and PE2.

Procedure

  1. Configure OSPF on PEs of the backbone network.

    # Configure PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] ip address 172.1.1.1 24
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    After the configuration is complete, PEs can learn Loopback1 address of each other.

    The information displayed on PE2 is used as an example.

    [PE2] display ip routing-table
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9        Routes : 9
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
           1.1.1.9/32 OSPF   10    1              D  172.1.1.1        GigabitEthernet1/0/0
            2.2.2.9/32  Direct 0    0              D  127.0.0.1        LoopBack1
          127.0.0.0/8   Direct 0    0              D  127.0.0.1        InLoopBack0
          127.0.0.1/32  Direct 0    0              D  127.0.0.1        InLoopBack0
    127.255.255.255/32  Direct 0    0              D  127.0.0.1        InLoopBack0
          172.1.1.0/24  Direct 0    0              D  172.1.1.2        GigabitEthernet1/0/0
          172.1.1.2/32  Direct 0    0              D  127.0.0.1        GigabitEthernet1/0/0
        172.1.1.255/32  Direct 0    0              D  127.0.0.1        GigabitEthernet1/0/0
    255.255.255.255/32  Direct 0    0              D  127.0.0.1        InLoopBack0

  2. Configure basic MPLS capabilities and MPLS LDP on the PEs to set up LDP LSPs.

    # Configure PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.
    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] mpls
    [PE1-GigabitEthernet3/0/0] mpls ldp
    [PE1-GigabitEthernet3/0/0] quit
    

    After the configuration is complete, run the display mpls ldp session command on the PEs. The command output shows that the MPLS LDP session between the PEs is in Operational state.

    The information displayed on PE2 is used as an example.

    [PE2] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
    ------------------------------------------------------------------------------
    PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
    ------------------------------------------------------------------------------ 
    1.1.1.9:0          Operational DU   Active   0000:00:04  17/17
    ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    

  3. Configure VPN instances on the PEs. On PE1, bind the VPN instances to the interfaces connected to CE1 and CE2 respectively. On PE2, bind the VPN instances to the interfaces connected to the MCE.

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] ipv4-family
    [PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] ipv4-family
    [PE1-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] ip binding vpn-instance vpna
    [PE1-GigabitEthernet1/0/0] ip address 10.1.1.2 24
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] ip binding vpn-instance vpnb
    [PE1-GigabitEthernet2/0/0] ip address 10.2.1.2 24
    [PE1-GigabitEthernet2/0/0] quit
    

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] ipv4-family
    [PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] ipv4-family
    [PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:2
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface gigabitethernet 2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [PE2-GigabitEthernet2/0/0.1] ip binding vpn-instance vpna
    [PE2-GigabitEthernet2/0/0.1] ip address 192.1.1.1 24
    [PE2-GigabitEthernet2/0/0.1] quit
    [PE2] interface gigabitethernet 2/0/0.2
    [PE2-GigabitEthernet2/0/0.2] dot1q termination vid 20
    [PE2-GigabitEthernet2/0/0.2] ip binding vpn-instance vpnb
    [PE2-GigabitEthernet2/0/0.2] ip address 192.2.1.1 24
    [PE2-GigabitEthernet2/0/0.2] quit
    

  4. Configure VPN instances on the MCE, and bind the VPN instances to the interfaces connected to CE3, CE4, and PE2.

    <Huawei> system-view
    [Huawei] sysname MCE
    [MCE] ip vpn-instance vpna
    [MCE-vpn-instance-vpna] ipv4-family
    [MCE-vpn-instance-vpna-af-ipv4] route-distinguisher 300:1
    [MCE-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [MCE-vpn-instance-vpna-af-ipv4] quit
    [MCE-vpn-instance-vpna] quit
    [MCE] ip vpn-instance vpnb
    [MCE-vpn-instance-vpnb] ipv4-family
    [MCE-vpn-instance-vpnb-af-ipv4] route-distinguisher 300:2
    [MCE-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [MCE-vpn-instance-vpnb-af-ipv4] quit
    [MCE-vpn-instance-vpnb] quit
    [MCE] interface gigabitethernet 3/0/0
    [MCE-GigabitEthernet3/0/0] ip binding vpn-instance vpna
    [MCE-GigabitEthernet3/0/0] ip address 10.3.1.2 24
    [MCE-GigabitEthernet3/0/0] quit
    [MCE] interface gigabitethernet 4/0/0
    [MCE-GigabitEthernet4/0/0] ip binding vpn-instance vpnb
    [MCE-GigabitEthernet4/0/0] ip address 10.4.1.2 24
    [MCE-GigabitEthernet4/0/0] quit
    [MCE] interface gigabitethernet 1/0/0.1
    [MCE-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [MCE-GigabitEthernet1/0/0.1] ip binding vpn-instance vpna
    [MCE-GigabitEthernet1/0/0.1] ip address 192.1.1.2 24
    [MCE-GigabitEthernet1/0/0.1] quit
    [MCE] interface gigabitethernet 1/0/0.2
    [MCE-GigabitEthernet1/0/0.2] dot1q termination vid 20
    [MCE-GigabitEthernet1/0/0.2] ip binding vpn-instance vpnb
    [MCE-GigabitEthernet1/0/0.2] ip address 192.2.1.2 24
    [MCE-GigabitEthernet1/0/0.2] quit
    

  5. Set up an MP-IBGP peer relationship between PEs. Set up EBGP peer relationships between PE1 and CE1, and between PE1 and CE2.

    # Configure CE1. The configuration on other PE1 and PE2 is similar to the configuration on CE1 and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] ipv4-family unicast
    [CE1-bgp-af-ipv4] import-route direct
    [CE1-bgp-af-ipv4] quit
    [CE1-bgp] quit

    After the configuration is complete, run the display bgp vpnv4 all peer command on PE1. The command output shows that the PE1 has set up an IBGP peer relationship with PE2 and EBGP peer relationships with CE1 and CE2. The peer relationships are in Established state.

    [PE1] display bgp vpnv4 all peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      2.2.2.9         4   100      288      287     0 01:19:16 Established       4
    
     Peer of IPv4-family for vpn instance :
    
     VPN-Instance vpna, router ID 1.1.1.9:
      10.1.1.1        4 65410        9       11     0 00:04:14 Established       4
    
     VPN-Instance vpnb, router ID 1.1.1.9:
      10.2.1.1        4 65420        9       12     0 00:04:09 Established       3
    

  6. Configure OSPF multi-instance between the MCE and PE2.

    # Configure PE2.

    [PE2] ospf 100 vpn-instance vpna
    [PE2-ospf-100] area 0
    [PE2-ospf-100-area-0.0.0.0] network 192.1.1.0 0.0.0.255
    [PE2-ospf-100-area-0.0.0.0] quit
    [PE2-ospf-100] import-route bgp
    [PE2-ospf-100] quit
    [PE2] ospf 200 vpn-instance vpnb
    [PE2-ospf-200] area 0
    [PE2-ospf-200-area-0.0.0.0] network 192.2.1.0 0.0.0.255
    [PE2-ospf-200-area-0.0.0.0] quit
    [PE2-ospf-200] import-route bgp
    [PE2-ospf-200] quit
    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpna
    [PE2-bgp-vpna] import-route ospf 100
    [PE2-bgp-vpna] quit
    [PE2-bgp] ipv4-family vpn-instance vpnb
    [PE2-bgp-vpnb] import-route ospf 200
    [PE2-bgp-vpnb] quit
    [PE2-bgp] quit
    

    # Configure the MCE.

    [MCE] ospf 100 vpn-instance vpna
    [MCE-ospf-100] area 0
    [MCE-ospf-100-area-0.0.0.0] network 192.1.1.0 0.0.0.255
    [MCE-ospf-100-area-0.0.0.0] quit
    [MCE-ospf-100] quit
    [MCE] ospf 200 vpn-instance vpnb
    [MCE-ospf-200] area 0
    [MCE-ospf-200-area-0.0.0.0] network 192.2.1.0 0.0.0.255
    [MCE-ospf-200-area-0.0.0.0] quit
    [MCE-ospf-200] quit
    

  7. Configure RIPv2 between the MCE and CE3, and between the MCE and CE4.

    # Configure the MCE.

    [MCE] rip 100 vpn-instance vpna
    [MCE-rip-100] version 2
    [MCE-rip-100] network 10.0.0.0
    [MCE-rip-100] import-route ospf 100
    [MCE-rip-100] quit
    [MCE] rip 200 vpn-instance vpnb
    [MCE-rip-200] version 2
    [MCE-rip-200] network 10.0.0.0
    [MCE-rip-200] import-route ospf 200
    [MCE-rip-200] quit
    

    # Configure CE3.

    <Huawei> system-view
    [Huawei] sysname CE3
    [CE3] rip 100
    [CE3-rip-100] version 2
    [CE3-rip-100] network 10.0.0.0
    [CE3-rip-100] import-route direct

    # Configure CE4.

    <Huawei> system-view
    [Huawei] sysname CE4
    [CE4] rip 200
    [CE4-rip-200] version 2
    [CE4-rip-200] network 10.0.0.0
    [CE4-rip-200] import-route direct
    

  8. Disable loop detection on the MCE device and import RIP routes.

    [MCE] ospf 100 vpn-instance vpna
    [MCE-ospf-100] vpn-instance-capability simple
    [MCE-ospf-100] import-route rip 100
    [MCE-ospf-100] quit
    [MCE] ospf 200 vpn-instance vpnb
    [MCE-ospf-200] vpn-instance-capability simple
    [MCE-ospf-200] import-route rip 200
    [MCE-ospf-200] quit
    

  9. Verify the configuration.

    # After the configuration is complete, run the display ip routing-table vpn-instance command on the MCE. The command output shows the route to the remote CE.

    # The VPN instance vpna is used as an example.

    [MCE] display ip routing-table vpn-instance vpna
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
             Destinations : 8        Routes : 8
    
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
           10.1.1.0/24  O_ASE  150  1              D  192.1.1.1       GigabitEthernet1/0/0.1
           10.3.1.0/24  Direct 0    0              D  10.3.1.2        GigabitEthernet3/0/0
           10.3.1.2/32  Direct 0    0              D  127.0.0.1       GigabitEthernet3/0/0
         10.3.1.255/32  Direct 0    0              D  127.0.0.1       GigabitEthernet3/0/0
          192.1.1.0/24  Direct 0    0              D  192.1.1.2       GigabitEthernet1/0/0.1
          192.1.1.2/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0.1
        192.1.1.255/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0.1
    255.255.255.255/32  Direct 0    0              D  127.0.0.1       InLoopBack0   

    # Run the display ip routing-table vpn-instance command on the PE. The command output shows the route to the remote CE.

    # The VPN instance vpna on PE1 is used as an example.

    [PE1] display ip routing-table vpn-instance vpna
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
             Destinations : 6        Routes : 6
    
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
           10.1.1.0/24  Direct 0    0              D  10.1.1.2        GigabitEthernet1/0/0
           10.1.1.2/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0
           10.3.1.0/24  IBGP   255  2             RD  2.2.2.9         GigabitEthernet3/0/0
          192.1.1.0/24  IBGP   255  0             RD  2.2.2.9         GigabitEthernet3/0/0
    255.255.255.255/32  Direct 0    0              D  127.0.0.1       InLoopBack0   
    

    # CE1 and CE3 can ping each other, and CE2 and CE4 can ping each other.

    # The ping from CE1 to CE3 is used as an example.

    [CE1] ping 10.3.1.1
      PING 10.3.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.3.1.1: bytes=56 Sequence=1 ttl=252 time=125 ms
        Reply from 10.3.1.1: bytes=56 Sequence=2 ttl=252 time=125 ms
        Reply from 10.3.1.1: bytes=56 Sequence=3 ttl=252 time=125 ms
        Reply from 10.3.1.1: bytes=56 Sequence=4 ttl=252 time=125 ms
        Reply from 10.3.1.1: bytes=56 Sequence=5 ttl=252 time=125 ms
      --- 10.3.1.1 ping statistics ---
    
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 125/125/125 ms
    

    # CE1 cannot ping CE2 or CE4. CE3 cannot ping CE2 or CE4.

    # For example, if you ping CE4 from CE1, the following information is displayed:

    [CE1] ping 10.4.1.1
      PING 10.4.1.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
    
      --- 10.4.1.1 ping statistics ---
        5 packet(s) transmitted
        0 packet(s) received
        100.00% packet loss
    
    

Configuration Files

  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    bgp 65410
     peer 10.1.1.2 as-number 100 
    #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    bgp 65420
     peer 10.2.1.2 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
     #
     ipv4-family vpn-instance vpna
      peer 10.1.1.1 as-number 65410
      import-route direct
     #
     ipv4-family vpn-instance vpnb
      peer 10.2.1.1 as-number 65420
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     ip binding vpn-instance vpna
     ip address 192.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.2
     dot1q termination vid 20
     ip binding vpn-instance vpnb
     ip address 192.2.1.1 255.255.255.0
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route ospf 100
     #
     ipv4-family vpn-instance vpnb
      import-route ospf 200
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    ospf 100 vpn-instance vpna
    import-route bgp
     area 0.0.0.0
      network 192.1.1.0 0.0.0.255
    #
    ospf 200 vpn-instance vpnb
    import-route bgp
     area 0.0.0.0
      network 192.2.1.0 0.0.0.255
    #
    return
  • MCE configuration file

    #
     sysname MCE
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 300:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 300:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip binding vpn-instance vpna
     ip address 192.1.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0.2
     dot1q termination vid 20
     ip binding vpn-instance vpnb
     ip address 192.2.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.0
    #
    interface GigabitEthernet4/0/0
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.0
    #
    ospf 100 vpn-instance vpna
     import-route rip 100
     vpn-instance-capability simple
     area 0.0.0.0
      network 192.1.1.0 0.0.0.255
    #
    ospf 200 vpn-instance vpnb
     import-route rip 200
     vpn-instance-capability simple
     area 0.0.0.0
      network 192.2.1.0 0.0.0.255
    #
    rip 100 vpn-instance vpna
     version 2
     network 10.0.0.0
     import-route ospf 100
    #
    rip 200 vpn-instance vpnb
     version 2
     network 10.0.0.0
     import-route ospf 200
    #
    return
  • CE3 configuration file

    #
     sysname CE3
    #
    interface GigabitEthernet1/0/0
     ip address 10.3.1.1 255.255.255.0
    #
    rip 100
     version 2
     network 10.0.0.0
     import-route direct
    #
    return
  • CE4 configuration file

    #
     sysname CE4
    #
    interface GigabitEthernet1/0/0
     ip address 10.4.1.1 255.255.255.0
    #
    rip 200
     version 2
     network 10.0.0.0
     import-route direct
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 143750

Downloads: 361

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next