No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring GRE to Implement Communication Between FR Networks

Example for Configuring GRE to Implement Communication Between FR Networks

Networking Requirements

As shown in Figure 3-25, Router_1 and Router_2 use the OSPF protocol to implement communication over the public network. The customer requires that FR networks can communicate over the public network.

Figure 3-25  Configuring GRE to implement communication between FR networks

Configuration Roadmap

To implement communication between FR networks, you need to directly connect Router_1 and Router_2 using a GRE tunnel and configure the link bridge function.

  1. Configure an IGP (OSPF process 1 in this example) to implement interworking between the devices.

  2. Set up a GRE tunnel between the routers and configure the link bridge function, so that traffic from FR networks can be transmitted over the GRE tunnel.

Procedure

  1. Configure an IP address for each physical interface.

    # Configure Router_1.

    <Huawei> system-view
    [Huawei] sysname Router_1
    [Router_1] interface gigabitethernet 1/0/0
    [Router_1-GigabitEthernet1/0/0] ip address 1.1.1.1 255.255.255.0
    [Router_1-GigabitEthernet1/0/0] quit
    [Router_1] interface serial 1/0/0
    [Router_1-Serial1/0/0] link-protocol fr
    [Router_1-Serial1/0/0] fr dlci 200
    [Router_1-fr-dlci-Serial1/0/0-200] quit
    [Router_1-Serial1/0/0] quit

    # Configure Router_2.

    <Huawei> system-view
    [Huawei] sysname Router_2
    [Router_2] interface gigabitethernet 1/0/0
    [Router_2-GigabitEthernet1/0/0] ip address 2.1.1.1 255.255.255.0
    [Router_2-GigabitEthernet1/0/0] quit
    [Router_2] interface serial 1/0/0
    [Router_2-Serial1/0/0] link-protocol fr
    [Router_2-Serial1/0/0] fr dlci 200
    [Router_2-fr-dlci-Serial1/0/0-200] quit
    [Router_2-Serial1/0/0] quit

  2. Configure OSPF to ensure reachable routes between the routers over the public network.

    # Configure Router_1.

    [Router_1] ospf 1
    [Router_1-ospf-1] area 0
    [Router_1-ospf-1-area-0.0.0.0] network 1.1.1.0 0.0.0.255
    [Router_1-ospf-1-area-0.0.0.0] quit
    [Router_1-ospf-1] quit

    # Configure Router_2.

    [Router_2] ospf 1
    [Router_2-ospf-1] area 0
    [Router_2-ospf-1-area-0.0.0.0] network 2.1.1.0 0.0.0.255
    [Router_2-ospf-1-area-0.0.0.0] quit
    [Router_2-ospf-1] quit

  3. Configure tunnel interfaces.

    # Configure Router_1.

    [Router_1] interface tunnel 0/0/1
    [Router_1-Tunnel0/0/1] tunnel-protocol gre
    [Router_1-Tunnel0/0/1] ip address 10.3.1.1 255.255.255.0
    [Router_1-Tunnel0/0/1] source 1.1.1.1
    [Router_1-Tunnel0/0/1] destination 2.1.1.1
    [Router_1-Tunnel0/0/1] quit

    # Configure Router_2.

    [Router_2] interface tunnel 0/0/1
    [Router_2-Tunnel0/0/1] tunnel-protocol gre
    [Router_2-Tunnel0/0/1] ip address 10.3.1.2 255.255.255.0
    [Router_2-Tunnel0/0/1] source 2.1.1.1
    [Router_2-Tunnel0/0/1] destination 1.1.1.1
    [Router_2-Tunnel0/0/1] quit

    # After the configuration is complete, the tunnel interfaces turn Up and can ping each other.

  4. Configure the link bridge function.

    # Configure Router_1.

    [Router_1] link-bridge 2 interface serial 1/0/0 out-interface tunnel 0/0/1
    

    # Configure Router_2.

    [Router_2] link-bridge 2 interface serial 1/0/0 out-interface tunnel 0/0/1
    

  5. Verify the configuration.

    # FR networks can communicate over the public network.

Configuration Files

  • Configuration file of Router_1

    #
     sysname Router_1
    #
     link-bridge 2 interface Serial1/0/0 out-interface Tunnel0/0/1
    # 
    interface Serial1/0/0
     link-protocol fr 
     fr dlci 200 
    #
    interface GigabitEthernet1/0/0
     ip address 1.1.1.1 255.255.255.0
    #
    interface Tunnel0/0/1
     ip address 10.3.1.1 255.255.255.0
     tunnel-protocol gre
     source 1.1.1.1
     destination 2.1.1.1
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.0 0.0.0.255
    #
    return
  • Configuration file of Router_2

    #
     sysname Router_2
    #
     link-bridge 2 interface Serial1/0/0 out-interface Tunnel0/0/1
    # 
    interface Serial1/0/0
     link-protocol fr 
     fr dlci 200 
    #
    interface GigabitEthernet1/0/0
     ip address 2.1.1.1 255.255.255.0
    #
    interface Tunnel0/0/1
     ip address 10.3.1.2 255.255.255.0
     tunnel-protocol gre
     source 2.1.1.1
     destination 1.1.1.1
    #
    ospf 1
     area 0.0.0.0
      network 2.1.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 145301

Downloads: 361

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next