No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an OSPF Sham Link

Example for Configuring an OSPF Sham Link

Networking Requirements

As shown in Figure 7-53, CE1 and CE2 belong to the same OSPF area of VPN1 and they connect to PE1 and PE2 respectively. A backdoor link exists between CE1 and CE2 and is used as a backup link.

The CEs and PEs need to run OSPF. When the backbone network is running properly, VPN traffic of CE1 and CE2 should be forwarded over the MPLS backbone network without passing through the backdoor link.

Figure 7-53  Networking diagram for configuring OSPF sham link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Set up an ME-IBGP peer relationship between the PEs and configure OSPF between the PEs and CEs.

  2. Create a VPN instance on the PEs and bind it to the interfaces connected to CEs.

  3. Create an OSPF sham link on the PEs.

  4. Set the cost of the backdoor link to be larger than the cost of the sham link so that VPN traffic is transmitted over the MPLS backbone network.

Procedure

  1. Configure OSPF on the customer network.

    Configure OSPF on CE1, RTA, and CE2 and advertise the network segment of each interface.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet2/0/0
    [CE1-GigabitEthernet2/0/0] ip address 20.1.1.1 24
    [CE1-GigabitEthernet2/0/0] quit
    [CE1] interface gigabitethernet1/0/0
    [CE1-GigabitEthernet1/0/0] ip address 100.1.1.1 24
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] ospf
    [CE1-ospf-1] area 0
    [CE1-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [CE1-ospf-1-area-0.0.0.0] network 100.1.1.0 0.0.0.255
    [CE1-ospf-1-area-0.0.0.0] quit
    [CE1-ospf-1] quit
    

    # Configure RTA.

    <Huawei> system-view
    [Huawei] sysname RTA
    [RTA] interface gigabitethernet 1/0/0
    [RTA-GigabitEthernet1/0/0] ip address 20.1.1.2 24
    [RTA-GigabitEthernet1/0/0] quit
    [RTA] interface gigabitethernet 2/0/0
    [RTA-GigabitEthernet2/0/0] ip address 30.1.1.1 24
    [RTA-GigabitEthernet2/0/0] quit
    [RTA] ospf
    [RTA-ospf-1] area 0
    [RTA-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [RTA-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [RTA-ospf-1-area-0.0.0.0] quit
    [RTA-ospf-1] quit
    

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] interface gigabitethernet 2/0/0
    [CE2-GigabitEthernet2/0/0] ip address 30.1.1.2 24
    [CE2-GigabitEthernet2/0/0] quit
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] ip address 120.1.1.2 24
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] ospf
    [CE2-ospf-1] area 0
    [CE2-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [CE2-ospf-1-area-0.0.0.0] network 120.1.1.0 0.0.0.255
    [CE2-ospf-1-area-0.0.0.0] quit
    [CE2-ospf-1] quit
    

  2. Complete basic BGP/MPLS IP VPN configuration on the backbone network: configure an IGP, enable MPLS and LDP, and set up an MP-IBGP peer relationship between the PEs.

    # Configure PE1.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] ip address 10.1.1.1 24
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] mpls
    [PE1-GigabitEthernet2/0/0] mpls ldp
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] ospf 1 router-id 1.1.1.9
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.9 as-number 100
    [PE1-bgp] peer 3.3.3.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit
    

    # Configure P.

    <Huawei> system-view
    [Huawei] sysname P
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] ip address 10.1.1.2 24
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] ip address 40.1.1.1 24
    [P-GigabitEthernet2/0/0] quit
    [P] interface loopback 1
    [P-LoopBack1] ip address 2.2.2.9 32
    [P-LoopBack1] quit
    [P] mpls lsr-id 2.2.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] mpls
    [P-GigabitEthernet1/0/0] mpls ldp
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] mpls
    [P-GigabitEthernet2/0/0] mpls ldp
    [P-GigabitEthernet2/0/0] quit
    [P] ospf 1 router-id 2.2.2.9
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [P-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit
    

    # Configure PE2.

    <Huawei> system-view
    [Huawei] sysname PE2
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] ip address 40.1.1.2 24
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 3.3.3.9 32
    [PE2-LoopBack1] quit
    [PE2] mpls lsr-id 3.3.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] mpls
    [PE2-GigabitEthernet2/0/0] mpls ldp
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] ospf 1 router-id 3.3.3.9
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.9 as-number 100
    [PE2-bgp] peer 1.1.1.9 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit
    

    After the configuration is complete, PE1 and PE2 can learn the route to the loopback interface of each other and set up an MP-IBGP peer relationship.

  3. Configure OSPF between the PEs and CEs.

    # Configure PE1.

    [PE1] ip vpn-instance vpn1
    [PE1-vpn-instance-vpn1] ipv4-family
    [PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1
    [PE1-vpn-instance-vpn1-af-ipv4] quit
    [PE1-vpn-instance-vpn1] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] ip binding vpn-instance vpn1
    [PE1-GigabitEthernet1/0/0] ip address 100.1.1.2 24
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] ospf 100 router-id 5.5.5.5 vpn-instance vpn1
    [PE1-ospf-100] domain-id 10
    [PE1-ospf-100] import-route bgp
    [PE1-ospf-100] area 0
    [PE1-ospf-100-area-0.0.0.0] network 100.1.1.0 0.0.0.255
    [PE1-ospf-100-area-0.0.0.0] quit
    [PE1-ospf-100] quit
    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpn1
    [PE1-bgp-vpn1] import-route direct
    [PE1-bgp-vpn1] import-route ospf 100
    [PE1-bgp-vpn1] quit
    [PE1-bgp] quit
    

    # Configure PE2.

    [PE2] ip vpn-instance vpn1
    [PE2-vpn-instance-vpn1] ipv4-family
    [PE2-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:2
    [PE2-vpn-instance-vpn1-af-ipv4] vpn-target 1:1
    [PE2-vpn-instance-vpn1-af-ipv4] quit
    [PE2-vpn-instance-vpn1] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] ip binding vpn-instance vpn1
    [PE2-GigabitEthernet1/0/0] ip address 120.1.1.1 24
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] ospf 100 router-id 6.6.6.6 vpn-instance vpn1
    [PE2-ospf-100] import-route bgp
    [PE2-ospf-100] domain-id 10
    [PE2-ospf-100] area 0
    [PE2-ospf-100-area-0.0.0.0] network 120.1.1.0 0.0.0.255
    [PE2-ospf-100-area-0.0.0.0] quit
    [PE2-ospf-100] quit
    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpn1
    [PE2-bgp-vpn1] import-route direct
    [PE2-bgp-vpn1] import-route ospf 100
    [PE2-bgp-vpn1] quit
    [PE2-bgp] quit
    

    After the configuration is complete, run the display ip routing-table vpn-instance command on the PEs. The command output shows that the routes to the remote CEs are OSPF routes through the customer network, not the BGP routes through the backbone network.

    The information displayed on PE1 is used as an example.

    [PE1] display ip routing-table vpn-instance vpn1
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpn1
             Destinations : 7        Routes : 7
      Destination/Mask  Proto  Pre  Cost         Flags  NextHop       Interface
           20.1.1.0/24  OSPF   10   2                D  100.1.1.1     GigabitEthernet1/0/0
           30.1.1.0/24  OSPF   10   3                D  100.1.1.1     GigabitEthernet1/0/0
          100.1.1.0/24  Direct 0    0                D  100.1.1.2     GigabitEthernet1/0/0
          100.1.1.2/32  Direct 0    0                D  127.0.0.1     GigabitEthernet1/0/0
        100.1.1.255/32  Direct 0    0                D  127.0.0.1     GigabitEthernet1/0/0
          120.1.1.0/24  OSPF   10   4                D  100.1.1.1     GigabitEthernet1/0/0
    255.255.255.255/32  Direct 0    0                D  127.0.0.1     InLoopBack0 

  4. Configure an OSPF sham link.

    NOTE:

    To forward VPN traffic through the MPLS backbone network, ensure that the cost of the sham link is smaller than the cost of the OSPF route used for forwarding VPN traffic over the customer network. A commonly used method is to set the cost of the forwarding interface on the customer network to be larger than the cost of the sham link.

    # Configure CE1.

    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] ospf cost 10
    [CE1-GigabitEthernet2/0/0] quit
    

    # Configure CE2.

    [CE2] interface gigabitethernet 2/0/0
    [CE2-GigabitEthernet2/0/0] ospf cost 10
    [CE2-GigabitEthernet2/0/0] quit
    

    # Configure PE1.

    [PE1] interface loopback 10
    [PE1-LoopBack10] ip binding vpn-instance vpn1
    [PE1-LoopBack10] ip address 5.5.5.5 32
    [PE1-LoopBack10] quit
    [PE1] ospf 100
    [PE1-ospf-100] area 0
    [PE1-ospf-100-area-0.0.0.0] sham-link 5.5.5.5 6.6.6.6 cost 1
    [PE1-ospf-100-area-0.0.0.0] quit
    [PE1-ospf-100] quit
    

    # Configure PE2.

    [PE2] interface loopback 10
    [PE2-LoopBack10] ip binding vpn-instance vpn1
    [PE2-LoopBack10] ip address 6.6.6.6 32
    [PE2-LoopBack10] quit
    [PE2] ospf 100
    [PE2-ospf-100] area 0
    [PE2-ospf-100-area-0.0.0.0] sham-link 6.6.6.6 5.5.5.5 cost 1
    [PE2-ospf-100-area-0.0.0.0] quit
    [PE2-ospf-100] quit
    

  5. Verify the configuration.

    # After the configuration is complete, run the display ip routing-table vpn-instance command on the PEs. The command output shows that the routes to the remote CEs are BGP routes through the backbone network, and there are routes to the destination of the sham link.

    # The information displayed on PE1 is used as an example.

    [PE1] display ip routing-table vpn-instance vpn1
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpn1
             Destinations : 9        Routes : 9
      Destination/Mask  Proto  Pre  Cost      Flags  NextHop           Interface
            5.5.5.5/32  Direct 0    0             D  127.0.0.1         LoopBack10
            6.6.6.6/32  IBGP   255  0            RD  3.3.3.9           GigabitEthernet2/0/0
           20.1.1.0/24  OSPF   10   11            D  100.1.1.1         GigabitEthernet1/0/0
           30.1.1.0/24  OSPF   10   12            D  100.1.1.1         GigabitEthernet1/0/0
          100.1.1.0/24  Direct 0    0             D  100.1.1.2         GigabitEthernet1/0/0
          100.1.1.2/32  Direct 0    0             D  127.0.0.1         GigabitEthernet1/0/0
        100.1.1.255/32  Direct 0    0             D  127.0.0.1         GigabitEthernet1/0/0
          120.1.1.0/24  IBGP   255  0            RD  3.3.3.9           GigabitEthernet2/0/0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1         InLoopBack0 

    # Run the display ip routing-table command on the CEs. The command output shows that the cost of the OSPF route to the remote CE has changed to 3, and the next hop has changed to the interface connected to PE. That is, VPN traffic to the remote CE is forwarded through the backbone network.

    # The information displayed on CE1 is used as an example.

    [CE1] display ip routing-table
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 14       Routes : 14
      Destination/Mask  Proto  Pre   Cost        Flags NextHop         Interface
            5.5.5.5/32  O_ASE  150   1              D  100.1.1.2       GigabitEthernet1/0/0
            6.6.6.6/32  O_ASE  150   1              D  100.1.1.2       GigabitEthernet1/0/0
           20.1.1.0/24  Direct 0     0              D  20.1.1.1        GigabitEthernet2/0/0
           20.1.1.1/32  Direct 0     0              D  127.0.0.1       GigabitEthernet2/0/0
         20.1.1.255/32  Direct 0     0              D  127.0.0.1       GigabitEthernet2/0/0
           30.1.1.0/24  OSPF   10    11             D  20.1.1.2        GigabitEthernet2/0/0
          100.1.1.0/24  Direct 0     0              D  100.1.1.1       GigabitEthernet1/0/0
          100.1.1.1/32  Direct 0     0              D  127.0.0.1       GigabitEthernet1/0/0
        100.1.1.255/32  Direct 0     0              D  127.0.0.1       GigabitEthernet1/0/0
         120.1.1.0/24 OSPF   10    3              D  100.1.1.2       GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0     0              D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0     0              D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0     0              D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0     0              D  127.0.0.1       InLoopBack0
    
    
    NOTE:

    Cost of the OSPF route from CE1 to CE2 = Cost of the path from CE1 to PE1 + Cost of the sham link + Cost of the path from PE2 to CE2 = 1 + 1 + 1 = 3

    # Run the tracert command on CE1. The command output shows that the data sent from CE1 to CE2 passes through the interface connected to PE1. That is, VPN traffic is transmitted through the backbone network.

    [CE1] tracert 120.1.1.1
     traceroute to  120.1.1.1(120.1.1.1), max hops: 30 ,packet length: 40,press CTRL_C to break 
     1 100.1.1.2 10 ms  1 ms  1 ms                                                  
     2 10.1.1.2 10 ms  1 ms  1 ms                                                   
     3 120.1.1.1 10 ms  2 ms  1 ms 
    [CE1] tracert 30.1.1.2
     traceroute to  30.1.1.2(30.1.1.2), max hops: 30 ,packet length: 40,press CTRL_C to break
     1 20.1.1.2 10 ms  1 ms  1 ms                                                   
     2 30.1.1.2 10 ms  2 ms  1 ms  

    # Run the display ospf 100 sham-link command on the PEs to check information about the sham link.

    # The information displayed on PE1 is used as an example.

    [PE1] display ospf 100 sham-link
                                                                                       
             OSPF Process 100 with Router ID 5.5.5.5                                
     Sham Link:                                                                     
     Area            NeighborId      Source-IP       Destination-IP  State Cost     
     0.0.0.0         6.6.6.6         5.5.5.5         6.6.6.6         P-2-P 1        

    # Run the display ospf sham-link area command. The command output shows that the neighbor relationship is in Full state.

    [PE1] display ospf sham-link area 0
                                                                                     
             OSPF Process 1 with Router ID 1.1.1.9                                  
                                                                                    
             OSPF Process 100 with Router ID 5.5.5.5                                
                                                                                    
      Sham-Link: 5.5.5.5 --> 6.6.6.6                                                
      Neighbor ID: 6.6.6.6,    State: Full,    GR status: Normal                    
      Area: 0.0.0.0                                                                 
      Cost: 1  State: P-2-P, Type: Sham                                             
      Timers: Hello 10 , Dead 40 , Retransmit 5 , Transmit Delay 1                  

    # Run the display ospf routing command on the CEs. The command output shows that the route to the remote CE is learned as an intra-area route.

    [CE1] display ospf routing
              OSPF Process 1 with Router ID 100.1.1.1
                       Routing Tables
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     120.1.1.0/24       3     Transit    100.1.1.2       6.6.6.6         0.0.0.0
     20.1.1.0/24        10    Transit    20.1.1.1        100.1.1.1       0.0.0.0
     30.1.1.0/24        11    Transit    20.1.1.2        30.1.1.1        0.0.0.0
     100.1.1.0/24       1     Transit    100.1.1.1       100.1.1.1       0.0.0.0
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     6.6.6.6/32         1         Type2      3489661028  100.1.1.2       5.5.5.5
     5.5.5.5/32         1         Type2      3489661028  100.1.1.2       6.6.6.6
    
     Total Nets: 6
     Intra Area: 4  Inter Area: 0  ASE: 2  NSSA: 0

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip binding vpn-instance vpn1
     ip address 100.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface LoopBack10
     ip binding vpn-instance vpn1
     ip address 5.5.5.5 255.255.255.255
    #
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance vpn1
      import-route direct
      import-route ospf 100
    #
    ospf 1 router-id 1.1.1.9
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    ospf 100 router-id 5.5.5.5 vpn-instance vpn1
     import-route bgp
     domain-id 0.0.0.10
     area 0.0.0.0
      network 100.1.1.0 0.0.0.255
      sham-link 5.5.5.5 6.6.6.6
    #
    return
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 40.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1 router-id 2.2.2.9
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 40.1.1.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 100:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 3.3.3.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip binding vpn-instance vpn1
     ip address 120.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 40.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    interface LoopBack10
     ip binding vpn-instance vpn1
     ip address 6.6.6.6 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance vpn1
      import-route direct
      import-route ospf 100
    #
    ospf 1 router-id 3.3.3.9  
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 40.1.1.0 0.0.0.255
    #
    ospf 100 router-id 6.6.6.6 vpn-instance vpn1
     import-route bgp
     domain-id 0.0.0.10
     area 0.0.0.0
      network 120.1.1.0 0.0.0.255
      sham-link 6.6.6.6 5.5.5.5
    #
    return
  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
     ip address 100.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 20.1.1.1 255.255.255.0
     ospf cost 10
    #
    ospf 1
     area 0.0.0.0
      network 100.1.1.0 0.0.0.255
      network 20.1.1.0 0.0.0.255
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
     ip address 120.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 30.1.1.2 255.255.255.0
     ospf cost 10
    #
    ospf 1
     area 0.0.0.0
      network 30.1.1.0 0.0.0.255
      network 120.1.1.0 0.0.0.255
    #
    return
  • RTA configuration file

    #
     sysname RTA
    #
    interface GigabitEthernet1/0/0
     ip address 20.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 30.1.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 20.1.1.0 0.0.0.255
      network 30.1.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 141970

Downloads: 357

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next