No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Tunnel Policy for an L3VPN

Example for Configuring a Tunnel Policy for an L3VPN

Networking Requirements

As shown in Figure 7-66, CE1 and CE3 belong to vpna, and CE2 and CE4 belong to vpnb. Two MPLS TE tunnels and one LSP are set up between PE1 and PE2. To use the tunnels more efficiently, vpnb uses multiple tunnels to share the loads and prefers the TE tunnels for load balancing.

Figure 7-66  Networking diagram for configuring a tunnel policy for an L3VPN

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol so that PEs can communicate with each other.

  2. Configure basic MPLS capabilities on the routers on the backbone network and set up an LSP and two MPLS TE tunnels between the PEs.

  3. Configure VPN instances on PEs and connect CEs to the PEs.

  4. Configure tunnel policies and apply the policies to different VPN instances.

  5. Configure MP-IBGP to exchange VPN routing information.

Procedure

  1. Configure an IGP on the MPLS backbone network so that PEs can communicate.

    # Configure PE1.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] quit
    [PE1] interface gigabitethernet1/0/0
    [PE1-GigabitEthernet1/0/0] ip address 100.1.1.1 30
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 100.1.1.0 0.0.0.3
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure PE2.

    <Huawei> system-view
    [Huawei] sysname PE2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.2 32
    [PE2-LoopBack1] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] ip address 100.1.1.2 30
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 100.1.1.0 0.0.0.3
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    # After the configuration is complete, run the display ip routing-table command on PEs, and you can view that PEs have learned the routes to Loopback1 interfaces from each other.

    # The information displayed on PE1 is used as an example.

    [PE1] display ip routing-table
    Route Flags: R - relay, D - download to forwarding
    ------------------------------------------------------------------------------
    Routing Tables: _public_
             Destinations : 9      Routes : 9
    Destination/Mask    Proto  Pre  Cost       Flags  NextHop         Interface
            1.1.1.1/32  Direct 0    0              D  127.0.0.1       LoopBack1
            2.2.2.2/32 OSPF   10  1               D  100.1.1.2       GigabitEthernet1/0/0
          100.1.1.0/30  Direct 0    0              D  100.1.1.1       GigabitEthernet1/0/0
          100.1.1.1/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0
          100.1.1.3/32  Direct 0    0              D  127.0.0.1       GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0    0              D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0              D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0              D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0              D  127.0.0.1       InLoopBack0

  2. Configure basic MPLS capabilities on the MPLS backbone to set up an LDP LSP between PEs.

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] mpls
    [PE1-GigabitEthernet1/0/0] mpls ldp
    [PE1-GigabitEthernet1/0/0] quit

    # Configure PE2.

    [PE2] mpls lsr-id 2.2.2.2
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] mpls
    [PE2-GigabitEthernet1/0/0] mpls ldp
    [PE2-GigabitEthernet1/0/0] quit

    # After the configuration is complete, an LDP LSP is set up between PE1 and PE2. Run the display tunnel-info all command, and you can find the LSP destined for the address 2.2.2.2. Run the display mpls ldp lsp command, and you can view LSP information.

    # The information displayed on PE1 is used as an example.

    [PE1] display tunnel-info all
     * -> Allocated VC Token
    Tunnel ID           Type                 Destination           Token
    ----------------------------------------------------------------------
    0x15                lsp                   2.2.2.2                21      
    0x16                lsp                   2.2.2.2                22      
    
    [PE1] display mpls ldp lsp
      LDP LSP Information
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop         OutInterface
     -------------------------------------------------------------------------------
     1.1.1.1/32         3/NULL         2.2.2.2         127.0.0.1       InLoop0
    *1.1.1.1/32         Liberal/16                     DS/2.2.2.2
     2.2.2.2/32         NULL/3         -               100.1.1.2       GE1/0/0      
     2.2.2.2/32         16/3           2.2.2.2         100.1.1.2       GE1/0/0      
     -------------------------------------------------------------------------------
     TOTAL: 3 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established
     A '*' before a Label means the USCB or DSCB is stale
     A '*' before a UpstreamPeer means the session is stale
     A '*' before a DS means the session is stale
     A '*' before a NextHop means the LSP is FRR LSP

  3. Set up MPLS TE tunnels between PEs.

    # Configure PE1.

    [PE1] mpls
    [PE1-mpls] mpls te
    [PE1-mpls] mpls rsvp-te
    [PE1-mpls] mpls te cspf
    [PE1-mpls] quit
    [PE1] interface gigabitethernet1/0/0
    [PE1-GigabitEthernet1/0/0] mpls te
    [PE1-GigabitEthernet1/0/0] mpls rsvp-te
    [PE1-GigabitEthernet1/0/0] quit

    # Configure PE2.

    [PE2] mpls
    [PE2-mpls] mpls te
    [PE2-mpls] mpls rsvp-te
    [PE2-mpls] mpls te cspf
    [PE2-mpls] quit
    [PE2] interface gigabitethernet1/0/0
    [PE2-GigabitEthernet1/0/0] mpls te
    [PE2-GigabitEthernet1/0/0] mpls rsvp-te
    [PE2-GigabitEthernet1/0/0] quit

    # Enable OSPF on the devices along the TE tunnels to transmit TE attributes.

    # Configure PE1.

    [PE1] ospf 1
    [PE1-ospf-1] opaque-capability enable
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] mpls-te enable
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure PE2.

    [PE2] ospf 1
    [PE2-ospf-1] opaque-capability enable
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] mpls-te enable
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    # Configure an MPLS TE tunnel.

    # Configure PE1.

    [PE1] interface tunnel 0/0/1
    [PE1-Tunnel0/0/1] ip address unnumbered interface loopback 1
    [PE1-Tunnel0/0/1] tunnel-protocol mpls te
    [PE1-Tunnel0/0/1] destination 2.2.2.2
    [PE1-Tunnel0/0/1] mpls te tunnel-id 11
    [PE1-Tunnel0/0/1] mpls te commit
    [PE1-Tunnel0/0/1] quit

    # Configure PE2.

    [PE2] interface tunnel 0/0/1
    [PE2-Tunnel0/0/1] ip address unnumbered interface loopback 1
    [PE2-Tunnel0/0/1] tunnel-protocol mpls te
    [PE2-Tunnel0/0/1] destination 1.1.1.1
    [PE2-Tunnel0/0/1] mpls te tunnel-id 11
    [PE2-Tunnel0/0/1] mpls te commit
    [PE2-Tunnel0/0/1] quit

    # Configure an MPLS TE tunnel and bind the tunnel to the VPN.

    # Configure PE1.

    [PE1] interface tunnel 0/0/2
    [PE1-Tunnel0/0/2] ip address unnumbered interface loopback 1
    [PE1-Tunnel0/0/2] tunnel-protocol mpls te
    [PE1-Tunnel0/0/2] destination 2.2.2.2
    [PE1-Tunnel0/0/2] mpls te tunnel-id 22
    [PE1-Tunnel0/0/2] mpls te reserved-for-binding
    [PE1-Tunnel0/0/2] mpls te commit
    [PE1-Tunnel0/0/2] quit

    # Configure PE2.

    [PE2] interface tunnel 0/0/2
    [PE2-Tunnel0/0/2] ip address unnumbered interface loopback 1
    [PE2-Tunnel0/0/2] tunnel-protocol mpls te
    [PE2-Tunnel0/0/2] destination 1.1.1.1
    [PE2-Tunnel0/0/2] mpls te tunnel-id 22
    [PE2-Tunnel0/0/2] mpls te reserved-for-binding
    [PE2-Tunnel0/0/2] mpls te commit
    [PE2-Tunnel0/0/2] quit

    # After the configuration is complete, run the display mpls te tunnel-interface command on PEs, and you can view that Tunnel0/0/1 and Tunnel0/0/2 are both Up. The information displayed on PE1 is used as an example.

    [PE1] display mpls te tunnel-interface
        ----------------------------------------------------------------            
                                   Tunnel0/0/1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  11                                                   
        Ingress LSR ID      :  1.1.1.1          Egress LSR ID:  2.2.2.2             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 1                    
                                                                                    
        ----------------------------------------------------------------            
                                   Tunnel0/0/2                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  22                                                   
        Ingress LSR ID      :  1.1.1.1          Egress LSR ID:  2.2.2.2             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 2                    

  4. Configure VPN instances on PEs and bind the instances to the interfaces connected to CEs.

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] ipv4-family
    [PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] ipv4-family
    [PE1-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface gigabitethernet2/0/0
    [PE1-GigabitEthernet2/0/0] ip binding vpn-instance vpna
    [PE1-GigabitEthernet2/0/0] ip address 10.1.1.2 30
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] ip binding vpn-instance vpnb
    [PE1-GigabitEthernet3/0/0] ip address 10.2.1.2 30
    [PE1-GigabitEthernet3/0/0] quit

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] ipv4-family
    [PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 100:3
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] ipv4-family
    [PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:4
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] ip binding vpn-instance vpna
    [PE2-GigabitEthernet2/0/0] ip address 10.3.1.2 30
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface gigabitethernet 3/0/0
    [PE2-GigabitEthernet3/0/0] ip binding vpn-instance vpnb
    [PE2-GigabitEthernet3/0/0] ip address 10.4.1.2 30
    [PE2-GigabitEthernet3/0/0] quit

    # Assign IP addresses to the interfaces on the CEs according to Figure 7-66. The configuration procedure is not provided here.

    # After the configuration is complete, run the display ip vpn-instance verbose command on PEs, and you can view configuration of the VPN instances.

    NOTE:

    If a PE has multiple interfaces bound to the same VPN, when you run the ping command to ping the CE connected to the remote PE, specify the source IP address; that is, specify -a source-ip-address in the ping -a source-ip-address -vpn-instance vpn-instance-name destination-address command. Otherwise, the ping fails.

  5. Configure and apply a tunnel policy on PEs.

    # Configure the tunnel policy for binding primary tunnel and apply the tunnel policy to vpna.

    # Configure PE1.

    [PE1] tunnel-policy policy1
    [PE1-tunnel-policy-policy1] tunnel binding destination 2.2.2.2 te tunnel 0/0/2
    [PE1-tunnel-policy-policy1] quit
    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] ipv4-family
    [PE1-vpn-instance-vpna-af-ipv4] tnl-policy policy1
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit

    # Configure PE2.

    [PE2] tunnel-policy policy1
    [PE2-tunnel-policy-policy1] tunnel binding destination 1.1.1.1 te tunnel 0/0/2
    [PE2-tunnel-policy-policy1] quit
    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] ipv4-family
    [PE2-vpn-instance-vpna-af-ipv4] tnl-policy policy1
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit

    # Configure a tunnel type prioritizing policy and apply the policy to vpnb.

    # Configure PE1.

    [PE1] tunnel-policy policy2
    [PE1-tunnel-policy-policy2] tunnel select-seq cr-lsp lsp load-balance-number 2
    [PE1-tunnel-policy-policy2] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] ipv4-family
    [PE1-vpn-instance-vpnb-af-ipv4] tnl-policy policy2
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit

    # Configure PE2.

    [PE2] tunnel-policy policy2
    [PE2-tunnel-policy-policy2] tunnel select-seq cr-lsp lsp load-balance-number 2
    [PE2-tunnel-policy-policy2] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] ipv4-family
    [PE2-vpn-instance-vpnb-af-ipv4] tnl-policy policy2
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit

  6. Set up an MP-IBGP peer relationship between the PEs.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 2.2.2.2 as-number 100
    [PE1-bgp] peer 2.2.2.2 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 2.2.2.2 enable
    [PE1-bgp-af-vpnv4] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.1 as-number 100
    [PE2-bgp] peer 1.1.1.1 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.1 enable
    [PE2-bgp-af-vpnv4] quit

    # After the configuration is complete, run the display bgp peer or display bgp vpnv4 all peer command on the PEs. The command output shows that a BGP peer relationship is set up between PEs and the BGP peer relationship is in Established state.

  7. Set up EBGP peer relationships between PEs and CEs.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-af-vpna] peer 10.1.1.1 as-number 65410
    [PE1-bgp-af-vpna] quit
    [PE1-bgp] ipv4-family vpn-instance vpnb
    [PE1-bgp-af-vpnb] peer 10.2.1.1 as-number 65410
    [PE1-bgp-af-vpnb] quit
    [PE1-bgp] quit

    # Configure CE1.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure CE2.

    [CE2] bgp 65410
    [CE2-bgp] peer 10.2.1.2 as-number 100
    [CE2-bgp] import-route direct
    [CE2-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpna
    [PE2-bgp-af-vpna] peer 10.3.1.1 as-number 65420
    [PE2-bgp-af-vpna] quit
    [PE2-bgp] ipv4-family vpn-instance vpnb
    [PE2-bgp-af-vpnb] peer 10.4.1.1 as-number 65420
    [PE2-bgp-af-vpnb] quit
    [PE2-bgp] quit

    # Configure CE3.

    [CE3] bgp 65420
    [CE3-bgp] peer 10.3.1.2 as-number 100
    [CE3-bgp] import-route direct
    [CE3-bgp] quit

    # Configure CE4.

    [CE4] bgp 65420
    [CE4-bgp] peer 10.4.1.2 as-number 100
    [CE4-bgp] import-route direct
    [CE4-bgp] quit

  8. Verify the configuration.

    # Run the display bgp routing-table command on CEs, and you can find the routes to the remote CEs.

    # The information displayed on CE1 is used as an example.

    [CE1] display bgp routing-table
    
     BGP Local router ID is 3.3.3.3
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 5
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   3.3.3.3/32         0.0.0.0         0                     0      ?
     *>   5.5.5.5/32         10.1.1.2                              0      100 65420?
     *>   10.4.1.0/24        0.0.0.0         0                     0      ?
                             10.4.1.1        0                     0      100?
     *>   10.1.1.2/32        0.0.0.0         0                     0      ?
     *>   10.3.1.0/30        10.1.1.2                              0      100?
     *>   127.0.0.0          0.0.0.0         0                     0      ?
     *>   127.0.0.1/32       0.0.0.0         0                     0      ?
    

    # Run the display ip routing-table vpn-instance verbose command on PEs, and you can find the tunnels used by the VPN routes.

    # The information displayed on PE1 is used as an example.

    [PE1] display ip routing-table vpn-instance vpna 5.5.5.5 verbose
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
    Summary Count : 1
    
     Destination: 5.5.5.5/32
        Protocol: IBGP             Process ID: 0
      Preference: 255                    Cost: 0
         NextHop: 2.2.2.2           Neighbour: 2.2.2.2
           State: Active Adv Relied       Age: 00h00m08s
             Tag: 0                  Priority: low
           Label: 0x13                QoSInfo: 0x0
      IndirectID: 0xb9
    RelayNextHop: 0.0.0.0           Interface: Tunnel0/0/2
        TunnelID: 0x3d                  Flags: RD
    
    [PE1] display ip routing-table vpn-instance vpnb 6.6.6.6 verbose
    Route Flags: R - relay, D - download for forwarding
    ------------------------------------------------------------------------------
    Routing Table : vpnb
    Summary Count : 1
    
    Destination: 6.6.6.6/32
         Protocol: IBGP            Process ID: 0
       Preference: 255                   Cost: 0
          NextHop: 2.2.2.2          Neighbour: 2.2.2.2
            State: Active Adv Relied      Age: 00h04m37s
              Tag: 0                 Priority: low
            Label: 0x15               QoSInfo: 0x0
       IndirectID: 0xb8
     RelayNextHop: 0.0.0.0          Interface: Tunnel0/0/1
         TunnelID: 0x3b                 Flags: RD
     RelayNextHop: 0.0.0.0          Interface: LDP LSP
         TunnelID: 0x1c                 Flags: RD

    # CEs in the same VPN can ping each other, whereas CEs in different VPNs cannot.

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      tnl-policy policy1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      tnl-policy policy2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 1.1.1.1
    mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 100.1.1.1 255.255.255.252
     mpls
     mpls te
     mpls rsvp-te
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.252
    #
    interface GigabitEthernet3/0/0
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.252
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te tunnel-id 11
     mpls te commit
    #
    interface Tunnel0/0/2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te tunnel-id 22
     mpls te reserved-for-binding
     mpls te commit
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.2 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpna
      peer 10.1.1.1 as-number 65410
     #
     ipv4-family vpn-instance vpnb
      peer 10.2.1.1 as-number 65410
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      mpls-te enable
      network 100.1.1.0 0.0.0.3
      network 1.1.1.1 0.0.0.0
    #
    tunnel-policy  policy1
     tunnel binding destination 2.2.2.2 te Tunnel0/0/2
    #
    tunnel-policy  policy2
     tunnel select-seq cr-lsp lsp load-balance-number 2
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:3
      tnl-policy policy1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:4
      tnl-policy policy2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 2.2.2.2
    mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 100.1.1.2 255.255.255.252
     mpls
     mpls te
     mpls rsvp-te
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.252
    #
    interface GigabitEthernet3/0/0
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.252
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te tunnel-id 11
     mpls te commit
    #
    interface Tunnel0/0/2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te tunnel-id 22
     mpls te reserved-for-binding
     mpls te commit
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance vpna
      peer 10.3.1.1 as-number 65420
     #
     ipv4-family vpn-instance vpnb
      peer 10.4.1.1 as-number 65420
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      mpls-te enable
      network 100.1.1.0 0.0.0.3
      network 2.2.2.2 0.0.0.0
    #
    tunnel-policy  policy1
     tunnel binding destination 1.1.1.1 te Tunnel0/0/2
    #
    tunnel-policy  policy2
     tunnel select-seq cr-lsp lsp load-balance-number 2
    #
    return
  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.252
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.1 255.255.255.252
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 65410
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • CE3 configuration file

    #
     sysname CE3
    #
    interface GigabitEthernet1/0/0
     ip address 10.3.1.1 255.255.255.252
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
    #
    bgp 65420
     peer 10.3.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.3.1.2 enable
    #
    return
  • CE4 configuration file

    #
     sysname CE4
    #
    interface GigabitEthernet1/0/0
     ip address 10.4.1.1 255.255.255.252
    #
    interface LoopBack1
     ip address 6.6.6.6 255.255.255.255
    #
    bgp 65420
     peer 10.4.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.4.1.2 enable
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 153557

Downloads: 372

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next