No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Local CCC Connection

Example for Configuring a Local CCC Connection

Networking Requirements

As shown in Figure 10-19, sites of an enterprise at different geographical locations connect to a PE on the ISP network through CE1 and CE2. To simplify configuration, the enterprise hopes that the two CEs communicate with each other like on a LAN. That is, data packets of each CE traverse the ISP network without being modified by the PE. The enterprise will not increase sites in the future and wants to use exclusive VPN resources on the ISP network to protect data security.

To meet requirements of the enterprise, create a local CCC connection to enable CE1 and CE2 to exchange Layer 2 information directly.

Figure 10-19  Local CCC connection

Configuration Roadmap

The enterprise hopes that the two CEs communicate with each other like on a LAN. This requirement can be satisfied by a VLL solution. Because the enterprise will not increase sites in the future and the two CE1 connected to the same PE, a local CCC connection can be set up between the CEs to meet the customer requirements.

The configuration roadmap is as follows:

  1. Configure the basic MPLS capabilities on the PE and enable the MPLS L2VPN. Enabling MPLS L2VPN is the prerequisite for VLL configuration.

  2. Create a local connection between CE1 and CE2 on PE. The local CCC connection is bidirectional, so only one connection is required.

Procedure

  1. Configure the CEs.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] ip address 100.1.1.1 24
    [CE1-GigabitEthernet1/0/0] quit

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] ip address 100.1.1.2 24
    [CE2-GigabitEthernet1/0/0] quit

  2. Configure PE.

    # Configure the LSR ID and enable MPLS and MPLS L2VPN.

    <Huawei> system-view
    [Huawei] sysname PE
    [PE] interface loopback 1
    [PE-LoopBack1] ip address 1.1.1.9 32
    [PE-LoopBack1] quit
    [PE] mpls lsr-id 1.1.1.9
    [PE] mpls
    [PE-mpls] quit
    [PE] mpls l2vpn
    [PE-l2vpn] quit

    # Create a local connection between CE1 and CE2.

    [PE] ccc ce1-ce2 interface gigabitethernet 1/0/0 out-interface gigabitethernet 2/0/0

  3. Verify the configuration.

    # After completing the configuration, check the CCC information on the PE. The command output shows that a local CCC connection has been set up and the status is Up.

    [PE] display vll ccc
    total  ccc vc : 1
    local  ccc vc : 1,  1 up
    remote ccc vc : 0,  0 up
    
    name: ce1-ce2, type: local, state: up,
    intf1: GigabitEthernet1/0/0 (up),access-port: false
    
    intf2: GigabitEthernet2/0/0 (up),access-port: false
    VC last up time : 2010/07/24 12:31:31
    VC total up time: 0 days, 2 hours, 12 minutes, 51 seconds
    

    # Run the display l2vpn ccc-interface vc-type all command. The command output shows that the VC type is ccc and the VC status is Up.

    [PE] display l2vpn ccc-interface vc-type all
    Total ccc-interface of CCC : 2
    up (2), down (0)
    Interface                     Encap Type               State     VC Type
    GigabitEthernet1/0/0          ethernet                 up        ccc
    GigabitEthernet2/0/0          ethernet                 up        ccc
    

    # CE1 and CE2 can ping each other.

    [CE1] ping 100.1.1.2
      PING 100.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 100.1.1.2: bytes=56 Sequence=1 ttl=255 time=180 ms
        Reply from 100.1.1.2: bytes=56 Sequence=2 ttl=255 time=60 ms
        Reply from 100.1.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms
        Reply from 100.1.1.2: bytes=56 Sequence=4 ttl=255 time=70 ms
        Reply from 100.1.1.2: bytes=56 Sequence=5 ttl=255 time=60 ms
    
      --- 100.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/76/180 ms

Configuration Files

  • Configuration file of CE1

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
     ip address 100.1.1.1 255.255.255.0
    #
    return
  • Configuration file of PE

    #
     sysname PE
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls l2vpn
    #
    ccc ce1-ce2 interface GigabitEthernet1/0/0 out-interface GigabitEthernet2/0/0
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    return
  • Configuration file of CE2

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
     ip address 100.1.1.2 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 150701

Downloads: 365

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next