No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - VPN

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes VPN features on the device and provides configuration procedures and configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AS VPN Option C (Solution 1)

Example for Configuring Inter-AS VPN Option C (Solution 1)

Networking Requirements

The headquarters and branches of a company connect to networks of different carriers. To enable the headquarters and branches to communicate, Inter-AS BGP/MPLS IP VPN needs to be implemented. As shown in Figure 7-48, CE1 is located in the headquarters and connects to PE1 in AS 100. CE2 is located at the branch and connects to PE2 in AS 200. Both CE1 and CE2 belong to vpn1.

Figure 7-48  Networking diagram for configuring inter-AS VPN Option C

Configuration Roadmap

Inter-AS Option C can be deployed to meet the company's requirement. The configuration roadmap is as follows:

  1. On the MPLS backbone network in AS 100 and AS 200, configure an IGP protocol to enable the PE and ASBR-PEs to communicate with each other.
  2. Configure basic MPLS capabilities and MPLS LDP on the MPLS backbone network to set up LDP LSPs.
  3. Set up an MP-IBGP peer relationship between the PE and ASBR-PEs in each AS to exchange the labeled IPv4 routes.
  4. Create a VPN instance on the PE in each AS and bind the VPN instance to the interface connected to the CE.
  5. Set up an EBGP peer relationship between the PEs and CEs in each AS to exchange VPN routing information.
  6. Enable the capability of exchanging labeled IPv4 routes between the local ASBR-PE and the remote ASBR-PE.
  7. Set up an MP-EBGP relationship between PEs in different ASs and set the maximum hops between the PEs.
  8. Configure a routing policy on the ASBR-PE: Assign MPLS labels to the routes advertised to the emote ASBR-PE; assign new MPLS labels to the labeled IPv4 routes advertised to the PE in the local AS.

Procedure

  1. Assign IP addresses to interfaces according to Figure 7-48.

    # Configure PE1. The configuration on PE2, CE1, CE2, ASBR-PE1, and ASBR-PE2 is similar to the configuration on PE1 and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] ip address 172.1.1.2 24
    [PE1-GigabitEthernet1/0/0] quit
    

  2. On the MPLS backbone network in AS 100 and AS 200, configure OSPF to enable the PEs and the ASBR-PEs to communicate with each other.

    # Configure PE1. The configuration on PE2 and ASBR-PEs is similar to the configuration on PE1 and is not mentioned here.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    
    NOTE:

    The 32-bit loopback interface address used as LSR ID should be advertised by the PEs and ASBR-PEs using OSPF.

    After the configuration is complete, the ASBR and PEs in the same AS can set up an OSPF neighbor relationship. Run the display ospf peer command to verify that the status of the neighbor relationship is Full. Run the display ip routing-table command. The command output shows that the ASBR and PEs in the same AS have learned the routes to Loopback1 of each other.

  3. Configure basic MPLS capabilities and MPLS LDP on the MPLS backbone network of AS 100 and AS 200 to set up LDP LSPs.

    # Configure basic MPLS capabilities on PE1 and enable LDP on the interface connected to ASBR-PE1.

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] mpls
    [PE1-GigabitEthernet1/0/0] mpls ldp
    [PE1-GigabitEthernet1/0/0] quit
    

    # Configure basic MPLS capabilities on ASBR-PE1 and enable LDP on the interface connected to PE1.

    [ASBR-PE1] mpls lsr-id 2.2.2.9
    [ASBR-PE1] mpls
    [ASBR-PE1-mpls] quit
    [ASBR-PE1] mpls ldp
    [ASBR-PE1-mpls-ldp] quit
    [ASBR-PE1] interface gigabitethernet 1/0/0
    [ASBR-PE1-GigabitEthernet1/0/0] mpls
    [ASBR-PE1-GigabitEthernet1/0/0] mpls ldp
    [ASBR-PE1-GigabitEthernet1/0/0] quit
    

    # Configure basic MPLS capabilities on ASBR-PE2 and enable LDP on the interface connected to PE2.

    [ASBR-PE2] mpls lsr-id 3.3.3.9
    [ASBR-PE2] mpls
    [ASBR-PE2-mpls] quit
    [ASBR-PE2] mpls ldp
    [ASBR-PE2-mpls-ldp] quit
    [ASBR-PE2] interface gigabitethernet 1/0/0
    [ASBR-PE2-GigabitEthernet1/0/0] mpls
    [ASBR-PE2-GigabitEthernet1/0/0] mpls ldp
    [ASBR-PE2-GigabitEthernet1/0/0] quit
    

    # Configure basic MPLS capabilities on PE2 and enable LDP on the interface connected to ASBR-PE2.

    [PE2] mpls lsr-id 4.4.4.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] mpls
    [PE2-GigabitEthernet1/0/0] mpls ldp
    [PE2-GigabitEthernet1/0/0] quit
    

    After the configuration is complete, the PE and ASBR-PEs in the same AS can set up an LDP peer relationship. Run the display mpls ldp session command on the PE and ASBR-PEs to verify that the state is Operational.

    The information displayed on PE1 is used as an example.

    [PE1] display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.9:0          Operational DU   Active   0002:23:46  17225/17224
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    

  4. Set up an MP-IBGP peer relationship between the PE and ASBR-PEs.

    # On PE1: set up an MP-IBGP peer relationship with ASBR-PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.

    [PE1] bgp 100
    [PE1-bgp] peer 2.2.2.9 as-number 100
    [PE1-bgp] peer 2.2.2.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 2.2.2.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit
    

    # On ASBR-PE1: set up an MP-IBGP peer relationship with PE1. The configuration on ASBR-PE2 is similar to the configuration on ASBR-PE1 and is not mentioned here.

    [ASBR-PE1] bgp 100
    [ASBR-PE1-bgp] peer 1.1.1.9 as-number 100
    [ASBR-PE1-bgp] peer 1.1.1.9 connect-interface loopback 1
    [ASBR-PE1-bgp] ipv4-family vpnv4
    [ASBR-PE1-bgp-af-vpnv4] peer 1.1.1.9 enable
    [ASBR-PE1-bgp-af-vpnv4] quit
    [ASBR-PE1-bgp] quit
    

  5. On the PEs, create a VPN instance, enable the IPv4 address family in the instance, and bind the instance to the interfaces connected to CEs.

    NOTE:

    The VPN targets of the VPN instances on the ASBR-PE and PEs in an AS must match. In different ASs, the VPN targets of the PEs do not need to match.

    # Configure PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.
    [PE1] ip vpn-instance vpn1
    [PE1-vpn-instance-vpn1] ipv4-family
    [PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [PE1-vpn-instance-vpn1-af-ipv4] quit
    [PE1-vpn-instance-vpn1] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] ip binding vpn-instance vpn1
    [PE1-GigabitEthernet2/0/0] ip address 10.1.1.2 24
    [PE1-GigabitEthernet2/0/0] quit
    

  6. Set up EBGP peer relationships between the PEs and CEs to exchange VPN routing information.

    # Configure CE1. The configuration on CE2 is similar to the configuration on CE1 and is not mentioned here.

    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] bgp 65001
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpn1
    [PE1-bgp-vpn1] peer 10.1.1.1 as-number 65001
    [PE1-bgp-vpn1] import-route direct
    [PE1-bgp-vpn1] quit
    [PE1-bgp] quit

    After the configuration is complete, run the display bgp vpnv4 vpn-instance vpn-instancename peer command on the PEs. The command output shows that the BGP peer relationships have been set up between the PEs and CEs and are in Established state. Run the display bgp vpnv4 all peer command on the PEs. The command output shows that each PE has set up a BGP peer relationship with the CE and ASBR-PEs in the same AS, and the BGP peer relationships are in Established state.

    The information displayed on PE1 is used as an example.

    [PE1] display bgp vpnv4 vpn-instance vpn1 peer
                                                                                    
     BGP local router ID : 1.1.1.9                                                  
     Local AS number : 100                                                          
                                                                                    
     VPN-Instance vpn1, Router ID 1.1.1.9:                                          
     Total number of peers : 1                Peers in established state : 1        
                                                                                    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
                                                                                    
      10.1.1.1        4       65001     1043     1048     0 17:17:21 Established       2
    [PE1] display bgp vpnv4 all peer
                                                                                    
     BGP local router ID : 1.1.1.9                                                  
     Local AS number : 100                                                          
     Total number of peers : 2                Peers in established state : 2        
                                                                                    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
                                                                                    
      2.2.2.9         4         100       59       52     0 00:45:16 Established       0
                                                                                    
      Peer of IPv4-family for vpn instance :                                        
                                                                                    
     VPN-Instance vpn1, Router ID 1.1.1.9:                                          
      10.1.1.1        4       65001     1045     1050     0 17:19:21 Established       2

  7. Enable the capability of exchanging labeled IPv4 routes.

    # On PE1: Enable the capability of exchanging labeled IPv4 routes with ASBR-PE1. The configuration on PE2 is similar to the configuration on PE1 and is not mentioned here.

    [PE1] bgp 100
    [PE1-bgp] peer 2.2.2.9 label-route-capability
    [PE1-bgp] quit

    # On ASBR-PE1: Enable MPLS on the interface connected to ASBR-PE2. The configuration on ASBR-PE2 is similar to the configuration on ASBR-PE1 and is not mentioned here.

    [ASBR-PE1] interface gigabitethernet 2/0/0
    [ASBR-PE1-GigabitEthernet2/0/0] ip address 192.1.1.1 24
    [ASBR-PE1-GigabitEthernet2/0/0] mpls
    [ASBR-PE1-GigabitEthernet2/0/0] quit

    # On ASBR-PE1: Create a routing policy. The configuration on ASBR-PE2 is similar to the configuration on ASBR-PE1 and is not mentioned here.

    [ASBR-PE1] route-policy policy1 permit node 1
    [ASBR-PE1-route-policy] apply mpls-label
    [ASBR-PE1-route-policy] quit
    [ASBR-PE1] route-policy policy2 permit node 1
    [ASBR-PE1-route-policy] if-match mpls-label
    [ASBR-PE1-route-policy] apply mpls-label
    [ASBR-PE1-route-policy] quit

    # On ASBR-PE1: Apply a routing policy to the routes advertised to PE1, and enable the capability of exchanging labeled IPv4 routes with PE1. The configuration on ASBR-PE2 is similar to the configuration on ASBR-PE1 and is not mentioned here.

    [ASBR-PE1] bgp 100
    [ASBR-PE1-bgp] peer 1.1.1.9 route-policy policy2 export
    [ASBR-PE1-bgp] peer 1.1.1.9 label-route-capability

    # On ASBR-PE1: Apply a routing policy to the routes advertised to ASBR-PE2, and enable the capability of exchanging labeled IPv4 routes with ASBR-PE2.

    [ASBR-PE1-bgp] peer 192.1.1.2 as-number 200
    [ASBR-PE1-bgp] peer 192.1.1.2 route-policy policy1 export
    [ASBR-PE1-bgp] peer 192.1.1.2 label-route-capability
    [ASBR-PE1-bgp] quit

    # On ASBR-PE1: Advertise routes to loopback interfaces to ASBR-PE2, and then to PE2. The configuration on ASBR-PE2 is similar to the configuration on ASBR-PE1 and is not mentioned here.

    [ASBR-PE1] bgp 100
    [ASBR-PE1-bgp] network 1.1.1.9 32
    [ASBR-PE1-bgp] quit

  8. Set up an MP-EBGP peer relationship between PE1 and PE2.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 4.4.4.9 as-number 200
    [PE1-bgp] peer 4.4.4.9 connect-interface LoopBack 1
    [PE1-bgp] peer 4.4.4.9 ebgp-max-hop 10
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 4.4.4.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 200
    [PE2-bgp] peer 1.1.1.9 as-number 100
    [PE2-bgp] peer 1.1.1.9 connect-interface LoopBack 1
    [PE2-bgp] peer 1.1.1.9 ebgp-max-hop 10
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

  9. Verify the configuration.

    # After the configuration is complete, CE1 and CE2 learn routes to interfaces on each other and can ping each other successfully.

    # The information displayed on CE1 is used as an example.

    [CE1] display ip routing-table
    Route Flags:
    R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8         Routes : 8
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
           10.1.1.0/24  Direct 0    0             D  10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct 0    0             D  127.0.0.1       GigabitEthernet1/0/0
           10.2.1.0/24  EBGP   255  0             D  10.1.1.2        GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    
    
    [CE1] ping 10.2.1.1
      PING 10.2.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.2.1.1: bytes=56 Sequence=1 ttl=251 time=119 ms
        Reply from 10.2.1.1: bytes=56 Sequence=2 ttl=251 time=141 ms
        Reply from 10.2.1.1: bytes=56 Sequence=3 ttl=251 time=136 ms
        Reply from 10.2.1.1: bytes=56 Sequence=4 ttl=251 time=113 ms
        Reply from 10.2.1.1: bytes=56 Sequence=5 ttl=251 time=78 ms
      --- 10.2.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 78/117/141 ms

    # No VPNv4 route exists on ASBR-PEs. Run the display bgp routing-table label command on an ASBR-PE to check information about labels of routes.

    # ASBR-PE1 is used as an example.

    [ASBR-PE1] display bgp routing-table label
                                                                                    
     BGP Local router ID is 2.2.2.9                                                 
     Status codes: * - valid, > - best, d - damped,                                 
                   h - history,  i - internal, s - suppressed, S - Stale            
                   Origin : i - IGP, e - EGP, ? - incomplete                        
                                                                                    
                                                                                    
     Total Number of Routes: 2                                                      
                                                                                    
                                                                                    
            Network           NextHop           In/Out Label                        
                                                                                    
     *>     1.1.1.9           172.1.1.2         1098/NULL                           
     *>     4.4.4.9           192.1.1.2         1099/1067                           

Configuration Files

  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    bgp 65001
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #
    ip vpn-instance vpn1
     ipv4-family 
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 1.1.1.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip binding vpn-instance vpn1
     ip address 10.1.1.2 255.255.255.0
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     peer 4.4.4.9 as-number 200
     peer 4.4.4.9 ebgp-max-hop 10
     peer 4.4.4.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
      peer 2.2.2.9 label-route-capability
      peer 4.4.4.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
      peer 4.4.4.9 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.1.1.1 as-number 65001
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • ASBR-PE1 configuration file

    #
     sysname ASBR-PE1
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 192.1.1.1 255.255.255.0
     mpls
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 100
     peer 192.1.1.2 as-number 200
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      network 1.1.1.9 255.255.255.255
      peer 192.1.1.2 enable
      peer 192.1.1.2 route-policy policy1 export
      peer 192.1.1.2 label-route-capability
      peer 1.1.1.9 enable
      peer 1.1.1.9 route-policy policy2 export
      peer 1.1.1.9 label-route-capability
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     apply mpls-label
    route-policy policy2 permit node 1
     if-match mpls-label
     apply mpls-label
    #
    return
  • ASBR-PE2 configuration file

    #
     sysname ASBR-PE2
    #
     mpls lsr-id 3.3.3.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 162.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 192.1.1.2 255.255.255.0
     mpls
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    bgp 200
     peer 192.1.1.1 as-number 100
     peer 4.4.4.9 as-number 200
     peer 4.4.4.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      network 4.4.4.9 255.255.255.255
      peer 192.1.1.1 enable
      peer 192.1.1.1 route-policy policy1 export
      peer 192.1.1.1 label-route-capability
      peer 4.4.4.9 enable
      peer 4.4.4.9 route-policy policy2 export
      peer 4.4.4.9 label-route-capability
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 4.4.4.9 enable
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 162.1.1.0 0.0.0.255
    #
    route-policy policy1 permit node 1
     apply mpls-label
    route-policy policy2 permit node 1
     if-match mpls-label
     apply mpls-label
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 200:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 4.4.4.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 162.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip binding vpn-instance vpn1
     ip address 10.2.1.2 255.255.255.0
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    bgp 200
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 ebgp-max-hop 10
     peer 1.1.1.9 connect-interface LoopBack1
     peer 3.3.3.9 as-number 200
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
      peer 3.3.3.9 enable
      peer 3.3.3.9 label-route-capability
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.2.1.1 as-number 65002
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 162.1.1.0 0.0.0.255
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    bgp 65002
     peer 10.2.1.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033725

Views: 143531

Downloads: 361

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next