No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - WLAN-AC

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides the concepts, configuration procedures, and configuration examples of WLAN-AC features.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intra-AC Roaming

Example for Configuring Intra-AC Roaming

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, and WDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

A small enterprise needs to provide WLAN services for employees. Since the WLAN needs to cover only a small area, one AC is deployed to manage APs. To differentiate department management, employees are assigned different subnets by department. The enterprise expects that users can move within the enterprise with nonstop service transmission.

As shown in Figure 6-6, an AC provides services for enterprise employees. It connects to AP_1 and AP_2 respectively.

Figure 6-6  Configuring intra-AC roaming

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure parameters used for communication between the AC and APs to transmit CAPWAP packets.
  2. Configure the AC to function as a DHCP server to assign IP addresses to the STAs and APs.
  3. Configure basic WLAN services so that users can connect to the wireless network.

Data planning

Item

Data

DHCP server

The AC functions as a DHCP server to assign IP addresses to the STAs and APs.

IP address pool for the APs

10.10.10.2-10.10.10.254/24

IP address pool for the STAs

10.10.11.2–10.10.11.254/24

10.10.12.2–10.10.12.254/24

AC's source interface address

VLANIF 100: 10.10.10.1/24

AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap1 and regulatory domain profile domain
  • Name: ap-group2
  • Referenced profile: VAP profile wlan-vap2 and regulatory domain profile domain
Regulatory domain profile
  • Name: domain
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap1
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security
  • Name: wlan-vap2
  • Service VLAN: VLAN 102
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
  • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
  • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
  • The management VLAN and service VLAN cannot be configured the same.
  • When multiple VAP profiles are configured and share one service VLAN, enable inter-service VLAN proxy ARP if the data forwarding mode is set to tunnel.

Procedure

  1. Configure the APs to communicate with the AC.

    # Add Eth2/0/0 and Eth2/0/1 to management VLAN 100, service VLAN 101 and service VLAN 102.

    NOTE:

    You are advised to configure port isolation on Eth2/0/0 and Eth2/0/1 that connect the AC to the APs. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    <Huawei> system-view
    [Huawei] sysname AC
    [AC] vlan batch 100 to 102
    [AC] interface ethernet 2/0/0
    [AC-Ethernet2/0/0] port link-type trunk
    [AC-Ethernet2/0/0] port trunk pvid vlan 100
    [AC-Ethernet2/0/0] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/0] port-isolate enable
    [AC-Ethernet2/0/0] quit
    [AC] interface ethernet 2/0/1
    [AC-Ethernet2/0/1] port link-type trunk
    [AC-Ethernet2/0/1] port trunk pvid vlan 100
    [AC-Ethernet2/0/1] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/1] port-isolate enable
    [AC-Ethernet2/0/1] quit
    

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.10.10.1 255.255.255.0
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.10.11.1 255.255.255.0
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.10.12.1 255.255.255.0
    [AC-Vlanif102] dhcp select interface
    [AC-Vlanif102] quit
    

  3. Configure the APs to go online.

    # Create AP groups ap-group1 and ap-group2.

    [AC] wlan ac
    [AC-wlan-view] ap-group name ap-group1
    Info: This operation may take a few seconds. Please wait for a moment.done.
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    Info: This operation may take a few seconds. Please wait for a moment.done.
    [AC-wlan-ap-group-ap-group2] quit

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP groups.

    [AC-wlan-view] regulatory-domain-profile name domain
    [AC-wlan-regulate-domain-domain] country-code cn
    Info: The current country code is same with the input country code.
    [AC-wlan-regulate-domain-domain] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    [AC-wlan-ap-group-ap-group2] regulatory-domain-profile domain
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group2] quit
    [AC-wlan-view] quit

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    # Import APs offline on the AC and add AP_1 to AP group ap-group1 and AP_2 to AP group ap-group2. Assume that the type of AP_1 and AP_2 is AP6010DN-AGN and their MAC addresses are 60de-4476-e360 and dcd2-fc04-b500 respectively.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    [AC] wlan ac
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name ap1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac dcd2-fc04-b500
    [AC-wlan-ap-1] ap-name ap2
    [AC-wlan-ap-1] ap-group ap-group2
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-1] quit

    # After the APs are powered on, run the display ap all command to check the AP state. If the State field displays nor, the APs have gone online.

    [AC-wlan-view] display ap all
    Info: This operation may take a few seconds. Please wait for a moment.done.
    Total AP information:
    nor  : normal          [2]
    -------------------------------------------------------------------------------------------
    ID   MAC            Name Group     IP           Type            State STA Uptime
    -------------------------------------------------------------------------------------------
    0    60de-4476-e360 ap1  ap-group1 10.10.10.253 AP6010DN-AGN    nor   0   28S
    1    dcd2-fc04-b500 ap2  ap-group2 10.10.10.254 AP6010DN-AGN    nor   0   11S
    -------------------------------------------------------------------------------------------
    Total: 2

  4. Configure basic WLAN services on the AC.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profiles wlan-vap1 and wlan-vap2, set the service VLANs, and apply the security profile wlan-security and SSID profile wlan-ssid to the VAP profiles.

    [AC-wlan-view] vap-profile name wlan-vap1
    [AC-wlan-vap-prof-wlan-vap1] service-vlan vlan-id 101
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-wlan-vap1] security-profile wlan-security
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap1] ssid-profile wlan-ssid
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap1] quit
    [AC-wlan-view] vap-profile name wlan-vap2
    [AC-wlan-vap-prof-wlan-vap2] service-vlan vlan-id 102
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-wlan-vap2] security-profile wlan-security
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap2] ssid-profile wlan-ssid
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap2] quit
    

    # Bind VAP profile wlan-vap1 to AP group ap-group1, and VAP profile wlan-vap2 to AP group ap-group2, and apply the VAP profiles to radio 0 and radio 1 of the APs.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap1 wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    [AC-wlan-ap-group-ap-group2] vap-profile wlan-vap2 wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-ap-group2] quit
    

    # Commit the configuration.

    [AC-wlan-view] commit all                                                
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y      

  5. Verify the configuration.

    # The AC automatically delivers WLAN service configuration to the APs. After the service configuration is complete, run the display vap ssid wlan-net command to check VAP information. If Status in the command output is displayed as ON, the VAPs have been successfully created on AP radios.
    [AC-wlan-view] display vap ssid wlan-net
    Info: This operation may take a few seconds, please wait.
    WID : WLAN ID            
    --------------------------------------------------------------------------
    AP ID AP name RfID WID  BSSID          Status  Auth type  STA   SSID    
    --------------------------------------------------------------------------
    0     ap1     0    1    60DE-4476-E360 ON      WPA2-PSK   0     wlan-net
    0     ap1     1    1    60DE-4476-E370 ON      WPA2-PSK   0     wlan-net
    1     ap2     0    1    DCD2-FC04-B500 ON      WPA2-PSK   0     wlan-net
    1     ap2     1    1    DCD2-FC04-B510 ON      WPA2-PSK   0     wlan-net
    --------------------------------------------------------------------------
    Total: 4
    # In the coverage area of AP_1, connect the STA to the wireless network with SSID wlan-net and enter the password a1234567. After the STA successfully associates with the network, run the display station ssid wlan-net command on the AC. The command output shows that the STA with MAC address cc3a-61cf-6344 has associated with AP_1.
    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   0     ap1      0/1      2.4G  -     -/-        -     101   10.10.11.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0
    # When the STA moves from the coverage area of AP_1 to that of AP_2, run the display station ssid wlan-net command on AC. The command output shows that the STA has associated with AP_2.
    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   1     ap2      0/1      2.4G  11n   59/45      -32   102   10.10.12.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0
    # Run the display station roam-track sta-mac cc3a-61cf-6344 command on AC to check the STA roaming track.
    [AC-wlan-view] display station roam-track sta-mac cc3a-61cf-6344
    Access SSID:wlan-net
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ------------------------------------------------------------------------------
    L2/L3           AC IP                  AP name              Radio ID
    BSSID           TIME                   In/Out RSSI          Out Rx/Tx
    ------------------------------------------------------------------------------
    --              10.10.10.1            ap1                  1
    60de-4476-e360  2015/02/07 17:48:30    -57/-58              46/65
    L3              10.10.10.1            ap2                  1
    dcd2-fc04-b500  2015/02/07 17:54:50    -58/-                -/-
    ------------------------------------------------------------------------------
    Number: 1

Configuration Files

  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #                                                                               
    interface Vlanif100                                                              
     ip address 10.10.10.1 255.255.255.0
     dhcp select interface                                           
    #                                                                               
    interface Vlanif101                                                             
     ip address 10.10.11.1 255.255.255.0
     dhcp select interface       
    #                                                                               
    interface Vlanif102                                                             
     ip address 10.10.12.1 255.255.255.0
     dhcp select interface                                               
    #                                                                               
    interface Ethernet2/0/0                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #                                                                               
    interface Ethernet2/0/1                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #
    capwap source interface vlanif100
    #
    wlan ac
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#]:krYrz_r<ee}|Cq@9V(W{ZD$"\-R-HD_y.4#U4,%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap1
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     vap-profile name wlan-vap2
      service-vlan vlan-id 102
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain
     ap-group name ap-group1
      regulatory-domain-profile domain
      radio 0
       vap-profile wlan-vap1 wlan 1
      radio 1
       vap-profile wlan-vap1 wlan 1
      radio 2
       vap-profile wlan-vap1 wlan 1
     ap-group name ap-group2
      regulatory-domain-profile domain
      radio 0
       vap-profile wlan-vap2 wlan 1
      radio 1
       vap-profile wlan-vap2 wlan 1
      radio 2
       vap-profile wlan-vap2 wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name ap1
      ap-group ap-group1
     ap-id 1 type-id 19 ap-mac dcd2-fc04-b500 ap-sn 210235554710CB000078
      ap-name ap2
      ap-group ap-group2
    #
    return
Translation
Download
Updated: 2019-08-07

Document ID: EDOC1100033726

Views: 36421

Downloads: 220

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next