No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - WLAN-AC

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides the concepts, configuration procedures, and configuration examples of WLAN-AC features.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Dynamic Load Balancing

Example for Configuring Dynamic Load Balancing

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, and WDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 5-11, the AC connects to the upper layer network and manages the APs through the access and aggregation switches.

When a large number of STAs access the Internet through the same AP, the AP is heavily loaded, lowering user experience. The enterprise requires that data traffic be balanced on AP radios to prevent one AP radio from being heavily loaded.

Figure 5-11  Networking diagram for configuring dynamic load balancing

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the APs, AC, and upper-layer devices to communicate with each other.
  2. Configure the AC as a DHCP server to assign IP addresses to the APs and STAs.
  3. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  4. Configure WLAN service parameters for STAs to access the WLAN.
  5. Configure dynamic load balancing to prevent one AP from being heavily loaded.
Table 5-5  Data required for completing the configuration

Item

Data

DHCP server The AC functions as the DHCP server to assign IP addresses to the APs and STAs.
IP address pool for the APs 10.10.10.2-10.10.10.254/24
IP address pool for the STAs

10.10.11.2–10.10.11.254/24

10.10.12.2–10.10.12.254/24

IP address of the AC's source interface VLANIF 100: 10.10.10.1/24
AP group

Name: guest

Referenced profile: VAP profile guest and regulatory domain profile domain1

Name: employee

Referenced profile: VAP profile employee and regulatory domain profile domain1

Regulatory domain profile

Name: domain1

Country code: CN

SSID profile

Name: guest

SSID name: guest

Name: employee

SSID name: employee

Security profile

Name: guest

  • Security policy: WEP-40
  • Password: a1234

Name: employee

  • Security policy: WPA2+PSK+AES
  • Password: b1234567
VAP profile

Name: guest

  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile guest and security profile guest

Name: employee

  • Service VLAN: VLAN 102
  • Referenced profile: SSID profile employee and security profile employee
5G radio profile
  • Name: radio5g
  • Referenced profile: RRM profile loadbalance-dynamic
2G radio profile
  • Name: radio2g
  • Referenced profile: RRM profile loadbalance-dynamic
RRM profile
  • Name: loadbalance-dynamic
  • Start threshold for dynamic load balancing: 15
  • Load difference threshold for dynamic load balancing: 25%

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
  • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
  • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
  • The management VLAN and service VLAN cannot be configured the same.
  • When multiple VAP profiles are configured and share one service VLAN, enable inter-service VLAN proxy ARP if the data forwarding mode is set to tunnel.

Procedure

  1. Configure the APs to communicate with the AC.

    # Add Eth2/0/0 and Eth2/0/1 to management VLAN 100, service VLAN 101 and service VLAN 102.

    NOTE:

    You are advised to configure port isolation on Eth2/0/0 and Eth2/0/1 that connect the AC to the APs. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    <Huawei> system-view
    [Huawei] sysname AC
    [AC] vlan batch 100 to 102
    [AC] interface ethernet 2/0/0
    [AC-Ethernet2/0/0] port link-type trunk
    [AC-Ethernet2/0/0] port trunk pvid vlan 100
    [AC-Ethernet2/0/0] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/0] port-isolate enable
    [AC-Ethernet2/0/0] quit
    [AC] interface ethernet 2/0/1
    [AC-Ethernet2/0/1] port link-type trunk
    [AC-Ethernet2/0/1] port trunk pvid vlan 100
    [AC-Ethernet2/0/1] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/1] port-isolate enable
    [AC-Ethernet2/0/1] quit
    

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.10.10.1 255.255.255.0
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.10.11.1 255.255.255.0
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.10.12.1 255.255.255.0
    [AC-Vlanif102] dhcp select interface
    [AC-Vlanif102] quit
    

  3. Configure the APs to go online.

    # Create AP groups guest and employee.

    [AC] wlan ac
    [AC-wlan-view] ap-group name guest
    Info: This operation may take a few seconds. Please wait for a moment..done.
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    Info: This operation may take a few seconds. Please wait for a moment..done.
    [AC-wlan-ap-group-employee] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP groups.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    Info: The current country code is same with the input country code.
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-employee] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the APs offline on the AC. Add APs deployed in the lobby to AP group guest and APs in office areas to AP group employee. Configure names for the APs based on the APs' deployment locations, so that you can know where the APs are deployed from their names. For example, if the AP with MAC address 60de-4476-e360 is deployed in room 1 of the office building, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    [AC] wlan ac
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group guest
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group employee
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-1] quit
    

    # After the APs are powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the APs have gone online.

    [AC-wlan-view] display ap all
    Info: This operation may take a few seconds. Please wait for a moment.done.
    Total AP information:
    nor  : normal          [2]
    --------------------------------------------------------------------------------------------
    ID   MAC            Name   Group    IP           Type            State STA Uptime
    --------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 guest    10.10.10.253 AP6010DN-AGN    nor   0   1M:22S
    1    60de-4474-9640 area_2 employee 10.10.10.254 AP6010DN-AGN    nor   0   5S
    --------------------------------------------------------------------------------------------
    Total: 2

  4. Configure WLAN service parameters.

    # Create security profiles guest and employee and configure the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WEP-40 and WPA2+PSK+AES and passwords to a1234 and b1234567, respectively. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name guest
    [AC-wlan-sec-prof-guest] security wep share-key
    [AC-wlan-sec-prof-guest] wep key 0 wep-40 pass-phrase a1234
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-sec-prof-guest]wep default-key 0
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-sec-prof-guest] quit
    [AC-wlan-view] security-profile name employee
    [AC-wlan-sec-prof-employee] security wpa2 psk pass-phrase b1234567 aes
    [AC-wlan-sec-prof-employee] quit
    

    # Create SSID profiles guest and employee, and set the SSID names to guest and employee, respectively.

    [AC-wlan-view] ssid-profile name guest
    [AC-wlan-ssid-prof-guest] ssid guest
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-guest] quit
    [AC-wlan-view] ssid-profile name employee
    [AC-wlan-ssid-prof-employee] ssid employee
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-employee] quit
    

    # Create VAP profiles guest and employee, set the service VLANs, and apply the security profiles and SSID profiles to the VAP profiles.

    [AC-wlan-view] vap-profile name guest
    [AC-wlan-vap-prof-guest] service-vlan vlan-id 101
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-guest] security-profile guest
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-guest] ssid-profile guest
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-guest] quit
    [AC-wlan-view] vap-profile name employee
    [AC-wlan-vap-prof-employee] service-vlan vlan-id 102
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-employee] security-profile employee
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-employee] ssid-profile employee
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-employee] quit
    

    # Bind VAP profiles to the AP groups and apply the VAP profiles to radio of the APs.

    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] vap-profile guest wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] vap-profile employee wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-employee] quit
    

  5. Configure dynamic load balancing.

    # Create the RRM profile loadbalance-dynamic, and enable dynamic load balancing in the RRM profile loadbalance-dynamic and set the start threshold for dynamic load balancing to 15 and load difference threshold to 25%.

    [AC-wlan-view] rrm-profile name loadbalance-dynamic
    [AC-wlan-rrm-prof-loadbalance-dynamic] sta-load-balance dynamic enable 
    [AC-wlan-rrm-prof-loadbalance-dynamic] sta-load-balance dynamic start-threshold 15 
    [AC-wlan-rrm-prof-loadbalance-dynamic] sta-load-balance dynamic gap-threshold 25 
    [AC-wlan-rrm-prof-loadbalance-dynamic] quit

    # Create the 2G radio profile radio2g and bind the RRM profile loadbalance-dynamic to the 2G radio profile.

    [AC-wlan-view] radio-2g-profile name radio2g 
    [AC-wlan-radio-2g-prof-radio2g] rrm-profile loadbalance-dynamic
    [AC-wlan-radio-2g-prof-radio2g] quit

    # Create the 5G radio profile radio5g and bind the RRM profile loadbalance-dynamic to the 5G radio profile.

    [AC-wlan-view] radio-5g-profile name radio5g 
    [AC-wlan-radio-5g-prof-radio5g] rrm-profile loadbalance-dynamic
    [AC-wlan-radio-5g-prof-radio5g] quit

    # Bind the 5G radio profile radio5g and 2G radio profile radio2g to the AP group guest.

    [AC-wlan-view] ap-group name guest 
    [AC-wlan-ap-group-guest] radio-5g-profile radio5g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-guest] radio-2g-profile radio2g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-guest] quit

    # Bind the 5G radio profile radio5g and 2G radio profile radio2g to the AP group employee.

    [AC-wlan-view] ap-group name employee 
    [AC-wlan-ap-group-employee] radio-5g-profile radio5g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-employee] radio-2g-profile radio2g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-employee] quit

    # Commit the configuration.

    [AC-wlan-view] commit all                                                
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y      

  6. Verify the configuration.

    # Connect STAs to the WLAN with SSID guest and enter the password a1234. Run the display station ssid guest command on the AC. The command output shows that the STAs are connected to the WLAN guest.

    [AC-wlan-view] display station ssid guest
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    a81b-5a06-dc1e   0     area_1   0/1      2.4G  11g   7/44       -50   101   10.10.11.253
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0

    # Connect STAs to the WLAN with SSID employee and enter the password b1234567. Run the display station ssid employee command on the AC. The command output shows that the STAs are connected to the WLAN employee.

    [AC-wlan-view] display station ssid employee
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   1     area_2   0/1      2.4G  11n   36/56      -44   102   10.10.12.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0

    # Run the display rrm-profile name loadbalance-dynamic command on the AC to check the dynamic load balancing configuration.

    [AC-wlan-view] display rrm-profile name loadbalance-dynamic
    ------------------------------------------------------------
    Auto channel select                                    : enable
    Auto transmit power select                             : enable
    PER threshold for trigger channel/power select(%)      : 60
    Airtime fairness schedule                              : disable
    Dynamic adjust EDCA parameter                          : disable
    UAC check client's SNR                                 : disable
    UAC client's SNR threshold(dB)                         : 20
    UAC check client number                                : disable
    UAC client number access threshold                     : 64
    UAC client number roam threshold                       : 64
    UAC check channel utilization                          : disable
    UAC channel utilization access threshold               : 80
    UAC channel utilization roam threshold                 : 80
    UAC hide SSID                                          : disable
    Band steer deny threshold                              : 2
    Band balance start threshold                           : 10
    Band balance gap threshold(%)                          : 20
    Client's band expire based on continuous probe counts  : 35
    Station load balance                                   : enable
    Station load balance start threshold                   : 15
    Station load balance gap threshold(%)                  : 25
    Station load balance deny threshold                    : 3
    Smart-roam                                             : disable
    Smart-roam check SNR                                   : enable
    Smart-roam standing SNR threshold(dB)                  : 20
    Smart-roam SNR quick-kickoff-threshold(dB)             : 0
    Smart-roam check rate                                  : disable
    AMC policy                                             : auto-balance
    Smart-roam rate threshold(%)                           : 20
    Smart-roam rate quick-kickoff-threshold(%)             : 0
    Smart-roam high level SNR margin(dB)                   : 15
    Smart-roam low level SNR margin(dB)                    : 6
    Smart-roam SNR check interval(s)                       : 3
    Smart-roam unable roam client expire time(m)           : 120
    ------------------------------------------------------------

    # Run the display station load-balance sta-mac cc3a-61cf-6344 command on the AC to check AP radios participating in dynamic load balancing.

    [AC-wlan-view] display station load-balance sta-mac cc3a-61cf-6344
    Station load balance status: balance
    ------------------------------------------------------------------------------
    AP name                             Radio ID  
    ------------------------------------------------------------------------------
    area_2                              0
    area_1                              0
    ------------------------------------------------------------------------------
    Total: 2

    # When a new STA requests to connect to AP area_1, the AC uses a dynamic load balancing algorithm to redirect the STA to the AP with a light load according to the information reported by APs.

Configuration Files

  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #                                                                               
    interface Vlanif100                                                              
     ip address 10.10.10.1 255.255.255.0
     dhcp select interface                                           
    #                                                                               
    interface Vlanif101                                                             
     ip address 10.10.11.1 255.255.255.0
     dhcp select interface       
    #                                                                               
    interface Vlanif102                                                             
     ip address 10.10.12.1 255.255.255.0
     dhcp select interface                                               
    #                                                                               
    interface Ethernet2/0/0                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #                                                                               
    interface Ethernet2/0/1                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #
    capwap source interface vlanif100
    #
    wlan ac
     security-profile name guest
      security wep share-key
      wep key 0 wep-40 pass-phrase %^%#z*z]6]#!|%n:n}Xz'mhKE{PfN|cIj*eU$jJYH48S%^%#
     security-profile name employee
      security wpa2 psk pass-phrase %^%#H{1<-b]4~"*+Y:4-'/URy;$+,33UgQf)@9I(Yl]V%^%# aes
     ssid-profile name guest
      ssid guest
     ssid-profile name employee
      ssid employee
     vap-profile name guest
      service-vlan vlan-id 101
      ssid-profile guest
      security-profile guest
     vap-profile name employee
      service-vlan vlan-id 102
      ssid-profile employee
      security-profile employee
     regulatory-domain-profile name domain1
     rrm-profile name loadbalance-dynamic
      sta-load-balance dynamic enable
      sta-load-balance dynamic start-threshold 15
      sta-load-balance dynamic gap-threshold 25
     radio-2g-profile name radio2g
      rrm-profile loadbalance-dynamic
     radio-5g-profile name radio5g
      rrm-profile loadbalance-dynamic
     ap-group name guest
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile guest wlan 1
      radio 1
       radio-5g-profile radio5g
       vap-profile guest wlan 1
      radio 2
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile guest wlan 1
     ap-group name employee
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile employee wlan 1
      radio 1
       radio-5g-profile radio5g
       vap-profile employee wlan 1
      radio 2
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile employee wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group guest
     ap-id 1 type-id 19 ap-mac 60de-4474-9640 ap-sn 210235554710CB000075
      ap-name area_2
      ap-group employee
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100033726

Views: 33902

Downloads: 211

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next