No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - WLAN-AC

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides the concepts, configuration procedures, and configuration examples of WLAN-AC features.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Radio Calibration

Example for Configuring Radio Calibration

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, and WDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 5-9, a large number of APs are deployed in an office building. The APs connect to the AC to provide wireless services for users.

It will be a heavy workload to manually configure radio parameters (such as the channel) for the APs one by one. The enterprise IT department requires that the AC automatically allocate channels to the APs based on radio environments to simplify network deployment.

Figure 5-9  Networking diagram for configuring radio calibration

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the APs, AC, and upper-layer devices to communicate with each other.
  2. Configure the AC as a DHCP server to assign IP addresses to the APs and STAs.
  3. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  4. Configure WLAN service parameters for STAs to access the WLAN.
  5. Configure radio calibration so that the AC can automatically allocate the optimal working channels to the APs.
Table 5-3  Data required for completing the configuration

Item

Data

DHCP server The AC functions as the DHCP server to assign IP addresses to the APs and STAs.
IP address pool for the APs 10.10.10.2-10.10.10.254/24
IP address pool for the STAs

10.10.11.2–10.10.11.254/24

10.10.12.2–10.10.12.254/24

IP address of the AC's source interface VLANIF 100: 10.10.10.1/24
AP group

Name: guest

Referenced profile: VAP profile guest and regulatory domain profile domain1

Name: employee

Referenced profile: VAP profile employee and regulatory domain profile domain1

Regulatory domain profile

Name: domain1

Country code: CN

SSID profile

Name: guest

SSID name: guest

Name: employee

SSID name: employee

Security profile

Name: guest

  • Security policy: WEP-40
  • Password: a1234

Name: employee

  • Security policy: WPA2+PSK+AES
  • Password: b1234567
VAP profile

Name: guest

  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile guest and security profile guest

Name: employee

  • Service VLAN: VLAN 102
  • Referenced profile: SSID profile employee and security profile employee
5G radio profile
  • Name: radio5g
  • Referenced profiles: RRM profile wlan-net and air scan profile wlan-airscan
2G radio profile
  • Name: radio2g
  • Referenced profiles: RRM profile wlan-net and air scan profile wlan-airscan
RRM profile Name: wlan-net
Air scan profile
  • Name: wlan-airscan
  • Air scan channel set: all channels supported by the corresponding country code of an AP
  • Air scan interval: 80000 ms
  • Air scan duration: 80 ms

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
  • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
  • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
  • The management VLAN and service VLAN cannot be configured the same.
  • When multiple VAP profiles are configured and share one service VLAN, enable inter-service VLAN proxy ARP if the data forwarding mode is set to tunnel.

Procedure

  1. Configure the APs to communicate with the AC.

    # Add Eth2/0/0 and Eth2/0/1 to management VLAN 100, service VLAN 101 and service VLAN 102.

    NOTE:

    You are advised to configure port isolation on Eth2/0/0 and Eth2/0/1 that connect the AC to the APs. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    <Huawei> system-view
    [Huawei] sysname AC
    [AC] vlan batch 100 to 102
    [AC] interface ethernet 2/0/0
    [AC-Ethernet2/0/0] port link-type trunk
    [AC-Ethernet2/0/0] port trunk pvid vlan 100
    [AC-Ethernet2/0/0] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/0] port-isolate enable
    [AC-Ethernet2/0/0] quit
    [AC] interface ethernet 2/0/1
    [AC-Ethernet2/0/1] port link-type trunk
    [AC-Ethernet2/0/1] port trunk pvid vlan 100
    [AC-Ethernet2/0/1] port trunk allow-pass vlan 100 to 102
    [AC-Ethernet2/0/1] port-isolate enable
    [AC-Ethernet2/0/1] quit
    

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.10.10.1 255.255.255.0
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.10.11.1 255.255.255.0
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.10.12.1 255.255.255.0
    [AC-Vlanif102] dhcp select interface
    [AC-Vlanif102] quit
    

  3. Configure the APs to go online.

    # Create AP groups guest and employee.

    [AC] wlan ac
    [AC-wlan-view] ap-group name guest
    Info: This operation may take a few seconds. Please wait for a moment..done.
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    Info: This operation may take a few seconds. Please wait for a moment..done.
    [AC-wlan-ap-group-employee] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP groups.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    Info: The current country code is same with the input country code.
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-employee] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the APs offline on the AC. Add APs deployed in the lobby to AP group guest and APs in office areas to AP group employee. Configure names for the APs based on the APs' deployment locations, so that you can know where the APs are deployed from their names. For example, if the AP with MAC address 60de-4476-e360 is deployed in room 1 of the office building, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    [AC] wlan ac
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group guest
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group employee
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-1] quit
    

    # After the APs are powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the APs have gone online.

    [AC-wlan-view] display ap all
    Info: This operation may take a few seconds. Please wait for a moment.done.
    Total AP information:
    nor  : normal          [2]
    --------------------------------------------------------------------------------------------
    ID   MAC            Name   Group    IP           Type            State STA Uptime
    --------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 guest    10.10.10.253 AP6010DN-AGN    nor   0   1M:22S
    1    60de-4474-9640 area_2 employee 10.10.10.254 AP6010DN-AGN    nor   0   5S
    --------------------------------------------------------------------------------------------
    Total: 2

  4. Configure WLAN service parameters.

    # Create security profiles guest and employee and configure the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WEP-40 and WPA2+PSK+AES and passwords to a1234 and b1234567, respectively. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name guest
    [AC-wlan-sec-prof-guest] security wep share-key
    [AC-wlan-sec-prof-guest] wep key 0 wep-40 pass-phrase a1234
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-sec-prof-guest]wep default-key 0
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-sec-prof-guest] quit
    [AC-wlan-view] security-profile name employee
    [AC-wlan-sec-prof-employee] security wpa2 psk pass-phrase b1234567 aes
    [AC-wlan-sec-prof-employee] quit
    

    # Create SSID profiles guest and employee, and set the SSID names to guest and employee, respectively.

    [AC-wlan-view] ssid-profile name guest
    [AC-wlan-ssid-prof-guest] ssid guest
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-guest] quit
    [AC-wlan-view] ssid-profile name employee
    [AC-wlan-ssid-prof-employee] ssid employee
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-employee] quit
    

    # Create VAP profiles guest and employee, set the service VLANs, and apply the security profiles and SSID profiles to the VAP profiles.

    [AC-wlan-view] vap-profile name guest
    [AC-wlan-vap-prof-guest] service-vlan vlan-id 101
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-guest] security-profile guest
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-guest] ssid-profile guest
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-guest] quit
    [AC-wlan-view] vap-profile name employee
    [AC-wlan-vap-prof-employee] service-vlan vlan-id 102
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-employee] security-profile employee
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-employee] ssid-profile employee
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-employee] quit
    

    # Bind VAP profiles to the AP groups and apply the VAP profiles to radio of the APs.

    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] vap-profile guest wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] vap-profile employee wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-employee] quit
    

  5. Configure radio calibration.

    # Create the RRM profile wlan-net and enable automatic channel selection and automatic transmit power selection in the RRM profile. By default, automatic channel selection and automatic transmit power selection are enabled.

    [AC-wlan-view] rrm-profile name wlan-net
    [AC-wlan-rrm-prof-wlan-net] undo calibrate auto-channel-select disable 
    [AC-wlan-rrm-prof-wlan-net] undo calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-wlan-net] quit

    # Create the air scan profile wlan-airscan and configure the scan channel set, scan interval, and scan duration. By default, an air scan channel set contains all channels supported by the corresponding country code of an AP.

    [AC-wlan-view] air-scan-profile name wlan-airscan
    [AC-wlan-air-scan-prof-wlan-airscan] scan-channel-set country-channel
    [AC-wlan-air-scan-prof-wlan-airscan] scan-period 80
    Warning: Modifying the scan parameters may affect services.
    [AC-wlan-air-scan-prof-wlan-airscan] scan-interval 80000
    [AC-wlan-air-scan-prof-wlan-airscan] quit

    # Create the 2G radio profile radio2g and bind the RRM profile wlan-net and air scan profile wlan-airscan to the 2G radio profile.

    [AC-wlan-view] radio-2g-profile name radio2g 
    [AC-wlan-radio-2g-prof-radio2g] rrm-profile wlan-net
    [AC-wlan-radio-2g-prof-radio2g] air-scan-profile wlan-airscan
    [AC-wlan-radio-2g-prof-radio2g] quit

    # Create the 5G radio profile radio5g and bind the RRM profile wlan-net and air scan profile wlan-airscan to the 5G radio profile.

    [AC-wlan-view] radio-5g-profile name radio5g 
    [AC-wlan-radio-5g-prof-radio5g] rrm-profile wlan-net
    [AC-wlan-radio-5g-prof-radio5g] air-scan-profile wlan-airscan
    [AC-wlan-radio-5g-prof-radio5g] quit

    # Bind the 5G radio profile radio5g and 2G radio profile radio2g to the AP group guest.

    [AC-wlan-view] ap-group name guest 
    [AC-wlan-ap-group-guest] radio-5g-profile radio5g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-guest] radio-2g-profile radio2g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-guest] quit

    # Bind the 5G radio profile radio5g and 2G radio profile radio2g to the AP group employee.

    [AC-wlan-view] ap-group name employee 
    [AC-wlan-ap-group-employee] radio-5g-profile radio5g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-employee] radio-2g-profile radio2g radio all
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-employee] quit

    # Set the radio calibration mode to manual and trigger radio calibration. By default, the radio calibration mode is manual.

    [AC-wlan-view] calibrate enable manual
    [AC-wlan-view] calibrate manual startup

    # Commit the configuration.

    [AC-wlan-view] commit all                                                
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y      

  6. Verify the configuration.

    # Connect STAs to the WLAN with SSID guest and enter the password a1234. Run the display station ssid guest command on the AC. The command output shows that the STAs are connected to the WLAN guest.

    [AC-wlan-view] display station ssid guest
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   0     area_1   1/1      5G    11a   54/44      -49   101   10.10.11.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

    # Connect STAs to the WLAN with SSID employee and enter the password b1234567. Run the display station ssid employee command on the AC. The command output shows that the STAs are connected to the WLAN employee.

    [AC-wlan-view] display station ssid employee
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   1     area_2   0/1      2.4G  11n   36/56      -44   102   10.10.12.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0

    # Run the display radio all command on the AC to check radio calibration results.

    [AC-wlan-view] display radio all
    CH/BW:Channel/Bandwidth
    CE:Current EIRP (dBm)
    ME:Max EIRP (dBm)
    CU:Channel utilization
    ST:Status
    ------------------------------------------------------------------------
    AP ID Name    RfID  Band  Type    ST  CH/BW          CE/ME   STA    CU
    ------------------------------------------------------------------------
    0     area_1  0     2.4G  bgn     on  11/20M         27/27   0      25%
    0     area_1  1     5G    an      on  157/20M        28/28   0      0%
    1     area_2  0     2.4G  bgn     on  6/20M          27/27   1      15%
    1     area_2  1     5G    an      on  153/20M        28/28   0      1%
    ------------------------------------------------------------------------
    Total:4
    # Radio calibration stops one hour after the radio calibration is manually triggered. The following configuration steps are not provided in the configuration file. After that, you can perform either of the following configurations:
    • (Recommended) Set the radio calibration mode to scheduled. Configure the APs to perform radio calibration in off-peak hours, for example, between 00:00 am and 06:00 am.

      [AC-wlan-view] calibrate enable schedule time 03:00:00 
    • Manually fix the working channels of APs: disable automatic channel selection and automatic transmit power selection in the RRM profile. Manually trigger radio calibration when new APs are added to the network.

      [AC-wlan-view] rrm-profile name wlan-net
      [AC-wlan-rrm-prof-wlan-net] calibrate auto-channel-select disable 
      [AC-wlan-rrm-prof-wlan-net] calibrate auto-txpower-select disable
      [AC-wlan-rrm-prof-wlan-net] quit
      [AC-wlan-view] calibrate enable manual
      [AC-wlan-view] calibrate manual startup

Configuration Files

  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    #
    dhcp enable
    #                                                                               
    interface Vlanif100                                                              
     ip address 10.10.10.1 255.255.255.0
     dhcp select interface                                           
    #                                                                               
    interface Vlanif101                                                             
     ip address 10.10.11.1 255.255.255.0
     dhcp select interface       
    #                                                                               
    interface Vlanif102                                                             
     ip address 10.10.12.1 255.255.255.0
     dhcp select interface                                               
    #                                                                               
    interface Ethernet2/0/0                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #                                                                               
    interface Ethernet2/0/1                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                                  
     port trunk allow-pass vlan 100 to 102  
     port-isolate enable group 1
    #
    capwap source interface vlanif100
    #
    wlan ac
     calibrate enable manual
     security-profile name guest
      security wep share-key
      wep key 0 wep-40 pass-phrase %^%#G-~GU.v`U$RA7KCajYBCQ6};G#7OVIZ\=9HvBKZ6%^%#
     security-profile name employee
      security wpa2 psk pass-phrase %^%#H{1<-b]4~"*+Y:4-'/URy;$+,33UgQf)@9I(Yl]V%^%# aes
     ssid-profile name guest
      ssid guest
     ssid-profile name employee
      ssid employee
     vap-profile name guest
      service-vlan vlan-id 101
      ssid-profile guest
      security-profile guest
     vap-profile name employee
      service-vlan vlan-id 102
      ssid-profile employee
      security-profile employee
     regulatory-domain-profile name domain1
     air-scan-profile name wlan-airscan
      scan-period 80
      scan-interval 80000 
     rrm-profile name wlan-net
     radio-2g-profile name radio2g
      rrm-profile wlan-net
      air-scan-profile wlan-airscan 
     radio-5g-profile name radio5g
      rrm-profile wlan-net
      air-scan-profile wlan-airscan 
    ap-group name guest
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile guest wlan 1
      radio 1
       radio-5g-profile radio5g
       vap-profile guest wlan 1
      radio 2
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile guest wlan 1
     ap-group name employee
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile employee wlan 1
      radio 1
       radio-5g-profile radio5g
       vap-profile employee wlan 1
      radio 2
       radio-2g-profile radio2g
       radio-5g-profile radio5g
       vap-profile employee wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group guest
     ap-id 1 type-id 19 ap-mac 60de-4474-9640 ap-sn 210235554710CB000075
      ap-name area_2
      ap-group employee
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100033726

Views: 33647

Downloads: 207

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next