No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - WLAN-AC

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides the concepts, configuration procedures, and configuration examples of WLAN-AC features.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring WLAN Services on a Small-Scale Network (IPv4 Network)

Example for Configuring WLAN Services on a Small-Scale Network (IPv4 Network)

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, and WDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 4-35, the AP is directly connected to the AC. An enterprise branch needs to deploy WLAN services for mobile office so that branch users can access the enterprise internal network from anywhere at any time.

The following requirements must be met:
  • A WLAN named wlan-net is available.
  • Branch users are assigned IP addresses on 10.10.11.0/24.
Figure 4-35  Networking diagram of configuring WLAN services on a small-scale network

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Layer 2 connections between the AP, AC, and upstream device.
  2. Configure the AC to function as a DHCP server to assign IP addresses to the STAs and AP.
  3. Configure the AP to go online.
    1. Create an AP group and add the AP to the group. The APs that require the same configuration can be added to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the AP.
    3. Configure the AP authentication mode and import the AP offline so that the AP can go online properly.
  4. Configure WLAN service parameters for STAs to access the WLAN.
Table 4-9  Data planning

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to the STAs and AP.
IP address pool for the AP 10.10.10.2-10.10.10.254/24
IP address pool for STAs 10.10.11.2-10.10.11.254/24
AC's source interface address VLANIF 100: 10.10.10.1/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap and regulatory domain profile domain1
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
  • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
  • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
  • The management VLAN and service VLAN cannot be configured the same.
  • When multiple VAP profiles are configured and share one service VLAN, enable inter-service VLAN proxy ARP if the data forwarding mode is set to tunnel.

Procedure

  1. Connect the AP and AC.

    # Add Eth2/0/0 to management VLAN 100 and service VLAN 101.

    NOTE:

    You are advised to configure port isolation on Eth2/0/0 that connects the AC to the AP. If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    <Huawei> system-view
    [Huawei] sysname AC
    [AC] vlan batch 100 101
    [AC] interface ethernet 2/0/0
    [AC-Ethernet2/0/0] port link-type trunk
    [AC-Ethernet2/0/0] port trunk pvid vlan 100
    [AC-Ethernet2/0/0] port trunk allow-pass vlan 100 101
    [AC-Ethernet2/0/0] port-isolate enable
    [AC-Ethernet2/0/0] quit
    

  2. Configure the AC as a DHCP server to allocate IP addresses to the AP and STAs.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the interface IP address pool on VLANIF 100, and allocate IP addresses to STAs from the interface IP address pool on VLANIF 101.

    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.10.10.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.10.11.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  3. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan ac
    [AC-wlan-view] ap-group name ap-group1
    Info: This operation may take a few seconds. Please wait for a moment.done.
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    Info: The current country code is same with the input country code.
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    [AC] wlan ac
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Info: This operation may take a few seconds. Please wait for a moment.done.
    Total AP information:
    nor  : normal          [1]
    ---------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP           Type            State STA Uptime
    ---------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.10.10.254 AP6010DN-AGN    nor   0   6S
    ---------------------------------------------------------------------------------------------
    Total: 1

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    Info: This operation may take a few seconds, please wait.done.
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio all
    Info: This operation may take a few seconds, please wait..done.
    [AC-wlan-ap-group-ap-group1] quit
    

    # Commit the configuration.

    [AC-wlan-view] commit all                                                
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y      

  5. Verify the configuration.

    # After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    Info: This operation may take a few seconds, please wait.                       
    WID : WLAN ID                                                                   
    --------------------------------------------------------------------------      
    AP ID AP name RfID WID  BSSID          Status  Auth type  STA   SSID            
    --------------------------------------------------------------------------      
    0     area_1  0    1    60DE-4476-E360 ON      WPA2-PSK   0     wlan-net        
    0     area_1  1    1    60DE-4476-E370 ON      WPA2-PSK   0     wlan-net        
    --------------------------------------------------------------------------      
    Total: 2 

    # Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ------------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
    ------------------------------------------------------------------------------------------
    cc3a-61cf-6344   0     area_1   0/1      2.4G  11g   51/44      -55   101   10.10.11.254
    ------------------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0

Configuration Files

  • AC configuration file
    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100                                                             
     ip address 10.10.10.1 255.255.255.0                                            
     dhcp select interface
    #
    interface Vlanif101                                                             
     ip address 10.10.11.1 255.255.255.0                                            
     dhcp select interface
    #
    interface Ethernet2/0/0                                                         
     port link-type trunk                                                           
     port trunk pvid vlan 100                                                       
     port trunk allow-pass vlan 100 to 101                                          
     port-isolate enable group 1
    #
    capwap source interface vlanif100
    #
    wlan ac
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     ap-group name ap-group1                                                        
      regulatory-domain-profile domain1                                             
      radio 0                                                                       
       vap-profile wlan-vap wlan 1                                                  
      radio 1                                                                       
       vap-profile wlan-vap wlan 1                                                  
      radio 2                                                                       
       vap-profile wlan-vap wlan 1                                                  
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042            
      ap-name area_1                                                                
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100033726

Views: 33903

Downloads: 211

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next