No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Interoperation Configuration Guide

AR Router

This document provides cases for connecting AR enterprise routers to devices of other vendors.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring the Router

Configuring the Router

Configuration Roadmap

  1. Configure the enterprise intranet and configure the Router to assign IP addresses to intranet users.
  2. Configure a G.SHDSL interface as the primary interface.
  3. Configure a 3G interface as the backup interface.
  4. Configure default routes of the primary and backup interfaces so that intranet traffic can be transmitted to the Internet through the G.SHDSL and 3G interfaces.

Procedure

  1. Configure the enterprise intranet.

    # Create VLAN 20 and add Ethernet0/0/1 to VLAN 20.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan 20
    [Router-vlan20] quit
    [Router] interface ethernet 0/0/1
    [Router-Ethernet0/0/1] port link-type trunk
    [Router-Ethernet0/0/1] port trunk allow-pass vlan 20
    [Router-Ethernet0/0/1] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool pool_voce
    [Router-ip-pool-pool_voce] network 192.168.2.0 mask 255.255.255.0
    [Router-ip-pool-pool_voce] gateway-list 192.168.2.1
    [Router-ip-pool-pool_voce] dns-list 192.168.2.1
    [Router-ip-pool-pool_voce] quit

    # Assign IP addresses from the global address pool to users connected to VLANIF 20.

    [Router] interface vlanif 20
    [Router-Vlanif20] ip address 192.168.2.1 255.255.255.0
    [Router-Vlanif20] dhcp select global
    [Router-Vlanif20] quit

    # Configure allowed data flows in the enterprise intranet.

    [Router] acl number 2001
    [Router-acl-basic-2001] rule permit source 192.168.2.0 0.0.0.255
    [Router-acl-basic-2001] quit
    [Router] acl number 2002
    [Router-acl-basic-2002] rule permit source 192.168.0.0 0.0.0.255
    [Router-acl-basic-2002] quit

  2. Configure the G.SHDSL interface as the primary interface to connect to the Internet.

    # Set the transfer mode of the G.SHDSL interface to PTM.

    [Router] set workmode slot 1 shdsl ptm
    Info: Changing the working mode will reset the board in slot 1. Continue? [y/n]:
    y                                                                               
    INFO: Resetting board[1] succeeded. 

    # Deactivate Ethernet1/0/0 and Ethernet1/0/1.

    [Router] interface ethernet 1/0/0
    [Router-Ethernet1/0/0] shutdown
    [Router-Ethernet1/0/0] quit
    [Router] interface ethernet 1/0/1
    [Router-Ethernet1/0/1] shutdown
    [Router-Ethernet1/0/1] quit

    # Configure the G.SHDSL to work in CPE (client) mode (the default mode).

    # Bind the G.SHDSL interface to Ethernet1/0/0 and Ethernet1/0/1 in EFM mode. The number of the first interface to be bound must be 0 or 2.
    [Router] interface ethernet 1/0/0
    [Router-Ethernet1/0/0] shdsl bind efm 2

    # Set the modulation mode of the G.SHDSL interface to 16 PAM. The default modulation mode is auto, and the 16 PAM mode can be automatically delivered based on the modulation mode of the remote end.

    [Router-Ethernet1/0/0] shdsl pam 16

    # Activate Ethernet1/0/0 and Ethernet1/0/1.

    [Router-Ethernet1/0/0] undo shutdown
    [Router-Ethernet1/0/0] quit
    [Router] interface ethernet 1/0/1
    [Router-Ethernet1/0/1] undo shutdown
    [Router-Ethernet1/0/1] quit

    # Configure IP addresses for G.SHDSL sub-interfaces.

    [Router] interface ethernet 1/0/0.1035
    [Router-Ethernet1/0/0.1035] ip address 10.0.0.2 24
    [Router-Ethernet1/0/0.1035] dot1q termination vid 1035
    [Router-Ethernet1/0/0.1035] discard srr
    [Router-Ethernet1/0/0.1035] nat outbound 2001
    [Router-Ethernet1/0/0.1035] quit
    [Router] interface ethernet 1/0/0.1036
    [Router-Ethernet1/0/0.1036] ip address 10.0.0.3 25
    [Router-Ethernet1/0/0.1036] dot1q termination vid 1036
    [Router-Ethernet1/0/0.1036] discard srr
    [Router-Ethernet1/0/0.1036] nat outbound 2002
    [Router-Ethernet1/0/0.1036] quit

  3. Configure the 3G interface as the backup interface to connect to the 3G network.

    # Configure C-DCC for the dial-up connection.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate
    [Router-Cellular0/0/0] ppp ipcp dns request
    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] dialer-group 1
    [Router-Cellular0/0/0] dialer number *99#
    [Router-Cellular0/0/0] nat outbound 2002
    [Router-Cellular0/0/0] quit

    # Configure an NQA test instance.

    [Router] nqa test-instance user test
    [Router-nqa-user-test] test-type icmp
    [Router-nqa-user-test] destination-address ipv4 10.0.0.1
    [Router-nqa-user-test] probe-failtimes 5
    [Router-nqa-user-test] fail-percent 33
    [Router-nqa-user-test] frequency 35
    [Router-nqa-user-test] interval seconds 2
    [Router-nqa-user-test] timeout 2
    [Router-nqa-user-test] probe-count 15
    [Router-nqa-user-test] start now
    [Router-nqa-user-test] quit

    # Configure association between interface backup and NQA on the backup interface.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] standby track nqa user test
    [Router-Cellular0/0/0] standby timer delay 20 65
    [Router-Cellular0/0/0] quit

  4. Configure two default routes.

    [Router] ip route-static 0.0.0.0 0.0.0.0 10.0.0.1 track nqa voice wan_connected_check
    [Router] ip route-static 0.0.0.0 0.0.0.0 cellular 0/0/0 preference 100

Translation
Download
Updated: 2019-05-17

Document ID: EDOC1100034005

Views: 21081

Downloads: 445

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next