No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a BGP Confederation

Example for Configuring a BGP Confederation

Networking Requirements

As shown in Figure 9-34, there are multiple BGP routers in AS 200. It is required that the number of IBGP connections be reduced.

Figure 9-34 Networking diagram of configuring the confederation

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a BGP confederation on each router in AS 200 to divide AS 200 into three sub-ASs: AS 65001, AS 65002, and AS 65003. Three routers in AS 65001 establish full-mesh IBGP connections to reduce the number of IBGP connections.

Procedure

  1. Configure an IP address to each interface.

    # Configure IP addresses for all interfaces of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 0/0/1
    [RouterA-GigabitEthernet0/0/1] ip address 10.1.4.1 255.255.255.0
    [RouterA-GigabitEthernet0/0/1] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 200.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet3/0/0] quit
    [RouterA] interface gigabitethernet 4/0/0
    [RouterA-GigabitEthernet4/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet4/0/0] quit

    The configurations of RouterB, RouterC, RouterD, RouterE and RouterF are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure the BGP confederation.

    # Configure Router A.

    [RouterA] bgp 65001
    [RouterA-bgp] router-id 1.1.1.1
    [RouterA-bgp] confederation id 200
    [RouterA-bgp] confederation peer-as 65002 65003
    [RouterA-bgp] peer 10.1.1.2 as-number 65002 
    [RouterA-bgp] peer 10.1.2.2 as-number 65003
    [RouterA-bgp] ipv4-family unicast
    [RouterA-bgp-af-ipv4] peer 10.1.1.2 next-hop-local
    [RouterA-bgp-af-ipv4] peer 10.1.2.2 next-hop-local
    [RouterA-bgp-af-ipv4] quit

    # Configure Router B.

    [RouterB] bgp 65002
    [RouterB-bgp] router-id 2.2.2.2
    [RouterB-bgp] confederation id 200
    [RouterB-bgp] confederation peer-as 65001
    [RouterB-bgp] peer 10.1.1.1 as-number 65001
    [RouterB-bgp] quit

    # Configure Router C.

    [RouterC] bgp 65003
    [RouterC-bgp] router-id 3.3.3.3
    [RouterC-bgp] confederation id 200
    [RouterC-bgp] confederation peer-as 65001
    [RouterC-bgp] peer 10.1.2.1 as-number 65001
    [RouterC-bgp] quit

  3. Configure IBGP connections inside AS 65001.

    # Configure Router A.

    [RouterA] bgp 65001
    [RouterA-bgp] peer 10.1.3.2 as-number 65001
    [RouterA-bgp] peer 10.1.4.2 as-number 65001
    [RouterA-bgp] ipv4-family unicast
    [RouterA-bgp-af-ipv4] peer 10.1.3.2 next-hop-local
    [RouterA-bgp-af-ipv4] peer 10.1.4.2 next-hop-local
    [RouterA-bgp-af-ipv4] quit 

    # Configure Router D.

    [RouterD] bgp 65001
    [RouterD-bgp] router-id 4.4.4.4
    [RouterD-bgp] confederation id 200
    [RouterD-bgp] peer 10.1.3.1 as-number 65001
    [RouterD-bgp] peer 10.1.5.2 as-number 65001 
    [RouterD-bgp] quit

    # Configure Router E.

    [RouterE] bgp 65001
    [RouterE-bgp] router-id 5.5.5.5
    [RouterE-bgp] confederation id 200
    [RouterE-bgp] peer 10.1.4.1 as-number 65001
    [RouterE-bgp] peer 10.1.5.1 as-number 65001
    [RouterE-bgp] quit

  4. Configure the EBGP connection between AS 100 and AS 200.

    # Configure Router A.

    [RouterA] bgp 65001
    [RouterA-bgp] peer 200.1.1.2 as-number 100 
    [RouterA-bgp] quit

    # Configure Router F.

    [RouterF] bgp 100
    [RouterF-bgp] router-id 6.6.6.6
    [RouterF-bgp] peer 200.1.1.1 as-number 200 
    [RouterF-bgp] ipv4-family unicast
    [RouterF-bgp-af-ipv4] network 9.1.1.0 255.255.255.0
    [RouterF-bgp-af-ipv4] quit

  5. Verify the configuration.

    # Check the routing table of Router B.

    [RouterB] display bgp routing-table
    
    
    
    
     BGP Local router ID is 2.2.2.2
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
    
    
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
    
     *>i  9.1.1.0/24         10.1.1.1        0          100        0      (65001) 100i
    [RouterB] display bgp routing-table 9.1.1.0
    
    
    BGP local router ID : 2.2.2.2
     Local AS number : 65002
     Paths:   1 available, 1 best, 1 select
     BGP routing table entry information of 9.1.1.0/24:
     From: 10.1.1.1 (1.1.1.1)
     Route Duration: 00h12m29s
     Relay IP Nexthop: 0.0.0.0
     Relay IP Out-Interface: GigabitEthernet1/0/0
     Original nexthop: 10.1.1.1
     Qos information : 0x0
     AS-path (65001) 100, origin igp, MED 0, localpref 100, pref-val 0, valid, external-confed, best, select, active, pre 255
     Not advertised to any peer yet
    
    

    # Check the BGP routing table of Router D.

    [RouterD] display bgp routing-table
    
    
     BGP Local router ID is 4.4.4.4
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
    
    
     Total Number of Routes: 1
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
    
     *>i  9.1.1.0/24         10.1.3.1        0          100        0      100i
    [RouterD] display bgp routing-table 9.1.1.0
    
    
    BGP local router ID : 4.4.4.4
     Local AS number : 65001
     Paths:   1 available, 1 best, 1 select
     BGP routing table entry information of 9.1.1.0/24:
     From: 10.1.3.1 (1.1.1.1)
     Route Duration: 00h23m57s
     Relay IP Nexthop: 0.0.0.0
     Relay IP Out-Interface: GigabitEthernet1/0/0
     Original nexthop: 10.1.3.1
     Qos information : 0x0
     AS-path 100, origin igp, MED 0, localpref 100, pref-val 0, valid, internal-confed, best, select, active, pre 255
     Not advertised to any peer yet

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    interface GigabitEthernet0/0/1
     ip address 10.1.4.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     ip address 200.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet4/0/0
     ip address 10.1.3.1 255.255.255.0
    #
    bgp 65001
     router-id 1.1.1.1
     confederation id 200
     confederation peer-as 65002 65003
     peer 200.1.1.2 as-number 100
     peer 10.1.1.2 as-number 65002
     peer 10.1.2.2 as-number 65003
     peer 10.1.3.2 as-number 65001
     peer 10.1.4.2 as-number 65001
     #
     ipv4-family unicast
      undo synchronization
      peer 200.1.1.2 enable
      peer 10.1.1.2 enable
      peer 10.1.1.2 next-hop-local
      peer 10.1.2.2 enable
      peer 10.1.2.2 next-hop-local
      peer 10.1.3.2 enable
      peer 10.1.3.2 next-hop-local
      peer 10.1.4.2 enable
      peer 10.1.4.2 next-hop-local
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    bgp 65002
     router-id 2.2.2.2
     confederation id 200
     confederation peer-as 65001
     peer 10.1.1.1 as-number 65001
     #
     ipv4-family unicast
      undo synchronization
      peer 10.1.1.1 enable
    #
    return
    NOTE:

    The configuration file of Router C is similar to that of Router B, and is not mentioned here.

  • Configuration file of Router D

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.3.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.5.1 255.255.255.0
    #
    bgp 65001
     router-id 4.4.4.4
     confederation id 200
     peer 10.1.3.1 as-number 65001
     peer 10.1.5.2 as-number 65001
     #
     ipv4-family unicast
      undo synchronization
      peer 10.1.3.1 enable
      peer 10.1.5.2 enable
    #
    return
    NOTE:

    The configuration file of Router E is similar to that of Router D, and is not mentioned here.

  • Configuration file of Router F

    #
     sysname RouterF
    #
    interface GigabitEthernet1/0/0
     ip address 200.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 9.1.1.1 255.255.255.0
    #
    bgp 100
     router-id 6.6.6.6
     peer 200.1.1.1 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 9.1.1.0 255.255.255.0
      peer 200.1.1.1 enable
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034072

Views: 111037

Downloads: 163

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next