No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an OSPF NSSA

Example for Configuring an OSPF NSSA

Networking Requirements

Stub areas and NSSAs are described as follows:

Stub area

  • Does not transmit external routes from other areas.
  • Does not transmit AS external routes imported by ASBRs.

Type 5 LSAs are not transmitted in stub areas.

NSSA

  • Does not transmit external routes from other areas.

  • Transmits AS external routes imported by ASBRs.

    Type 7 LSAs generated by ASBRs in an NSSA are transmitted only within the NSSA. After receiving the Type 7 LSAs, ABRs in the NSSA translate them into Type 5 LSAs to advertise external routes to other areas on the OSPF network.

Configuring an area as an NSSA prevents a large number of external routes from consuming the bandwidth and storage resources of the router.

In Figure 5-39, OSPF runs on all routers, and the entire AS is partitioned into two areas. Router A and Router B function as ABRs to forward inter-area routes; Router C and Router D function as ASBRs and import external static routes 10.0.0.0/8 and 20.0.0.0/8. To import AS external routes but reduce the number of LSAs to be advertised to area 1 without affecting route reachability, configure area 1 as an NSSA and configure Router A as an LSA translator in the NSSA.

Figure 5-39 Networking for configuring an OSPF NSSA

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable OSPF and configure basic OSPF functions on each router
  2. Configure Area 1 as an NSSA.
  3. Configure Router D to import the static route 10.0.0.0/8.
  4. Configure Router C to import the static route 20.0.0.0/8.
  5. Configure Router A as an LSA translator in the NSSA.
  6. Disable Type 3 LSA advertisement to the NSSA to reduce the routing table size.

Data Preparation

To complete the configuration, you need the following data:

  • Router ID 1.1.1.1 of Router A; OSPF process ID 1; network segment 192.168.0.0/24 of area 0; network segments 192.168.1.0/24 and 192.168.3.0/24 of Area 1
  • Router ID 2.2.2.2 of Router B; OSPF process ID 1; network segment 192.168.2.0/24 of area 0; network segments 192.168.1.0/24 and 192.168.4.0/24 of Area 1
  • Router ID 3.3.3.3 of Router C; OSPF process ID 1; network segments 192.168.0.0/24 and 192.168.2.0/24 of area 0
  • Router ID 4.4.4.4 of Router D; OSPF process ID 1; network segments 192.168.3.0/24 and 192.168.4.0/24 of Area 1

Procedure

  1. Configure an IP address for each interface.

    Assign an IP address to each interface according to Figure 5-39. For configuration details, see "Configuration Files" in this section.

  2. Configure basic OSPF functions.

    Configuring Basic OSPF Functions shows how to configure basic OSPF functions. For details about the configuration, see Configuration Files in this section.

  3. Configure Router C to import the static route 20.0.0.0/8.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] ip route-static 20.0.0.0 8 null 0
    [RouterC] ospf 1
    [RouterC-ospf-1] import-route static
    [RouterC-ospf-1] quit

  4. Configure Router D to import the static route 10.0.0.0/8.

    [RouterD] ip route-static 10.0.0.0 8 null 0
    [RouterD] ospf 1
    [RouterD-ospf-1] import-route static
    [RouterD-ospf-1] quit

    # Display the OSPF routing table of Router C.

    [RouterC] display ospf routing
    
              OSPF Process 1 with Router ID 3.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2     3.3.3.3         0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     3.3.3.3         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     10.0.0.0/8         1         Type2      1           192.168.0.1     2.2.2.2
     
     Total Nets: 7
     Intra Area: 2  Inter Area: 4  ASE: 1  NSSA: 0
    
    

    After an NSSA is configured, the OSPF routing table of RouterRouter C contains the AS external static route 10.0.0.0/8 imported by Router D.

    # Display the OSPF routing table of Router D.

    [RouterD] display ospf routing
    
              OSPF Process 1 with Router ID 4.4.4.4
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.3.0/24     1     Transit    192.168.3.2     4.4.4.4         0.0.0.1
     192.168.4.0/24     1     Transit    192.168.4.1     4.4.4.4         0.0.0.1
     192.168.0.0/24     2     Inter-area 192.168.3.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.4.2     2.2.2.2         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.3.1     2.2.2.2         0.0.0.1
     192.168.2.0/24     2     Inter-area 192.168.4.2     2.2.2.2         0.0.0.1
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     20.0.0.0/8         1         Type2      1           192.168.3.1     1.1.1.1
    
     Total Nets: 7
     Intra Area: 2  Inter Area: 4  ASE: 1  NSSA: 0
    
    

    After an NSSA is configured, the OSPF routing table of Router D contains the AS external static route 20.0.0.0/8 imported by Router C.

  5. Configure Area 1 as an NSSA.

    # Configure Router A.

    [RouterA] ospf 1
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] nssa

    # Configure Router B.

    [RouterB] ospf 1
    [RouterB-ospf-1] area 1
    [RouterB-ospf-1-area-0.0.0.1] nssa

    # Configure Router D.

    [RouterD] ospf 1
    [RouterD-ospf-1] area 1
    [RouterD-ospf-1-area-0.0.0.1] nssa
    NOTE:

    NSSA attributes must be configured on all routers in the NSSA using the nssa command.

    # Display the OSPF routing table of Router C.

    [RouterC] display ospf routing
    
              OSPF Process 1 with Router ID 3.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2     3.3.3.3         0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     3.3.3.3         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     10.0.0.0/8         1         Type2      1           192.168.0.1     2.2.2.2
     
     Total Nets: 7
     Intra Area: 2  Inter Area: 4  ASE: 1  NSSA: 0
    
    

    After an NSSA is configured, the OSPF routing table of Router C still contains the AS external static route 10.0.0.0/8 imported by Router D, indicating that the NSSA can transmit AS external routes imported by ASBRs.

    The AdvRouter field shows that the router ID of the advertiser is 2.2.2.2. Router B functions as the LSA translator in the NSSA because OSPF selects the ABR with the largest router ID as an LSA translator by default.

    # Display the OSPF routing table of Router D.

    [RouterD] display ospf routing
    
              OSPF Process 1 with Router ID 4.4.4.4
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.3.0/24     1     Transit    192.168.3.2     4.4.4.4         0.0.0.1
     192.168.4.0/24     1     Transit    192.168.4.1     4.4.4.4         0.0.0.1
     192.168.0.0/24     2     Inter-area 192.168.3.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.4.2     2.2.2.2         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.3.1     2.2.2.2         0.0.0.1
     192.168.2.0/24     2     Inter-area 192.168.4.2     2.2.2.2         0.0.0.1
    
     Routing for NSSAs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     0.0.0.0/0          1         Type2      1           192.168.4.2     2.2.2.2
     0.0.0.0/0          1         Type2      1           192.168.3.1     1.1.1.1
    
     Total Nets: 8
     Intra Area: 4  Inter Area: 2  ASE: 0  NSSA: 2
    
    

    After an NSSA is configured, the OSPF routing table of Router D does not contain the AS external static route 20.0.0.0/8 imported by Router C, indicating that the NSSA cannot transmit external routes from other areas.

  6. Configure Router A as an LSA translator in the NSSA.

    [RouterA] ospf 1
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] nssa default-route-advertise translator-always

    # Display the OSPF routing table of Router C.

    [RouterC] display ospf routing
    
              OSPF Process 1 with Router ID 3.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2     3.3.3.3         0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     3.3.3.3         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.0.1     1.1.1.1         0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     2.2.2.2         0.0.0.0
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     10.0.0.0/8         1         Type2      1           192.168.0.1     1.1.1.1
    
     Total Nets: 7
     Intra Area: 2  Inter Area: 4  ASE: 1  NSSA: 0
    
    

    The AdvRouter field shows that the router ID of the advertiser has become 1.1.1.1, indicating that Router A functions an LSA translator in the NSSA.

  7. Disable Type 3 LSA advertisement to the NSSA.

    # Display the OSPF routing table of Router D.

    [RouterD] display ospf routing
    
              OSPF Process 1 with Router ID 4.4.4.4
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.3.0/24     1     Transit    192.168.3.2     4.4.4.4         0.0.0.1
     192.168.4.0/24     1     Transit    192.168.4.1     4.4.4.4         0.0.0.1
     192.168.0.0/24     2     Inter-area 192.168.3.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.4.2     2.2.2.2         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.3.1     2.2.2.2         0.0.0.1
     192.168.2.0/24     2     Inter-area 192.168.4.2     2.2.2.2         0.0.0.1
    
     Routing for NSSAs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     0.0.0.0/0          1         Type2      1           192.168.4.2     2.2.2.2
     0.0.0.0/0          1         Type2      1           192.168.3.1     1.1.1.1
    
     Total Nets: 8
     Intra Area: 4  Inter Area: 2  ASE: 0  NSSA: 2
    
    

    # Disable Type 3 LSA advertisement to the NSSA to reduce the routing table size.

    [RouterA] ospf
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] nssa default-route-advertise no-summary
    NOTE:

    Configuring the no-summary parameter may result in route flapping.

  8. Verify the configuration.

    # Display the OSPF routing table of Router D.

    [RouterD] display ospf routing
    
              OSPF Process 1 with Router ID 4.4.4.4
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.3.0/24     1     Transit    192.168.3.2     4.4.4.4         0.0.0.1
     192.168.4.0/24     1     Transit    192.168.4.1     4.4.4.4         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.4.2     2.2.2.2         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.3.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.4.2     2.2.2.2         0.0.0.1
     192.168.1.0/24     2     Transit    192.168.3.1     2.2.2.2         0.0.0.1
     
     Total Nets: 6
     Intra Area: 4  Inter Area: 2  ASE: 0  NSSA: 0
    
    

    The command output shows that ABRs no longer transmit Type 3 LSAs to the NSSA and that the routing table size is reduced.

Configuration Files

  • Router A configuration file

    #
     sysname RouterA
    #
    router id 1.1.1.1
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      nssa default-route-advertise translator-always
      nssa default-route-advertise no-summary
    #
    return
  • Router B configuration file

    #
     sysname RouterB
    #
    router id 2.2.2.2
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 192.168.4.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      nssa
    #
    return
  • Router C configuration file

    #
     sysname RouterC
    #
    router id 3.3.3.3
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    ospf 1
     import-route static
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    ip route-static 20.0.0.0 255.0.0.0 NULL0
    #
    return
  • Router D configuration file

    #
     sysname RouterD
    #
    router id 4.4.4.4
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.3.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.1 255.255.255.0
    #
    ospf 1
     import-route static
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      nssa
    #
    ip route-static 10.0.0.0 255.0.0.0 NULL0
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034072

Views: 109369

Downloads: 155

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next