No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BFD for BGP4+

Example for Configuring BFD for BGP4+

After BFD for BGP4+ is configured, BFD can fast detect the fault on the link between BGP4+ peers and notify it to BGP4+ so that service traffic can be transmitted through the backup link.

Networking Requirements

  • As shown in Figure 9-41, Router A belongs to AS 100, Router B to AS 200, and Router C to AS 200. Establish an EBGP connection between Router A and Router B and that between Router A and Router C.

  • Traffic is transmitted on the active link Router A → Router B. The link Router A → Router C → Router B acts as the standby link.

  • Use BFD to detect the BGP session between Router A and Router B. When the link between Router A and Router B fails, BFD can rapidly detect the failure and notify BGP of the failure. Traffic is transmitted on the standby link.

Figure 9-41 Networking diagram of configuring BFD for BGP4+

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the basic BGP4+ functions on each router.

  2. Configure MED attributes to control the routing selection of the routers.

  3. Enable the BFD on Router A and Router B.

Procedure

  1. Assign an IPv6 address to each interface.

    The detailed configuration is not mentioned here.

  2. Configure the basic BGP4+ functions. Establish an EBGP connection between Router A and Router B, that between Router A and Router C. Establish an IBGP connection between Router B and Router C.

    # Configure Router A.

    [RouterA] bgp 100
    [RouterA-bgp] router-id 1.1.1.1
    [RouterA-bgp] peer 2001:db8:8::2 as-number 200
    [RouterA-bgp] peer 2001:db8:10::2 as-number 200
    [RouterA-bgp] ipv6-family unicast
    [RouterA-bgp-af-ipv6] peer 2001:db8:8::2 enable
    [RouterA-bgp-af-ipv6] peer 2001:db8:10::2 enable
    [RouterA-bgp-af-ipv6] quit
    [RouterA-bgp] quit

    # Configure Router B.

    [RouterB] bgp 200
    [RouterB-bgp] router-id 2.2.2.2
    [RouterB-bgp] peer 2001:db8:8::1 as-number 100
    [RouterB-bgp] peer 2001:db8:9::1:2 as-number 200
    [RouterB-bgp] ipv6-family unicast
    [RouterB-bgp-af-ipv6] peer 2001:db8:8::1 enable
    [RouterB-bgp-af-ipv6] peer 2001:db8:9::1:2 enable
    [RouterB-bgp-af-ipv6] network 2001:db8:7::1 64
    [RouterB-bgp-af-ipv6] quit
    [RouterB-bgp] quit

    # Configure Router C.

    [Routerc] bgp 200
    [Routerc-bgp] router-id 3.3.3.3
    [Routerc-bgp] peer 2001:db8:10::1 as-number 100
    [Routerc-bgp] peer 2001:db8:9::1:1 as-number 200
    [RouterC-bgp] ipv6-family unicast
    [RouterC-bgp-af-ipv6] peer 2001:db8:10::1 enable
    [RouterC-bgp-af-ipv6] peer 2001:db8:9::1:1 enable
    [RouterC-bgp-af-ipv6] quit
    [RouterC-bgp] quit

    # Display the established BGP neighbors on Router A.

    [RouterA] display bgp ipv6 peer
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 2                 Peers in established state : 2
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      2001:db8:8::2   4         200       12       11     0 00:07:26 Established   0
      2001:db8:10::2  4         200       12       12     0 00:07:21 Established   0

  3. Configure MED attributes.

    Set the value of MED sent by Router B and Router C to Router A by using the policy.

    # Configure Router B.

    [RouterB] route-policy 10 permit node 10
    [RouterB-route-policy] apply cost 100
    [RouterB-route-policy] quit
    [RouterB] bgp 200
    [RouterB-bgp] ipv6-family unicast
    [RouterB-bgp-af-ipv6] peer 2001:db8:8::1 route-policy 10 export
    [RouterB-bgp-af-ipv6] quit
    [RouterB-bgp] quit

    # Configure Router C.

    [RouterC] route-policy 10 permit node 10
    [RouterC-route-policy] apply cost 150
    [RouterC-route-policy] quit
    [RouterC] bgp 200
    [RouterC-bgp] ipv6-family unicast
    [RouterC-bgp-af-ipv6] peer 2001:db8:10::1 route-policy 10 export
    [RouterC-bgp-af-ipv6] quit
    [RouterC-bgp] quit

    # Display all BGP routing information on Router A.

    [RouterA] display bgp ipv6 routing-table
    
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 2
     *>  Network  : 2001:db8:7::                                 PrefixLen : 64
         NextHop  : 2001:db8:8::2                                LocPrf    :
         MED      : 100                                      PrefVal   : 0
         Label    :
         Path/Ogn : 200  i
     *
         NextHop  : 2001:db8:10::2                                LocPrf    :
         MED      : 150                                      PrefVal   : 0
         Label    :
         Path/Ogn : 200  i

    As shown in the BGP routing table, the next hop address of the route to 2001:db8:7::1/64 is 2001:db8:8::2 and traffic is transmitted on the active link Router A → Router B.

  4. Configure the BFD detection function, the interval for sending the packets, the interval for receiving the packets, and the local detection time multiple.

    # Enable BFD on Router A, set the minimum interval for sending the packets and the minimum interval for receiving the packets to 100 ms, and set the local detection time multiple to 4.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bgp 100
    [RouterA-bgp] peer 2001:db8:8::2 bfd enable
    [RouterA-bgp] peer 2001:db8:8::2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [RouterA-bgp] quit

    # Enable BFD on Router B, set the minimum interval for sending the packets and the minimum interval for receiving the packets to 100 ms, and set the local detection time multiple to 4.

    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] bgp 200
    [RouterB-bgp] peer 2001:db8:8::1 bfd enable
    [RouterB-bgp] peer 2001:db8:8::1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [RouterB-bgp] quit

    # Display all BFD sessions set up by BGP on Router A.

    [RouterA] display bgp ipv6 bfd session all
      Local_Address  : 2001:db8:8::1
      Peer_Address   : 2001:db8:8::2
      Tx-interval(ms): 100         Rx-interval(ms): 100
      Multiplier     : 4           Interface      : GigabitEthernet1/0/0
      LD/RD          : 8192/8192   Session-State  : Up
      Wtr-interval(m):0
    

  5. Verify the Configuration.

    # Run the shutdown command on GE 2/0/0 of Router B to simulate the active link failure.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-Gigabitethernet2/0/0] shutdown

  6. # Display the routing table on Router A.

    [RouterA] display bgp ipv6 routing-table
    
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
     Total Number of Routes: 1
     *>  Network  : 2001:db8:7::                             PrefixLen : 64
         NextHop  : 2001:db8:10::2                           LocPrf    :
         MED      : 150                                      PrefVal   : 0
         Label    :
         Path/Ogn : 200  i

    As shown in the BGP routing table, the standby link Router A → Router C → Router B takes effect after the active link fails. The next hop address of the route to 2001:db8:7::1/64 becomes 2001:db8:10::2.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
     ipv6
    #
     bfd
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:8::1/64
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:10::1/64
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 100
     router-id 1.1.1.1
     peer 2001:db8:8::2 as-number 200
     peer 2001:db8:8::2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 2001:db8:8::2 bfd enable
     peer 2001:db8:10::2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      peer 2001:db8:8::2 enable
      peer 2001:db8:10::2 enable
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
     sysname RouterB
    #
     ipv6
    #
     bfd
    #
    interface interface GigabitEthernet2/0/0
     shutdown
     ipv6 enable
     ipv6 address 2001:db8:8::2/64
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:9::1:1/64
    #
    interface GigabitEthernet3/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:7::1/64
    #
    interface NULL0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 200
     router-id 2.2.2.2
     peer 2001:db8:8::1 as-number 100
     peer 2001:db8:8::1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 2001:db8:8::1 bfd enable
     peer 2001:db8:9::1:2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network 2001:db8:7:: 64
      peer 2001:db8:8::1 enable
      peer 2001:db8:8::1 route-policy 10 export
      peer 2001:db8:9::1:2 enable
    #
    route-policy 10 permit node 10
     apply cost 100
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
     ipv6
    #
    interface interface GigabitEthernet1/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:9::1:2/64
    #
    interface interface GigabitEthernet2/0/0
     undo shutdown
     ipv6 enable
     ipv6 address 2001:db8:10::2/64
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 200
     router-id 3.3.3.3
     peer 2001:db8:9::1:1 as-number 200
     peer 2001:db8:10::1 as-number 100
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      peer 2001:db8:9::1:1 enable
      peer 2001:db8:10::1 enable
      peer 2001:db8:10::1 route-policy 10 export
    #
    route-policy 10 permit node 10
     apply cost 150
    #
    return
Translation
Download
Updated: 2019-08-12

Document ID: EDOC1100034072

Views: 121098

Downloads: 180

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next