No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic OSPF Functions

Example for Configuring Basic OSPF Functions

Networking Requirements

As shown in Figure 5-35, all routers run OSPF, and the entire AS is divided into three areas. Router A and Router B serve as ABRs to forward routes between areas.

After the configuration, each router should learn the routes from the AS to all network segments.

Figure 5-35 Networking diagram of configuring basic OSPF functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable OSPF on each router.

  2. Specify network segments in different areas.

Procedure

  1. Configure an IP address for each interface.

    # Configure RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.0.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit

    The configurations of RouterB, RouterC, RouterD, RouterE, and RouterF are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure basic OSPF functions.

    # Configure Router A.

    [RouterA] router id 1.1.1.1
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.1] quit
    [RouterA-ospf-1] quit

    # Configure Router B.

    [RouterB] router id 2.2.2.2
    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] area 2
    [RouterB-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.2] quit
    [RouterB-ospf-1] quit

    # Configure Router C.

    [RouterC] router id 3.3.3.3
    [RouterC] ospf
    [RouterC-ospf-1] area 1
    [RouterC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] quit
    [RouterC-ospf-1] quit

    # Configure Router D.

    [RouterD] router id 4.4.4.4
    [RouterD] ospf
    [RouterD-ospf-1] area 2
    [RouterD-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.2] quit
    [RouterD-ospf-1] quit

    # Configure Router E.

    [RouterE] router id 5.5.5.5
    [RouterE] ospf
    [RouterE-ospf-1] area 1
    [RouterE-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
    [RouterE-ospf-1-area-0.0.0.1] quit
    [RouterE-ospf-1] quit

    # Configure Router F.

    [RouterF] router id 6.6.6.6
    [RouterF] ospf
    [RouterF-ospf-1] area 2
    [RouterF-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
    [RouterF-ospf-1-area-0.0.0.2] quit
    [RouterF-ospf-1] quit

  3. Verify the configuration.

    # View OSPF neighbors of Router A.

    [RouterA] display ospf peer
              OSPF Process 1 with Router ID 1.1.1.1
                      Neighbors
     Area 0.0.0.0 interface 192.168.0.1(GigabitEthernet1/0/0)'s neighbors
    Router ID: 2.2.2.2      Address: 192.168.0.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.0.2  BDR: 192.168.0.1   MTU: 0
       Dead timer due in 36  sec
       Retrans timer interval: 5
       Neighbor is up for 00:15:04
       Authentication Sequence: [ 0 ]
                      Neighbors
     Area 0.0.0.1 interface 192.168.1.1(GigabitEthernet2/0/0)'s neighbors
    Router ID: 3.3.3.3       Address: 192.168.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.1.2  BDR: 192.168.1.1   MTU: 0
       Dead timer due in 39  sec
       Retrans timer interval: 5
       Neighbor is up for 00:07:32
       Authentication Sequence: [ 0 ]
    

    # View the OSPF routing information of Router A.

    [RouterA] display ospf routing
              OSPF Process 1 with Router ID 1.1.1.1
                       Routing Tables
     Routing for Network
     Destination      Cost  Type         NextHop         AdvRouter       Area
     172.16.1.0/24     2    Transit     192.168.1.2     3.3.3.3         0.0.0.1
     172.17.1.0/24     3    Inter-area  192.168.0.2     2.2.2.2         0.0.0.0
     192.168.0.0/24    1    Transit     192.168.0.1     1.1.1.1         0.0.0.0
     192.168.1.0/24    1    Transit     192.168.1.1     1.1.1.1         0.0.0.1
     192.168.2.0/24    2    Inter-area  192.168.0.2     2.2.2.2         0.0.0.0
     Total Nets: 5
     Intra Area: 3  Inter Area: 2  ASE: 0  NSSA: 0

    # View the LSDB of Router A.

    [RouterA] display ospf lsdb
              OSPF Process 1 with Router ID 1.1.1.1
                      Link State Database
                              Area: 0.0.0.0
     Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    2.2.2.2         2.2.2.2            317  48    80000003    1
     Router    1.1.1.1         1.1.1.1            316  48    80000002    1
     Network   192.168.0.2     2.2.2.2            399  32    800000F8    0
     Sum-Net   172.16.1.0      1.1.1.1            250  28    80000001    2
     Sum-Net   172.17.1.0      2.2.2.2            203  28    80000001    2
     Sum-Net   192.168.2.0     2.2.2.2            237  28    80000002    1
     Sum-Net   192.168.1.0     1.1.1.1            295  28    80000002    1
                              Area: 0.0.0.1
    Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric
     Router    5.5.5.5         5.5.5.5            214  36    80000004    1        
     Router    3.3.3.3         3.3.3.3            217  60    80000008    1
     Router    1.1.1.1         1.1.1.1            289  48    80000002    1
     Network   192.168.1.1     1.1.1.1            202  28    80000002    0
     Network   172.16.1.1      3.3.3.3            670  32    80000001    0
     Sum-Net   172.17.1.0      1.1.1.1            202  28    80000001    3
     Sum-Net   192.168.2.0     1.1.1.1            242  28    80000001    2
     Sum-Net   192.168.0.0     1.1.1.1            300  28    80000001    1

    # View the routing table of Router D and test connectivity by using the ping command.

    [RouterD] display ospf routing
              OSPF Process 1 with Router ID 4.4.4.4
                       Routing Tables
     Routing for Network
     Destination        Cost  Type       NextHop      AdvRouter       Area
     172.16.1.0/24      4  Inter-area 192.168.2.1     2.2.2.2         0.0.0.2
     172.17.1.0/24      1  Transit    172.17.1.1      4.4.4.4         0.0.0.2
     192.168.0.0/24     2  Inter-area 192.168.2.1     2.2.2.2         0.0.0.2
     192.168.1.0/24     3  Inter-area 192.168.2.1     2.2.2.2         0.0.0.2
     192.168.2.0/24     1  Transit    192.168.2.2     4.4.4.4         0.0.0.2
     Total Nets: 5
     Intra Area: 2  Inter Area: 3  ASE: 0  NSSA: 0
    [RouterD] ping 172.16.1.1
      PING 172.16.1.1: 56  data bytes, press CTRL_C to break
        Reply from 172.16.1.1: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 172.16.1.1: bytes=56 Sequence=2 ttl=253 time=16 ms
        Reply from 172.16.1.1: bytes=56 Sequence=3 ttl=253 time=62 ms
        Reply from 172.16.1.1: bytes=56 Sequence=4 ttl=253 time=94 ms
        Reply from 172.16.1.1: bytes=56 Sequence=5 ttl=253 time=63 ms
      --- 172.16.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    router id 1.1.1.1
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    router id 2.2.2.2
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.2
      network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    router id 3.3.3.3
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
    #
    return
  • Configuration file of Router D

    #
     sysname RouterD
    #
    router id 4.4.4.4
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.2
      network 192.168.2.0 0.0.0.255
      network 172.17.1.0 0.0.0.255
    #
    return
  • Configuration file of Router E

    #
     sysname RouterE
    #
    router id 5.5.5.5
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.1
      network 172.16.1.0 0.0.0.255
    #
    return
    
  • Configuration file of Router F

    #
     sysname RouterF
    #
    router id 6.6.6.6
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.2
      network 172.17.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034072

Views: 110044

Downloads: 160

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next