No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Applying a Routing Policy for Importing Routes

Example for Applying a Routing Policy for Importing Routes

Networking Requirements

In Figure 10-5, Router B exchanges routing information with Router A through OSPF, and with Router C through IS-IS. A user wants Router B to import IS-IS routes into the OSPF network. The user also wants the route to 172.17.1.0/24 on the OSPF network to have a low preference and the route to 172.17.2.0/24 to have a tag, making it easy to reference by a routing policy.

Figure 10-5 Networking diagram for applying a routing policy for importing routes

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing policy on Router B, set the cost of the route to 172.17.1.0/24 to 100, and apply the routing policy when OSPF imports IS-IS routes. The routing policy allows the route to 172.17.1.0/24 to have a low preference.

  2. Configure a routing policy on Router B, set the tag of the route to 172.17.2.0/24 to 20, and apply the routing policy when OSPF imports IS-IS routes. This allows the tag of the route to 172.17.2.0/24 to take effect, making it easy to reference by a routing policy.

Procedure

  1. Assign an IP address to each interface.

    # Configure IP addresses for all interfaces of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit

    The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure IS-IS.

    # Configure Router C.

    [RouterC] isis
    [RouterC-isis-1] is-level level-2
    [RouterC-isis-1] network-entity 10.0000.0000.0001.00
    [RouterC-isis-1] quit
    [RouterC] interface gigabitethernet 4/0/0
    [RouterC-GigabitEthernet4/0/0] isis enable
    [RouterC-GigabitEthernet4/0/0] quit
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] isis enable
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] isis enable
    [RouterC-GigabitEthernet2/0/0] quit
    [RouterC] interface gigabitethernet 3/0/0
    [RouterC-GigabitEthernet3/0/0] isis enable
    [RouterC-GigabitEthernet3/0/0] quit

    # Configure Router B.

    [RouterB] isis
    [RouterB-isis-1] is-level level-2
    [RouterB-isis-1] network-entity 10.0000.0000.0002.00
    [RouterB-isis-1] quit
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] isis enable
    [RouterB-GigabitEthernet2/0/0] quit

  3. Configure OSPF and import routes.

    # Configure RouterA and enable OSPF.

    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

    # Configure RouterB. Enable OSPF and import IS-IS routes.

    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] import-route isis 1
    [RouterB-ospf-1] quit

    # Check the OSPF routing table of RouterA. You can see the imported routes.

    [RouterA] display ospf routing
    
    
              OSPF Process 1 with Router ID 192.168.1.1
                       Routing Tables
    
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1  Stub       192.168.1.1     192.168.1.1     0.0.0.0
    
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     172.17.1.0/24      1        Type2      1           192.168.1.2     192.168.1.2
     172.17.2.0/24      1        Type2      1           192.168.1.2     192.168.1.2
     172.17.3.0/24      1        Type2      1           192.168.1.2     192.168.1.2
     192.168.2.0/24     1        Type2      1           192.168.1.2     192.168.1.2
    
    
     Total Nets: 5
     Intra Area: 1  Inter Area: 0  ASE: 4  NSSA: 0

  4. Configure the filtering list.

    # Configure ACL 2002 to match 172.17.2.0/24.

    [RouterB] acl number 2002
    [RouterB-acl-basic-2002] rule permit source 172.17.2.0 0.0.0.255
    [RouterB-acl-basic-2002] quit

    # Configure the IP prefix list named prefix-a to match 172.17.1.0/24.

    [RouterB] ip ip-prefix prefix-a index 10 permit 172.17.1.0 24

  5. Configure the route-policy.

    [RouterB] route-policy isis2ospf permit node 10
    [RouterB-route-policy] if-match ip-prefix prefix-a
    [RouterB-route-policy] apply cost 100
    [RouterB-route-policy] quit
    [RouterB] route-policy isis2ospf permit node 20
    [RouterB-route-policy] if-match acl 2002
    [RouterB-route-policy] apply tag 20
    [RouterB-route-policy] quit
    [RouterB] route-policy isis2ospf permit node 30
    [RouterB-route-policy] quit

  6. Apply the route-policy when the route is imported.

    # Configure Router B and apply the route-policy when the route is imported.

    [RouterB] ospf
    [RouterB-ospf-1] import-route isis 1 route-policy isis2ospf
    [RouterB-ospf-1] quit

    # Check the OSPF routing table of Router A. You can see that the cost of the route with the destination address 172.17.1.0/24 is 100; the tag of the route with the destination address 172.17.2.0/24 is 20; other routing attributes remain unchanged.

    [RouterA] display ospf routing
    
    
              OSPF Process 1 with Router ID 192.168.1.1
                       Routing Tables
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1  Stub       192.168.1.1     192.168.1.1     0.0.0.0
    
    
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     172.17.1.0/24      100      Type2      1           192.168.1.2     192.168.1.2
     172.17.2.0/24      1        Type2      20          192.168.1.2     192.168.1.2
     172.17.3.0/24      1        Type2      1           192.168.1.2     192.168.1.2
     192.168.2.0/24     1        Type2      1           192.168.1.2     192.168.1.2
    
    
     Total Nets: 5
     Intra Area: 1  Inter Area: 0  ASE: 4  NSSA: 0

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • Configuration file of RouterB

    #
     sysname RouterB
    #
    acl number 2002
     rule 5 permit source 172.17.2.0 0.0.0.255
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.2 255.255.255.0
     isis enable 1
    #
    ospf 1
     import-route isis 1 route-policy isis2ospf
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    route-policy isis2ospf permit node 10
     if-match ip-prefix prefix-a
     apply cost 100
    #
    route-policy isis2ospf permit node 20
     if-match acl 2002
     apply tag 20
    #
    route-policy isis2ospf permit node 30
    #
    ip ip-prefix prefix-a index 10 permit 172.17.1.0 24
    #
    return
  • Configuration file of RouterC

    #
     sysname RouterC
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     ip address 172.17.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.2.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet3/0/0
     ip address 172.17.3.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet4/0/0
     ip address 192.168.2.1 255.255.255.0
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034072

Views: 110750

Downloads: 160

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next