No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between NQA and Ethernet Interface Backup in Active/Standby Mode

Example for Configuring Association Between NQA and Ethernet Interface Backup in Active/Standby Mode

Networking Requirements

As shown in Figure 2-17, the link RouterA->RouterB->RouterD is the primary link and the link RouterA->RouterC->RouterD is the backup link.

Devices are required to monitor the primary link status. When the primary link is faulty, the backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-17  Networking diagram of association between interface backup and NQA

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a static route to ensure connectivity at the network layer.

  2. Configure an NQA test instance on RouterA to monitor the primary link status.

  3. Configure association between interface backup and NQA on backup interface GE2/0/0 of RouterA. When the NQA test instance monitors the primary link status, traffic can be rapidly switched to the backup interface.

  4. Configure an NQA test instance of ICMP on RouterD and configure association between interface backup and NQA on GE2/0/0. When the NQA test instance detects the primary link fault, traffic can be rapidly switched to the backup link. This ensures that traffic sent from RouterA to RouterD and traffic sent from RouterD to RouterA use the same route.

Procedure

  1. Configure connectivity at the network layer.

    # Assign an IP address to each interface. Use RouterA as an example.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit

    # On RouterA, configure static routes to RouterD's interfaces on 10.1.4.0/24 and 10.1.5.0/24.

    [RouterA] ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 80
    [RouterA] ip route-static 10.1.5.0 255.255.255.0 10.1.3.2 preference 60

    # On RouterD, configure static routes to RouterA's interfaces on 10.1.2.0/24 and 10.1.3.0/24.

    [RouterD] ip route-static 10.1.2.0 255.255.255.0 10.1.4.1 preference 80
    [RouterD] ip route-static 10.1.3.0 255.255.255.0 10.1.5.1 preference 60

  2. Configure an NQA test instance on RouterA.

    # Configure the ICMP NQA test instance on RouterA.

    [RouterA] nqa test-instance user test
    [RouterA-nqa-user-test] test-type icmp
    [RouterA-nqa-user-test] destination-address ipv4 10.1.4.2
    [RouterA-nqa-user-test] frequency 10
    [RouterA-nqa-user-test] probe-count 2
    [RouterA-nqa-user-test] start now
    [RouterA-nqa-user-test] quit

  3. Configure association between interface backup and NQA on backup interface GE2/0/0 of RouterA.

    [RouterA] interface gigabitethernet2/0/0
    [RouterA-GigabitEthernet2/0/0] standby track nqa user test
    [RouterA-GigabitEthernet2/0/0] quit

  4. Configure an NQA test instance on RouterD and configure association between interface backup and NQA.

    [RouterD] nqa test-instance admin test
    [RouterD-nqa-admin-test] test-type icmp
    [RouterD-nqa-admin-test] destination-address ipv4 10.1.2.1
    [RouterD-nqa-admin-test] frequency 10
    [RouterD-nqa-admin-test] probe-count 2
    [RouterD-nqa-admin-test] start now
    [RouterD-nqa-admin-test] quit
    [RouterD] interface gigabitethernet 2/0/0
    [RouterD-GigabitEthernet2/0/0] standby track nqa admin test
    [RouterD-GigabitEthernet2/0/0] quit

  5. Verify the configuration.

    Run the display nqa results test-instance user test command. The command output shows that the NQA test instance status is success.

    [RouterA] display nqa results test-instance user test
    NQA entry(user, test) :testflag is active ,testtype is icmp
      1 .Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       Destination ip address:10.1.4.2
       Min/Max/Average Completion Time: 60/90/80
       Sum/Square-Sum  Completion Time: 240/19800
       Last Good Probe Time: 2011-04-19 16:38:38.7
       Lost packet ratio: 0 %        

    # View the NQA test instance status and backup interface status on RouterA. The command output shows that the NQA test instance status is OK and the status of GigabitEthernet2/0/0 is STANDBY.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                       
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          OK                
                                     GigabitEthernet2/0/0         STANDBY           
    

    Run the shutdown command on GE2/0/0 of RouterB to simulate a link fault. Run the display nqa results test-instance user test command on RouterA. The command output shows that the NQA test instance status is failed.

    [RouterA] display nqa results test-instance user test
    NQA entry(user, test) :testflag is active ,testtype is icmp
      1 .Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 0               
       Completion:failed                    RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:3                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Stats errors number:0               
       Destination ip address:10.1.4.2                                              
       Min/Max/Average Completion Time: 0/0/0                                       
       Sum/Square-Sum  Completion Time: 0/0                                         
       Last Good Probe Time: 0000-00-00 00:00:00.0                                  
       Lost packet ratio: 100 %    

    Run the display standby state command on RouterA. The command output shows that the NQA test instance status is ERR, and the status of backup interface GigabitEthernet2/0/0 is UP, indicating that the backup interface is started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                       
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          ERR                
                                     GigabitEthernet2/0/0         UP           
    
    

    Run the undo shutdown command on GE2/0/0 of RouterB. After GE2/0/0 goes to Up, and run the display standby state command on RouterA. The command output shows that the NQA test instance status is OK and backup interface GigabitEthernet2/0/0 switches to the standby state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          OK                
                                     GigabitEthernet2/0/0         STANDBY           
    

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.3.1 255.255.255.0
     standby track nqa user test
    #
     ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 80
     ip route-static 10.1.5.0 255.255.255.0 10.1.3.2
    #
     nqa test-instance user test
     test-type icmp
     destination-address ipv4 10.1.4.2
     frequency 10
     probe-count 2
     start now
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    interface GigabitEthernet1/0/0
      ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.4.1 255.255.255.0
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.3.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.1 255.255.255.0
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.4.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.2 255.255.255.0
     standby track nqa admin test
    #
     ip route-static 10.1.2.0 255.255.255.0 10.1.4.1 preference 80
     ip route-static 10.1.3.0 255.255.255.0 10.1.5.1
    #
     nqa test-instance admin test
     test-type icmp
     destination-address ipv4 10.1.2.1
     frequency 10
     probe-count 2
     start now
    #
    return
Translation
Download
Updated: 2019-08-12

Document ID: EDOC1100034076

Views: 56908

Downloads: 107

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next